Question about 2001 Mitsubishi Montero

3 Answers

Delay in starting the car

Whenever I start my Mistsubishi Montero 2001 limited 6G74 3.5l automatic the full model, there is a delay before the engine starts sometimes 2 to 3 minutes.
what could be the problem?
oxygen sensor, injectors , inhibitor swtich are ok (new)
is it the cooling temperature sensor? the igniter? the ignitor swtich or any switch or relay?
help
Dadoune

Posted by on

  • danickav3 Mar 03, 2009

    the car does that all the time (delay in starting) not on cold start only . I turn on the key and there is a delay with no noise while trying to start, just a delay and it start. Sometimes I have to keep my foot on the gas (accelerator) so it can stay (alive) running.

×

3 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 744 Answers

Hi the major problem is due to the single spade type connector going to a switch.. By means of a throttle pulley disconnected it and ur problem will be solved very simple... The switch must have gone bad...

thnk u!!!

Posted on Mar 03, 2009

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 3,037 Answers

Sounds like the fuel pump relay going bad or the fuel pump itself possibly by the sounds of it. Have a look at both of these and let me know what you or a mechanic finds when checking these.

Benjamin

Posted on Mar 03, 2009

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Mitsubishi Master
  • 19,396 Answers

Check the air intake temperature sensor.

Posted on Mar 03, 2009

  • Ginko
    Ginko Mar 03, 2009

    Your Montero has an air intake temperature sensor that tells the temp of the air coming to the engine to the electronic injection module, in the air intake is obstructed, or the sensor is dirty or faulty, then the car will have problems on cold start.
    Check the air intake and the air filter , and eventually replace the air intake temp sensor.




  • Ginko
    Ginko Mar 03, 2009

    If you turn on the key, and there is a delay with no noise, then you hear the starting motor kicking in, then your starter selenoid, neutral safety switch or your ignition switch is bad.

    The most likely is that the starter solenoid is bad.

    I suggest
    replacing the whole starter.
    If the starter selenoid is defective, then the starter motor usually also fails soon afterward.

    Sometimes the same fault can also be caused by a faulty ingnition.
    To test the ignition switch you just jump the
    start wire from ignition to battery, possible using a remote switch, so not to risk causing further damage.


×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Oil leak in 2001 mitsubishi montero sport


could be from a number of places have the engine thoroughly cleaned and then look for fresh oil drips starting at highest point of engine working way down

Apr 02, 2014 | 2001 Mitsubishi Montero Sport 4WD

1 Answer

Citroen troubleshooting


I had similar problems 2 times with the automatic heat / AC module.
I suppose your system is automatic too.

First time the commands were working erratically acting weird. Sometimes was heating at full capacity blowing heads off. At other times it was not starting at all.
The whole module had to be replaced.

Second time if the car stayed in the sun the AC was heating, after starting the engine and cooling started only after achieving greater speeds (above ~60km/h). Whenever the speed decreased the system began to heat again eventually. It turned out that the engine cooling fan was broken and had to be replaced. That fan cools both the engine radiator and the AC radiator. If it is faulty your engine might be at risk of overheating at low speeds.

Mar 26, 2014 | 2001 Citroen Xsara

1 Answer

Blaring horn non stop of 2001 mitsubishi montero limited


Do you have an antitheft system? If disarm it. If not you may have an electrical issue

Dec 21, 2012 | 2001 Mitsubishi Montero

1 Answer

2001 montero limited randomly wont start after setting a while starts fine


Check your gas cap and fuel pump. If you can start it after loosening the cap and putting it back on, your fuel pump is starting to die. It can't pull the gas out of the tank. When you release the cap, you let air in and release the vacuum in the tank.

Dec 13, 2012 | 2001 Mitsubishi Montero

1 Answer

Windshield Washer Pump Works But No Fluid Flow


May be the resevoir bottle may have something stuck in it, you are right, you may have a clogged line. Also check the routing of the hoses to the squirt that they are not pinched or kinked. Any washer fuild leaking anywhere?

Mar 13, 2010 | 1998 Mitsubishi Montero Sport

3 Answers

2001 Mitsubishi Montero Limited. 122k miles.


2003 Mitsubishi Montero Limited. 97k miles. Temp gauge is erratic when actual temp is normal. How do I fix this?

Nov 13, 2009 | 2001 Mitsubishi Montero

2 Answers

Serpertine belt installation on a 6g74 engine


5bd0a0e.gif
Accessory serpentine belt routing-3.5L engine

Nov 03, 2009 | 2001 Mitsubishi Montero

2 Answers

STARTING WITH DELAY ANYTIME


mcdevito75 here, It could be slow fuel delivery to the engine, Have your shop change the gas filter and check the fuel pump pressure.

Mar 02, 2009 | 2001 Mitsubishi Montero

Not finding what you are looking for?
2001 Mitsubishi Montero Logo

Related Topics:

1,058 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

yadayada
yadayada

Level 3 Expert

70387 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6880 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...