Question about 1995 Chevrolet K1500

1 Answer

4l60e not shifting correctly

I have a 1995 Chevrolet K1500 Z71 with a 4L60E. i have recently discovered that it will idle high and shift late and shift really hard when it does, and then will not shift into overdrive, the weird part about this is that it will not happen all the time just maybe every other time i drive it. please help me if you can. thanks

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 4,669 Answers

Do you have a check engine light coming on? Sounds like trans temp sensor. Have it scanned, it is an electrical issue to the transmission.

Posted on Mar 02, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

4l60e 1995 gmc k1500 transmission seems to shift fine but when shifting voltage drops to around 10 then back to 14 after shift.


Make sure your body to engine ground is good. If you can't find it add a flat flexible battery strap to a bolt on the frame and the other end to a bolt on the engine.

Oct 24, 2016 | 1995 Chevrolet K1500

1 Answer

Trans not shifting properly


Having the same issue in my th350 most likely you don't have proper vacuum or you kickdown is stuck. Check for vaccum lines and let me know what you find

Aug 29, 2012 | 1995 Chevrolet Blazer

1 Answer

1995 gmc sierra 1500 automatic transmission idles fast, and late shifts


Do you have a service engine light on? If so the first thing to do would be to check for what codes may be stored.
You can also check for vacuum leaks. A good place for a leak is the TB base gasket. Those start to leak and give a fast idle.
As for the late shifts, just about all you can do is check fluid level. The shifts are computer controled. 93+ trucks have the 4L60E. Not even a TV cable to check adjustment on.
Fix the fast idle and the late shifts issue may go away.

Oct 05, 2011 | 1995 GMC Sierra C1500

1 Answer

Will a 700r4 work in my silverado that has a 4l60e if not what has to be done to make it work


the 4l60e is an electronic 700r4 it will work and shift but you will always have a check engine light on because computer will see no communication with trans mission. there is no way of overcoming this. I would recommend finding the correct transmission to install might cost a little more now but save a lot of aggravation later

Mar 02, 2011 | 1995 Chevrolet K1500

1 Answer

I have a 1995 K1500 4x4 with a 4l60e with 206,000 it shifts ok but it feels like its slipping in 3rd i don't know when the fluid and filter were changed last if ever also when it shifts into 2nd & 3rd...


I would change the filter and fluid and go from there. sounds like it might be starving for oil but if you can change it yourself and see how dirty the pan is inside with clutch dust or filings. there usually is a magnet in the pan to catch the filings debris be sure to clean it off also nice to know how it is wearing between oil changes

May 26, 2010 | 1995 Chevrolet K1500

1 Answer

ENGINE IDLEING VERY HIGH IN PARK, WHEN IN GEAR TRANS DOSE NOT SHIFT GEARS


sounds like two problems 1 engine can idle high with vaccum leaks or bad idle air control or maf sensor 2 if trans wont shift in to gear fluid first next would be to tcm or wire connection on trans good luck

Dec 30, 2009 | 1993 Chevrolet K1500

2 Answers

1995 Chevy S10. The transmission (4L60E) has been


HI YOU MAY HAVE A BAD IGNITION SWITCH OR YEST A BAD SHIFT SOLENOID 3-4

Jun 25, 2009 | 1995 Chevrolet S-10 CA Edition

1 Answer

4L60E won't shift to 3rd on 1995 Chevy Astro 2wd


do the pin point tests, these start witjh running a trouble code test, autozone and kragen will do this for free, if u haven't had the trans apart then cross out any crossed wiring issues, but I do think you will find a problem with the 2-3 shift solenoid, either the solenoid has failed or the connector has a problem on the outside of the trans.

Feb 25, 2009 | 1995 Chevrolet Astro

Not finding what you are looking for?
1995 Chevrolet K1500 Logo

607 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

61249 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...