Question about 1999 GMC Jimmy

1 Answer

Sputtering when at half throttle.....

When the truck warms up to normal runnig temperatures the sputtering starts. it backfires and losses power.... What would be the problem??? Someone said it could be the PCM failing...

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,055 Answers

Coil could be getting hot and braking down and also the timing chain could be streched

Posted on Mar 01, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why is my car sputtering and losing power after it warms up?


How long since a tune-up? Any applicable trouble codes? If temp related, check the coolant temp sensor. Check your throttle position sensor. Don't replace anything unless your testing points in that direction.

Oct 09, 2016 | 2000 Pontiac Sunfire

1 Answer

2000 Pontiac Montana that starts and runs fine for 7-12 min then looses throttle power. Sputters at 1k-2k for 10-15 min then runs fine for 7-15 min then runs even worse, wills sputter at 750+ rpm.


3.4L Engine Sensor Location Pictures and Comments

www.greatautohelp.com/sensor-location/3400-Sensor-Comments-2.html
the battery for a few minutes to see if that helped. ... If the gauge is at half way on the first start, then yes, either the ... All of a sudden I could not accelerate and the carelost power. ... But once the temperature gauge goes to normal it will run fine. ... 3-7-12. I replaced head gaskets and intake gaskets on my 2000 Pontiac 3.4L

[PDF]2000 Pontiac Montana Owners Manual - GM Extended ...


Nov 28, 2015 | 2000 Pontiac Montana

1 Answer

Yesterday my 94 bird ran great. this morning it is hesitant, boggs down when throttle is pressed, and sounds as if it backfires. When i give it enough gas to make the tires lay rubber all it does is ****...


Do you have a check engine light lit ? Did you let it warm to normal operating temperature, If you do does it still running poorly ? You should have it hook up to a diagnostic tool to see what sensor or sensors is out of specification ! Could have coolant temp. , mass air , throttle position sensor , problem !

Mar 23, 2015 | 1994 Ford Thunderbird

1 Answer

Have a 95 tacoma run normal when cold starts sputtering when warm


Don't know if this will help or not. I had a 1991 Camry that ran fine until it got warm. Would sputter and stall. I cleaned and messed with the throttle body adjustment until it ran OK. Can't remember what I did but there was some sort of adjustment on the throttle body. Good luck.

Jul 08, 2014 | 1995 Toyota Tacoma

1 Answer

Loss of power upon take off


What year is the car and is the check engine light on ?

Feb 16, 2014 | Lincoln Town Car Cars & Trucks

1 Answer

1999 dodge ram 5.2 runs about thirty miles then stalls after running fine just suddenly loses all power sputters backfires engine stumbling badly. crank it up 4 or 5 hours later runs a little then same...


General advice:After warming up track the problem:sparkplugs (even new can have the ceramic parts broken/cracked /wiring (after warming up the isolation get's soft,can loose spark power)/ignition coil(s) (gets hot,stop runnig),running reach,fuel pump/fuel pump relay.Best guess:fuel pump mallfunction (low pressure) related,fuel filter cloged/water in the fuel/fuel line cloged/chipped. Cheers,hope u figure it out,let the people know.

Oct 26, 2013 | 1994 Dodge Ram

1 Answer

1990 dodge 360. Runs fine. unpredictable backfire


You want to check your timing for accuracy and then check all plug wires for burned or cracked ends. Also check the single coil tower where the coilwire connects for very small cracks. Then check the inside of the disrtibutor cap for the same small cracks. Throughout this process I'm certain you'll find the culprit. Thanks, Dana

Jan 30, 2010 | 1990 Dodge W250

2 Answers

97 jeep wrangler 2.5 auto, backfire and loss of power on warm day


COULD BE DIFFERENT THINGS BUT I RECOMEND TO HAVE IT CHECK WITH A GOOD SCANNER TO FIND OUT TROUBLE CODES BEFORE BEGIN SPENDING MONEY

Sep 24, 2009 | 1998 Jeep Wrangler

2 Answers

5.3 chevy hesitates when cold runs fine after warming up


what is the fuel pressure reading, sounds like low fuel pressure, you should have 60 PSI at idle and more when you throttle the engine up about 65 PSI, it should NEVER go down.

Aug 14, 2009 | 1999 Chevrolet Silverado 1500

Not finding what you are looking for?
1999 GMC Jimmy Logo

Related Topics:

169 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

70365 Answers

Freddy

Level 3 Expert

1311 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...