Question about 1999 Ford F250 Regular Cab

1 Answer

Heater run when key is in the off position

The truck runs fine if your on it but if you run highway speed it acks like its missing something wrong like I said it heater and the passenger air bag light and sometimes flash little bet and I dont know what it is help pls and thanks

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Ford Master
  • 21,949 Answers

Please re write in queens english,little bit lost with this one as to what the fault is,must go er indoors moaning that iam on here and not making her a tea.lets all become fundamentalist muslims and cover women up with a burka and only permit them to speak when spoken too.or they face a flogging or evan better a good stoning

Posted on Feb 28, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why does my truck run fine at Highway speed and rattle real bad when I come to a stop


Sounds like you have a misfire in the engine. Do you have a check engine light on?

May 22, 2016 | Cars & Trucks

1 Answer

Car runs perfect then starts missing real bad then stalls


Not unusual for fuel pumps to begin to fail once they are heated up from running. First thing in the morning pump is cool, then as you drive, it heats up and begins to lose pressure. After sitting a 1/2hr-1hr, it may start again and run fine for a short time and start to act up again. Had similar problem and found good fuel pressure when tank and pump cool, but lost pressure once vehicle driven a distance and pump heated up. The hotter the weather, the shorter the distance I could drive. If you can somehow set it up to have fuel pressure checked when it starts to act up, that would certainly help confirm if fuel pressure is the culprit.

Jan 10, 2013 | 1996 Dodge Stratus

1 Answer

2004 Silverado 4.3 V6 Has miss on cylinders 2 and 4. Have done complete tune up Plugs Wires Cap Rotor,Fuel Filter. Still had Miss. Compression on all 6 within 8 lbs of each other. lowest reading 168...


Check engine light on? Any codes? Missed before and after the cap was changed? Or is the cap new so you assume its good. I have had caps bad out of the box.

May 29, 2011 | Chevrolet C1500 Cars & Trucks

1 Answer

Engine misses/hesitates on low speeds. Runs fine


is the check engine light on? have you ever serviced the injectors? if not try that first because there are many things that give the symptoms you spoke of. but this is the cheapest.
vbninja E.A.P

Jul 23, 2010 | 2005 Cadillac CTS

2 Answers

W/cruise engaged, engine seems to miss and run roughly


Its probably a problem with the cruise vacuum hose.......maybe blocked a little or the vacuum seal leaking a little. Trace the vacuum hose through to the engine area.

Jul 20, 2010 | 2001 Dodge Ram 1500 Truck 2WD

3 Answers

Truck idles fine all the time. However, on the


did you change the wires?..and cap?...could also be a bad coil

Mar 09, 2010 | 1996 Chevrolet K1500

1 Answer

Heater blower won't turn off


most likely a blower resister which should be located under the passenger compartment

Nov 28, 2008 | 1997 Ford Thunderbird LX

Not finding what you are looking for?
1999 Ford F250 Regular Cab Logo

65 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

61249 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...