Question about 1999 Oldsmobile Alero

1 Answer

99 oldsmobile alero

While in park car idles rough,changed plugs,boots the whole nine,drove car for about 3 miles still no power. Parked car smelled something burning,looked under car to see the converter red hot,does this mean that the converter is shot?

Posted by on

  • Anonymous Feb 28, 2009

    yea i have the same but i replaced engine and cat and its still doing the same thing

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

I would get the car in to a mechanic right away. Sounds like the converter might be plugged. This has been known to cause car fires.

Posted on Feb 27, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why does my 1999 Oldsmobile alero runs rough when the track off light is on


1999 Oldsmobile Alero Stumble and Loss of Power 3000rpm

www.2carpros.com/.../oldsmobile-alero-1999-oldsmobile-alero-stumble-...
Sep 28, 2008 - Engine Performance problem 1999 Oldsmobile Alero 6 cyl Front ... Hey All, Had a very rough running Mazda 626 on LPG, engine code FP.

1999 Oldsmobile Alero High Idle Fix - YouTube

? 1:47
www.youtube.com/watch?v=xBV9BmjFZVs
Jul 4, 2010 - Uploaded by GrindTimeAuto
1999 Oldsmobile Alero High Idle Fix ... How To Fix Or Prevent Stalling, Surging Or Rough Idle, Cleaning Throttle Body and MAF Sensor ...

Feb 17, 2015 | 1999 Oldsmobile Alero

1 Answer

My 99 Oldsmobile Alero started sputtering with and heater hose near firewall was leaking coolant Pulled over then half hour later drove back to house with no problems then car is parked and sputters when...


with the heater hose leaking and the engine missing I suspect an overheated engine from loss of coolant or pressure . It may be a blocked filter but I would expect a constant loss of power at rpm's.

Apr 21, 2014 | Cars & Trucks

1 Answer

Will not Start after running two days


Try pulling engine codes , possible crank sensor.

Feb 04, 2014 | 1987 Oldsmobile Toronado

1 Answer

87 Olds Toronado put new gas tank, brake lines, plugs, gas filter, drove over a hundred miles(started to sound like a miss on the way back)and parked it for the night. Got in the next morning drove a


Since it is an older vehicle, check under the dash for any "rigging" that might have been done over the years. Start at the battery and follow all electrical wires that lead into the dashboard and fuse panels and check for any frayed or split lines that might be causing you to have a short circuit somewhere. that's what it sounds like to me. Unless you have a huge sound system with some 15" woofers in the trunk you shouldn't be experiencing any power shortages.

Feb 04, 2014 | 1987 Oldsmobile Toronado

1 Answer

My 99 alero GL runs great...85,000


COULD BE GROUND PROBLEMS OR THE TACH GOING BAD.EVEN THOUGH CAR SEEMS TO BE RUNNING GOOD IDLING GOOD.SOME TIMES A SPARK PLUG MISFIRE.CAUSING A LITTLE ROUGH IDLING CAUSING TACH NEEDLE TO GO CRAZY.I SEEN ALTERNATOR WITH VOLTAGE REGULATOR GOING BAD CAUSE A POWER SURGE CAUSING HEAD LIGHTS TO DIM A LITTLE THEN BRIGHT WHILE ENGINE IDLING.THIS WILL CAUSE TACH METER NEEDLE BOUNCE AROUND ALSO.

Apr 03, 2010 | 1999 Oldsmobile Alero

1 Answer

Running roug at low idle, smooths out at 2500 rpms


change plug and wire if its been a while most cars have 90000 miles platinum plugs in them.but the wires wear before plugs.so change plugs and wires.+clean fuel injectors .change fuel filter and air filter.if car still run rough your idling to low.have idling check .

Jun 06, 2009 | 2001 Oldsmobile Alero

1 Answer

2000 Alero hard to start


I had this problem with my 1999 alero i took it apart and investigated it myself because i have been a mechanic for 25 years now but i had to replace the starter relay the whole ignition system and believe it or not new valves. After I replaced all of those my alero drove better then eer and the lights never went back on or any of the other lights....

Dec 19, 2008 | 2000 Oldsmobile Alero

1 Answer

When i start my car you smell gas ,and it smoke.


HTML clipboard If you can smell gas ONLY when the engine is running, then the gas didn't get burned completely. It could be the combination of the computer, oxygen sensors, and/or catalytic converter is going bad. If you could smell gas when it's parked, you might want to take it to a mechanic to have your gas line checked for leaks and for pressure test. Here's a website that talk a little about gas smell www.mycarsmellsbad.com good luck.

Dec 12, 2008 | 1999 Oldsmobile Alero

Not finding what you are looking for?
1999 Oldsmobile Alero Logo

Related Topics:

356 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

60541 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21927 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...