Question about 1999 Jeep Cherokee

1 Answer

Won't start went to garage started for them for one week every day then got it home on a wed. didn't use until saturday went about 5 miles came home then for two days didn't use it and went to start it and won't start the alternator has been changed as we thought that was the problem

Posted by on

  • yadayada
    yadayada May 11, 2010

    has the battery been tested, that is the very 1st thing u need to check ALWAYS.

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 144 Answers

Have someone check for spark at the plugs,if no spark either the crank sensor or cam sensor has gone bad,and making a guess from working on these I would say the crank sensor but you should be the mil lamp "check egine light" to come on and set a fault code,this assumes the engine cranks over and fuel system is ok

Posted on Mar 11, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 05 trailblazer. It won't start. Thought


Are you saying it will not start, or will not crank ?

Jul 07, 2013 | Cars & Trucks

1 Answer

Engine won't go over 5-10 MPH


You need to take the car to the dealer, because you need to recalibrate the electric throttle body with a TECH 2 Scanner, because the system went into a Limp mode.

Nov 03, 2012 | 2006 Saab 9-3 2.0

1 Answer

Start, drive, stop, need boost to start again; then after a day of not driving it will start without boost on the second day. What's going on?


check your battery. i had the same problem two months ago. i thought it was the alternator or starter , but the shop said i my battery wouldn't keep a charge.

Dec 27, 2011 | 1993 Cadillac Fleetwood

1 Answer

2002 volvo s60 cylinder 3 misfire detected


I have a bad feeling. I own a Volvo SW XC70 and I had to change the timing belt because I didn't want to have to buy a new engine. I changed it at around 150K miles. The belt is a composite and is not a chain (metal), so it can stretch, thus giving you "bad" timing and making it impossible to tune. If you have not checked or changed the belt, try it. It really won't cost that much (depending on where you take it. I went to Volvo. Good luck.
DON'T DRIVE THE CAR UNTIL YOU ARE SURE.

Dec 11, 2011 | 2002 Volvo S60

1 Answer

Hi, I have a transit t260 2.0 diesel engine 2002 that now won't start? I hadn't started it for a month before today. Today I started it, it fired up first time drove it for about half a mile, it...


I think it is i will probably have to pull the timing belt, it sounds like it probably skipped due to the serpentine belt cords wrapped around something under the timing belt cover, any other suggestions on alternate causes before I start pulling the brand new timing belt?12

Jul 16, 2011 | Ford Transit Connect Cars & Trucks

1 Answer

My 1995 honda accord cranks but won't start sometimes and others starts right up. what could this be? I've been told there is no pulse to injectors?


Does it seem to be tempreture related. i had a cutomers vehicle for almost 2 weeks and it started everytime. The thing was it was inside the garage. Finally one day I had pulled it out into the sun and when i went to put it back in, at that point it didn't start. It was a Honda but don't remember the year but it was around a 1995 like yours. It eneded up being the PGMFI relay wich would cause the exact sysmtoms that you are talking about. I have found out since then that this is a common problem. Give that a shot. I hope this helps and good luck.

Jun 01, 2011 | 1995 Honda Accord

2 Answers

Have a f350 diesel turbo .engine.just replace furl injectors two weeks ago. egr valve has been replaced twice and egr cooler once a year ago. the problem long cranks then it will start.However,no power and...


Had the same thing happen 2 years ago when it started 80 miles from home when i took off from a red light it didnt want to go pouring white raw fuel smoke i bet it took 5 miles to get up to a speed where i wasnt getting run over we finally got it home and it was the bearings gone in the turbo.

Jun 01, 2011 | Ford F-350 Cars & Trucks

1 Answer

The 12 volt battery(LUCAS 065/3) on my FORD FIESTA 1100cc is 4 years old, in that time i have only driven 1,600 miles as my journeys are usually very local. I make sure i use the car twice a week to keep...


Running so few miles has accelerated the aging of the battery - the battery never had a chance to fully recharge in such small trips -  so now you have to replace it a year sooner than usual.
Just replace it.

Aug 28, 2010 | Ford Escort Cars & Trucks

1 Answer

WON'T START


my 2006 pt cruiser won"t start. the light do come on but it will not turn over just a clicking sound. i drove it for about an hour then went back to it 30 mins later and it didn"t start. just clicking sound.

Sep 21, 2008 | 2006 Chrysler PT Cruiser

Not finding what you are looking for?
1999 Jeep Cherokee Logo

Related Topics:

151 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jeep Experts

yadayada
yadayada

Level 3 Expert

60792 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Jeep Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...