Question about 1997 Jaguar XK8

Open Question

XK8 "Lumpy" idle

My '96 XK8 has developed a 'lumpy' idle. Sitting at the lights in D, you can feel it juddering slightly. I can't decide whether it is the engine running slightly rough at idle speed or the torque converter/gearbox 'sticking' slightly (or indeed something else...). Either way, it isn't quite right, but as soon as you push the throttle you're away as smooth as anything. Any thoughts?

Posted by on

5 Suggested Answers

  • 273 Answers

SOURCE: fiesta running lumpy

try running redex through the system then change the fuel filter to rule out a blocked line

Posted on May 19, 2009

Mustgo
  • 2359 Answers

SOURCE: my 2005 audi a4 is running lumpy

Don't laugh,have you try the Champion #344 copper plug


I'm assuming you has a 1.8 liter Turbo A4


Back in my racing day,I use high energy Jacobs Electronic to boost the spark. They call for copper plugs!!!


Go to a good auto part store and look up a set of Champion plug for your engine.


Good luck

Posted on Jul 15, 2009

  • 1 Answer

SOURCE: renault espace 2.0 8v s reg

my espace runs rich and i loose power goin up a hill. its really slugish as well change all the parts that were diognoised but still have problems with it

Posted on Aug 02, 2009

  • 1 Answer

SOURCE: Runs lumpy when idling

just brought a megane 165 2.0 turbo,nice car,just been serviced from a renault dealer 29000 on the clock,HOWEVER,the toxic fume light flickas on and off at slow speed,it goes off at normal travelling speed,the car is not misfiring,it all seems ok,ive rang the dealer i bought it from and hes saying because the car stands often a week between being used its getting some condenstation in or around the cataltic converter,like i said the car is running fine,DO YOU THINK THE GUY IS FOBBING ME OFF,in the manual it says it should be checked over,any thoughts?

Posted on Sep 15, 2009

  • 2 Answers

SOURCE: Transmission fault on early Jag XK8

I had similar problem but worse. Mine would not reverse uphill! I changed oil and filter in torque converter and solved the problem.

Posted on Oct 27, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

When I do a kick down in a 00 XJ8 Sovereign. It seems to be hesitant and the same when you kick down when the S button is engaged. If you build up the speed gradually, then kick down it seems ok


Kickdown switch not working....is this common? - Gassing Station ...

www.pistonheads.com/gassing/topic.asp?h=0&f...t...

PistonHeadsThe kickdown switch on 2000 model XJ8 3.2 Sovereign is not working. Based on members experience is this likely to a faulty switch or a computer problem? More results from www.pistonheads.com

XK8 Sluggish Performance

www.jaguarforum.com/showthread.php?t=76206
Nov 19, 2014 - A 2002 XJ8 SE, A 2000 XJ8 Sovereign, and a 2000 XK8 Coupe. ... If I only press the throttle pedal a little way, there is no kick down and the car ... Misfire, Lumpy running??? - Jaguar Forum.co.uk
Apr 3, 2015
Proud new owner of a Jaguar XJ8
Nov 21, 2014
Misfire/slight hesitation under hard acceleration - Jaguar Forum.co.uk
Feb 13, 2012
S-Type 3.0 SE Hesitant on Kickdown - Jaguar Forum.co.uk
Apr 7, 2008
More results from www.jaguarforum.com

XJ8 and Kick-Down - JaguarForums


Dec 16, 2015 | Cars & Trucks

Tip

Bad fuel economy and lumpy idling - possibly causes


<p><b><u><span>Excessive fuel consumption and 'lumpy' idling engine</span></u></b><br /> <p><b><span>Possible faults:-</span></b><br /> <p><b><u><br /></u></b><br /> <p><b><u><span>Coolant sensor </span></u></b><span><span> </span>- engine is signaled as being 'cold' all the time, not just at start up, causing ECU to set longer injection cycle </span><br /> <p><span><span>&oslash;<span> </span></span></span><span>Low coolant level can prevent sensor being able to detect coolant temperature</span><br /> <p><span><span>&oslash;<span> </span></span></span><span>Faulty 'open' thermostat allows coolant to circulate without regulation and perhaps prevents the engine from achieving normal running temperatures.</span><br /> <p><span> </span><br /> <p><b><u><span>FPR</span></u></b><span> - broken diaphragm allows fuel to enter the vacuum line and then into the inlet manifold. Additional source of fuel makes the fuel air mix richer causing a faster and lumpy idle.</span><br /> <p><span> </span><br /> <p><b><u><span>Vacuum leak </span></u></b><span>- 'high oxygen' signal from O2 sensor causes ECU to set longer injection cycle.</span><br /> <p><span> </span><br /> <p><b><u><span>O2 sensor</span></u></b><span> - 'high oxygen' sensor error causes ECU to set longer fuel injection cycle</span><br /> <p><span> </span><br /> <p><b><u><span>MAF</span></u></b><span> - 'over reads' in error the amount of air entering causing ECU to set longer fuel injection cycle </span><br /> <p><span> </span><br /> <p><b><u><span>IAT</span></u></b><span> - 'under reads' in error the temperature of incoming air causing ECU to set longer fuel injection cycle</span><br /> <p><span> </span><br />

on Jul 22, 2011 | Mercedes-Benz E-Class Cars & Trucks

1 Answer

320d running lumpy starts and runs but very lumpy


Check your spark plugs for any misfiring chambers. This lumpy behaviour is likely related to one or more chamber misfiring.

Feb 09, 2015 | Cars & Trucks

1 Answer

Why is the engine light on


Your engine light comes on to tell you that there is a problem with your engine. As your description would indicate, there is a problem with your engine. If you have a scan tool hooked up to your car it will tell you what the computer sees as being the source of the problem.

Sep 27, 2014 | Cars & Trucks

2 Answers

I have a mondeo 53 plate 2.0 tdci that has a lack of power and running lumpy


I would be checking spark plugs and plug leads. Also could be petrol injectors, sorry about so much but this could be many things. Billy

Jun 05, 2014 | 2003 Ford Mondeo

1 Answer

2003 Alfa 156 JTS Fault codes P0120,P1121,P1122, P1682,P1687 & P1688 The engine has an idle speed of 1250/1600 rpm will not fall lower even when hot. It feels lumpy when driving at low speed. I changed...


Hi

I own a alfa 156 jts, and have the same problem, first I cleaned the maf sensor, then I changed the pedal assy. It came back. Now I have changed the Throttle body Ass\'y ( TPS) and it has fixed the problem. Also a new set of plugs will fix the lumpy problem?

Sep 11, 2013 | 2000 Alfa Romeo 156

1 Answer

Engine light on, sounds and feels like using lumpy petrol.


i have found 2 areas that cause issues such as you are reporting.
one is poor voltage. check the connection at the starter motor between the alternator and the battery.
the other and perhaps more likely is a wet ECU.

the ecu box is under the windshield on the passenger side, access under the hood. this are can get wet ad corrode an ECU.

remove the ecu, take the bottom plate off and clean any corri=oded and wet areas with alcohol and a tooth brush..be gentle.
i would look for a way of mounting the ecu so that it doesn't lay on a flat surface that gets wet...

Jan 28, 2010 | 1999 BMW 323 Series

2 Answers

Runs lumpy when idling


clean throtle boddy and idle speed actuator
marko

Sep 14, 2009 | 2000 Renault 181

1 Answer

Hi I have 2000 BMW 320i. Lumpy idle when cold and oil light for


Your oil is a little low, and the timing may be off a bit but if it smooths out after warm it is probably ljust
low oil.

Jun 29, 2009 | 2000 BMW 3 Series

1 Answer

Engine idles lumpy - why?


1.6 zetec surely ,for this year

Jun 23, 2008 | 1999 Ford Escort

Not finding what you are looking for?
1997 Jaguar XK8 Logo

Related Topics:

163 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jaguar Experts

Colin Stickland
Colin Stickland

Level 3 Expert

21990 Answers

Raygin
Raygin

Level 2 Expert

322 Answers

yadayada
yadayada

Level 3 Expert

64034 Answers

Are you a Jaguar Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...