Question about 1997 Ford Expedition

1 Answer

My 97 Expedition has no power. Tried to jump. Nothing! Meter reads 12.4V. No electrical at all. What can cause this? Thank in advance Mark

Posted by on

  • Uriel Tello
    Uriel Tello May 11, 2010

    do your head lights work? your accesories in the car turn on? can you crank the engine?

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 599 Answers

Check power and grounds..at battery and at other end of battery cables first and advise ...good luck

Posted on Feb 26, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Battery is good but no power period on a 1999 ford expedition no lights no nothing


go to www.bbbind.com/ free wiring diagrams . Check main B+ cable, fusible links . Do you know how to do basic electrical testing with a volt meter ? Videos on you tube an how to read wiring diagrams .
At bbbind enter vehicle info. year , make , model an engine size . Under system click electrical distribution then under subsystem click power distribution . Check main battery + feed . see where voltage is an isn't .

Jul 04, 2016 | Ford Cars & Trucks

1 Answer

98 Pathfinder All Electrical in Vehicle Gone.


I would go with the corroded cables. You would have power to everything even with the alternator out of the truck.

Jun 19, 2013 | 2001 Nissan Pathfinder

1 Answer

97 c1500 starting problem, battery or starter or electrical problem?


The solenoid on the starter may need to be replaced.

Jul 05, 2012 | 1997 Chevrolet C1500

1 Answer

1997 Ford Expedition gauges stopped working, fuel, speed, etc is that a fuse or electrical? Which fuse?


my 97 expedition cluster is out. i replaced the cluter and nothing happen. what else can it be?

Apr 01, 2012 | Cars & Trucks

1 Answer

2002 Chrysler 300M, stop lamp & park/horn circuits grounded on load side. What can cause this?


Do you know how to use a DVOM - digital volt ohm meter to trouble shoot automotive electrical circuits ? Using a wiring diagram to find testing points in the B+ power flow of the vehicle electrical circuits .
Free wiring diagrams here http://www.bbbind.com/free_tsb.html Enter vehicle info. year , make , model , engine size . Under system click electrical distribution , then under subsystem click power distribution . Click on the search button , then each link one at a time !
. stop lamp & park/horn circuits grounded on load side. What can cause this? A direct short to ground .
Finding The Source Of Electrical Shorts In Your Car

Electric Testing Techniques You Need to Know

Apr 29, 2017 | 2002 Chrysler 300M

4 Answers

97 Expedition, 5.4L hesitated during acceleration 40-45MPH. Check Engine light flashed, then stayed on. Would get up to 55-60MPH. All guages read ok. First trouble ever with this car.


go to a parts store and they will let you use their scanner for free. sounds like a cylinder misfiring. The scanner will tell you which one it is.

Dec 13, 2009 | 1997 Ford Expedition

1 Answer

97 Pontiac Sunfire overheating


check the engine coolant temp sensor, if the sensor is failing it will read always cold and not turn the fan on, if everything else looks and tested ok try the ECTS (engine coolant temp sensor)

Jun 20, 2009 | 1997 Pontiac Sunfire

Not finding what you are looking for?
1997 Ford Expedition Logo

Related Topics:

111 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

fordexpert

Level 3 Expert

5546 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...