Question about 1989 Oldsmobile Cutlass Ciera

1 Answer

1989 Olds 3.3 Eng. I left the ignition on for two

1989 Olds 3.3 Eng. I left the ignition on for two days. After charging the battery as soon as I turned the key to ON, the Tach needle fliped from the left side zero to the right side 7000, without the engine running. The needle just lays on the right side now, all the time. All other gauges appear to be working fine. Any suggestions?

Posted by on

  • Jay Williams Feb 26, 2009

    I called AutoZone about the OBD tool. They said 1989 did not have a obd tool access. They suggested I take the positive battery cable off for a while. I disconnected the + cable for two hours, but that didn't fix it. Do you think I should try AdvancedAuto or O'Rielly? Any other suggestions? jpw46@yahoo.com

×

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sniper:

    An expert who has posted more than 50 answers, of which 90% or more were rated as helpful.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

  • Expert
  • 73 Answers

Try to reset the computer (via obd tool)

Posted on Feb 24, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

Tip

Cadillac service light 1989-01


Eldorado

2000-01

Turn the ignition to ON. Press the TRIP button on the driver information center (DIC) switch to view various menu choices and stop on OIL LIFE REMAINING. A message will display the percentage of oil life remaining. Press and hold the RESET button on the DIC switch for at least 2 seconds. A message will display the percentage of oil life remaining as 99 percent. The engine oil life monitor is now reset. Turn the ignition OFF.


DeVille,
Eldorado


1999

To reset the service Oil Life Indicator, display the
"OIL LIFE LEFT" message by pressing the "INFORMATION SKIP" (skip info) button. Press and hold the "RESET NO" (no info reset) button until "100% OIL LIFE" is displayed.


Deville,
Seville


2000-01

Turn the ignition to ON, Press the INFO button on the driver information center (DIC) to display ENGINE OIL LIFE. Press and hold the INFO RESET button on the DIC until the display reads 100% ENGINE OIL LIFE. The engine oil life index is now reset. Turn the ignition OFF.


Deville,
Seville,
Eldorado


1997-98

Display "ENGINE OIL LIFE" by pressing the "INFO" button. Press and hold the "INFO RESET" button until the message shows 100.


All Models
except
Fleetwood


1994-97

Press the "INFORMATION" button until "OIL LIFE LEFT" is displayed. Press the "RESET" button until "100" or "0.0 OIL LIFE LEFT" is displayed.


Fleetwood


1994-96

To reset "CHANGE OIL" light, turn the ignition switch to the run position without starting the engine. Fully depress and release the accelerator pedal 3 times within 5 seconds.


All Models,
Seville,
Eldorado


1993,
1994-95,
1994-95

The automatic transaxle message can be reset through the following procedure. If "CHANGE TRANSAXLE FLUID" appears on the Information Center, press and hold the "OFF" and "REAR DEFROST" buttons until "TRANS FLUID RESET" appears.


DeVille,
Fleetwood


1991-93

When "CHANGE OIL SOON" light is illuminated, press and hold the "RESET" and "RANGE" buttons on the Fuel Data Center for 5 to 60 seconds. When the buttons are released, the light will flash four times if it has been reset. If the light comes back on for more than 5 seconds, repeat the procedure.


Allante


1989-93

When "CHANGE OIL SOON" appears on the Driver Information Center, press the "RANGE" button until "OIL LIFE INDEX" shows on display. Then press and hold "AVG SPEED" and "RESET" (or "RANGE" on late models) buttons until display shows "100".


Seville,
Eldorado


1992-93

Press "INFORMATION" button on the Driver Information Center until "OIL LIFE INDEX" is displayed. Press "STORE/RECALL" until "OIL LIFE INDEX" resets to 100.


Seville,
Eldorado


1989-91

When "CHANGE OIL SOON" or "CHANGE ENGINE OIL SOON" appears on the Driver Information Center, press "ENG-DATA" button until the "OIL LIFE INDEX" appears. Then press the "ENG-DATA" button and the "RANGE" buttons at the same time until 100 displays (about 5 seconds).





















on Dec 07, 2009 | Cadillac Eldorado Cars & Trucks

1 Answer

Whats wrong when the computer as ys check your charging station


Does the radio turn on when you turn ignition. If not then the Battery
has bad cell. Replace battery. Battery's in Olds Aurora 98 typically
get a very long life. 6 years . After 6 I recommend replacing battery
If your car turns what does your battery read. If it's reading only 12 V
with eng. going, your alternator has gone out. If battery is new then you'll need to find another reason your battery is draining charge.

Jul 15, 2014 | 1998 Oldsmobile Aurora

1 Answer

Ecv malfunction


Is your Ignition switch working O.K. ? My Daughters 03 Had a bunch of codes,trans codes and service eng soon light etc. Come to find out Her ignition switch was Bad, it wasn't powering up all circuits, replaced it and worked to this day, 3 years ago

Feb 29, 2012 | 2003 Chevrolet Trailblazer Ext

1 Answer

I have a 1990 Olds 98 with a charging problem. THe battery is good and the alt is new. It is not charging


You need to test your charging system circuits at the alternator. (see diagram and instructions)

BLK is the cable to the battery POSITIVE terminal - this is hot at all times.
PINK/BLACK comes from Fuse #5 (15 Amp) in the relay center under the right side of the instrument panel. This wire is hot (battery voltage) with the ignition switch in the RUN, BULB TEST, or START positions.
BROWN comes from your instrument panel and is protected by Fuse #16 (20 Amp) in the instrument panel left side fuse block. This wire will have slightly less than battery voltage with the ignition switch in the RUN, BULB TEST, or START positions.
If any of this is not as described, let me know what you have found and we can continue if needed.

10_28_2011_12_29_29_am.jpg

Oct 27, 2011 | 1990 Oldsmobile Regency

1 Answer

1998 Olds Cutlass- My gauges were moving around very quickly when I turned the ignition. It won't start now and sounds like the battery is dead, but it's not. My gas gauge has spun around and sits under...


HiYour battery is not fully charged, jump start vehicle and take it to and AutoZone or similar auto parts store to have your charging/starting system checked for free.
On the gauges issue, you have to remove the instrument cluster and manually turn/reset the gas gauge. I have a 98 Olds Intrigue and happened a few times. I pull the gauge needle out and set it where it would be if the key where OFF, then plug the electrical connector on the cluster and turn the key to ON to verify gauge positions, on my case, I had to reset the temp. gauge too.
Good Luck! Don't forget to rate this post!!

Sep 22, 2010 | 1998 Oldsmobile Cutlass

1 Answer

A 1989 olds royal brougham (88)with new battery,


I would check the crankshaft and camshaft sensors. I don't think the connections are wrong, they really only go on 1 way.

May 02, 2010 | 1989 Oldsmobile Eighty Eight Royale

1 Answer

Car sat for two years there is no spark and i can't hear the fuel pump working what other problems could i have ( installed a new ignition coil)


So you have no crank no start correct?
Battery must be fully charged ( three day charge) or new.Make sure battery cables are clean and tight.
Use meter and make sure B+ making it to starter .
If B+ not at starter then check cable to starter and neutral safety switch and ignition switch.

This is for crank no start

B+ goes from battery to Ignition switch to coil to switching device( ignition module) to plug.
use a volt meter and find out where B+ stops.

Apr 22, 2010 | 1989 Honda Prelude

1 Answer

I have a 1989 4 cylinder 2.0 liter Toyota Camry LE edition. When I got to start the car if it was cold in the morning or it has been sitting awhile the car doesnt want to start. It starts to turn then...


That Is a classic faulty battery :

1) Faulty batterys can not hold their charge (soon godouwn)

2) When your starter motor draws high currant from the battery the voltage drops right off so the starter dis-engages the voltage then rises and the starter atempts to re-engage..........AND VOLTAGE DROPS OFF AGAIN! go back to the start of this paragraph! hole prosses starts again! untillyou let go of the key!

3) don't keep doing that by the way as it ruins the solonoyd contacts after a while!

4) Just replace the Battery and check rhe charge rate
should be 13.8 volts minimum to 14.5volts absalute maximum!

5) the anser here is get a new battery! they only last 2 years at best these days!

there you go problem solved.

Mar 10, 2010 | 1989 Toyota Camry

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

103 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

76848 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8582 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...