Question about 2005 GMC Sierra

1 Answer

I started my truck this morning,no problems. I left work at 10:00 am for a coffee,it started no problem. When I go to leave at 5:00 pm , it would not start, I have lights and all electrical but it will not start.Is there a fusable link for the starter outside of the fuse panel?

Posted by on

  • Bruce Bracey
    Bruce Bracey May 11, 2010

    Does the engine actually spin or turn over when you try to start it? If so, the fusible links are ok.

    Let me know and we will get started.

    Regards.

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 54 Answers

There is a shift lever park interlock. Either push the shift lever firmly in to park or turn the key on, put your foot on the brake and pull the shift lever down at least to drive then return it firmly back to drive, you may also rock the truck back and forth while it is in park, then try to start it.

Posted on Feb 23, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Electrical Short in 1998 Plymouth Neon


Your fusible link could be burnt,follow all wires tied into positive cable on battery.

Jul 31, 2012 | 1998 Plymouth Neon

1 Answer

04 elantra stalls when cold


No codes would point to fuel problem such as low pressure.
Was the car left overnight at the shop so it would be a cold start for the mechanic ?

Jul 01, 2012 | 2004 Hyundai Elantra

1 Answer

I have a 1998 pontiac sunfire started fine when i left for work this morning trying to leave work now all it doesis starts then immediately dies


Read thru this link. You may have an antitheft failure. Symptoms are very similar.

http://vatspasslockpasskeysecurityhelp.yolasite.com/

Jun 05, 2012 | 1998 Pontiac Sunfire

1 Answer

Start, drive, stop, need boost to start again; then after a day of not driving it will start without boost on the second day. What's going on?


check your battery. i had the same problem two months ago. i thought it was the alternator or starter , but the shop said i my battery wouldn't keep a charge.

Dec 27, 2011 | 1993 Cadillac Fleetwood

1 Answer

Hi i have a 05 transporter 1.9tdi with roughly 100k makes a screech when locking left plus white smoke when starting only sometimes ,any ideas ,dont want too go too main dealer they will want my house...


like your style ,want the house ?? the left turn power screech could just be the belt needs a bit mor tension ,check the oil level first though ,now as for the white smoke on starting ,WELL IGNORE IT this is caused by the automatic excess fuel cold start device and the smoke is a light grey not white but it appears like this as you see light through it making it look white .This is normal on a cold morning it doesnt need new filters or the codes read or a tranny flush or the pigs tails brushing just leave alone ,check the steering fluid level use ATF to top up or hydraulic oil then if still screeches tighten the belt unless its a one big one in whick case it may need a new tensioner or just leave it alone its not a major problem as yet .Must tell the other mechanics in the pueblo this morning as we congregate in marias bar for brekkie and coffee and tell tall tales but this one will take the biscuit thats for sure .

Jan 25, 2011 | 2005 Volkswagen Microbus

1 Answer

On the way to work this morning hazard lights randomly flashed about 4 times in the space of 5 ks,thought it might have something to do with an electrics fault or is this a subie warning of some type(1997...


ahh yeah turns out i'm a muppet ,i had turned the imoboliser/alarm on ,while i went into the servo for ciggys and a coffee ,i didn't disarm properly and drove to work ,thank goodness subies rev high ,if i had stalled,could have been a little imbrassing,trouble with early morning starts .
Talken to winger in the morning No engine warning lights are connected to the hazards(and you can stop laughing at me now!)

on a brighter not i have my car booked if for a service ,thanks anyway

Jun 18, 2009 | 1997 Subaru Impreza

1 Answer

My car is not turning on!


Try to use other car key, (or replace the key batteries if u don,t have other one)

Apr 11, 2009 | 2000 Mercedes-Benz E-Class

1 Answer

Only starts on a warm afternoon


Hi...
I'm A mechanic. And I was involved in a problem like this. With the same kind of vehicle.
And Finally a Found the problem. On my Case was the Coolant temperature sensor.

Maybe on your case is diferent but You don't loss nothing Trying .
In the morning Try to start the Vehicle if no run.
Go at front under hood, and disconnect the ECT Engine coolant sensor.
Is located at the front of the Engine Beside of the Thermostat housing.
After you disconnect go try to start if run ok. Replace the sensor with a new one.

I hope this help on your problem.

Thank you for use fixya...

Nov 07, 2008 | 1995 Plymouth Voyager

Not finding what you are looking for?
2005 GMC Sierra Logo

Related Topics:

214 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

61168 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...