Question about 1985 Ford F150

1 Answer

My alternator is not 'recyling' power like it should.

The power is just coming off the battery. i just put a new voltage regulator and alternator on it and it wont work. it keeps fyin my solenolids and i cant find what is wrong with it. oh ya ounce you give it a good jump starte with wil run for about an hour then slowly die

Posted by on

  • warren_phil Feb 23, 2009

    it does not have the fuseable linkage to the alt to the starter. it has not had on since the day i got the truck it has a streight 6 in it

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 17 Answers

Check the wire from alt to stater probably has a fuseable link fried 9 out of ten times

Posted on Feb 23, 2009

  • avery69 Feb 23, 2009

    ok there is a fuse for the alt under the hood in the fuse box

×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

89 dodge d-150...new altanator. .new battery...truck will run till battery is drained seems like charging system is not working...all grounds are good, there is no external voltage regulator that I have...


The voltage regulator is mounted on the firewall of this truck. There should be a 2 wire plug that plugs into the alternator, one should be green, ground that wire to see if the alternator starts charging. If the voltage output increases then the regulator is bad.

Feb 24, 2015 | Dodge Cars & Trucks

1 Answer

Why is my 1972 chevelle voltage regulator make noise when you rev it up


If the battery is no good,then you will hear the alternator
hum all the time, trying to charge it

Check for diode problems & A/C Ripple on the circuit

Check all vehicle grounds (wires)

If the wiring is good & the light comes on, it isn't charging
properly,have you not metered that,voltage,amperage &
ripple

You can go through 3 alternators from the auto part chains, to
find a good one.

Sep 07, 2014 | Cars & Trucks

1 Answer

2003 Ford Windstar----I had battery light, abs and brake light intermittantly coming on. Found that alternator was over charging and there was a bad wire overheating going from battery and fuse panel. ...


Hello, It could be what you said. But if you know the Voltage was too high, you may want to replace the Ignition Relay and the Fuel pump Relay. If the contact points are cooked, they could work intermittently and it would be difficult to test. A bump or a little overheating could cause the contact points to break loose and then work when they cool.

It is good that the "check lights" are off. I always tell my clients that the scans are free at Autozone, Oreillys, and Advance. Some things like Relays may not trigger a light.

Be careful with a Wiggle test, but you may find a short in the wiring by shaking the wiring under the hood. I doubt the Voltage Regulator is causing your current stalling problem. A fully charged Battery without a Regulator or an Alternator would provide an amount of reliable power until the Battery was drawn down.

I hope my Solution is very helpful.

Jun 26, 2011 | 2003 Ford Windstar

2 Answers

There is a ground some were that is causeing the battery not to charge put new selinoid ,new battery,alternater,new key lock cylender check wirers fuses relay switches and battery still wont charge


It sounds like you have done a whole lot of replacing and not much "diagnosing". Did you chech for battery voltage at the alternator? There should be battey voltage at the large Black/Orange wire that is on the B+ terminal of the alternator. This wire should have voltage all the time. If there is no battery voltage, you most likely have a burned fusible link at the starter relay area.
There should also be voltage at the "S" terminal with the ignition on. If there is no voltage, then check for voltage at the "S" terminal of the voltage regulator. If there is no voltage at the "S" terminal on the voltage regulator then check the "I" terminal on the regulator for voltage.

NOTE: The voltage on the "S" terminal should be 1/2 that of the voltage on the "I" terminal.

If there is voltage on the "I" terminal, make sure your voltage regulator is grounded properly to the fender and retest to see if it is charging the battery. If it is still not charging, disconnect the regulator connector and connect a jumper between the "A" and "F" terminals of the connector. Start the engine. The alternator should now be charging the battery at high voltage (usually over 15 volts) If it does, replace your voltage regulator. If it does not, then you need to check your wiring between the voltage regulator and the alternator.

Please also review this article:

What Else Could Be Wrong?

Jun 15, 2011 | 1987 Ford F 150

1 Answer

New alternator new battery installed still wont charge the battery and radio and power anttena dont work


If you have a voltage meter, you should check if your voltage regulator is working correctly. The voltage regulator should keep the voltage to the battery something under 15 volts when the motor is running (more than 13.5 volts with all electrical turned off).

If more than 14.5 volts, you may be damaging your new battery and regulator is not working properly. Also, radio may not come on because a voltage sensor is protecting it from the high voltage. Antenna is controlled by radio so that should not be working either.

Good luck.

May 05, 2011 | Buick Century Cars & Trucks

1 Answer

I seem to have a charging of the battery problem. I would get 14 volts to my battery from my alternator and then 6 volts, i changed m alternator and things were going great, no problems. Now it is acting...


Hi,
If you were originally having a wild fluctuation in measurement at the battery the voltage regulator would have been shot. I'm not sure of what the condition was of the original alternator. But I would definitely have changed the voltage regulator. A bad regulator can ruin a battery and all sorts of other things. If you are now getting wild variations in voltage
1st Purchase and install a new voltage regulator. (probably about $20.00 these days.
Then check your new battery by doing the following:
1 Disconnect it from the truck's electrical system.
2 Charge it up using another vehicle and jumpers.
3 After disconnecting the battery from the jumpers, let it sit for a few minutes.
4 Check the voltage. If it is below 12 volts, the battery is shot. Replace it under warranty.
5 When you get the new battery, Install it in the truck and start it up. Then measure the voltages coming into the battery from the alternator and the new voltage regulator.
If all is well, your done.
If not. Pull the alternator and replace that.
Hope this helps,
Good Luck,
Mark

Jan 05, 2011 | 1988 Dodge Ram 50

3 Answers

I have a 1977 mercury marqius and i cant find out why its not charging. It has a new genarater,voltage Regulater, and also new fuse links. It seems like the charge is bloked from coming out of the...


You need to confirm that there is battery voltage to the battery post of the alternator.If there is then turn the key on and verify that there is power to the field post.If you have no power to the field it will not charge,you either plugged the regulator in before you put it on and ruined the regulator or you may have a bad wire splice between the alternators battery wire and the yellow wire in the regulator plug,check to see if it has 12volts to it at all times.If none of the above,run your own 10 gauge ground wire from the alternator to the block or the have the new alternator tested.

Jan 17, 2010 | 1977 Mercury Grand Marquis

2 Answers

My 7.3 L diesel ford f-250 shows the battery light (check charge system) on in the dash. I tried to drive it and the voltage gauge started dropping into the 10-11 v range. I replaced the alternator...


You must have an older vehicle,but I am pretty sure the 7.3 was put out after the voltage regulator was put in the alternator.What you are describing is a voltage regulator on the the firewall.If this is so,replace the voltage regulator on the firewall,with a new one.This will be the problem most likely.The voltage regulator on the firewall should be kind of flat,almost square,and a wide plug,goes all the way across the voltage regulator.If You don`t have external regulator,then it is built in the alternator,and the alternator you purchased is bad.Be sure the wires on the back of the alternator are not broken anywhere.The big post ,largest wire,on the back of the alternator is the out put wire.It should go to the battery.If it does not have 13.65 to 14.25 volts on the back of the alternator,and at the battery positive post.Like I said,I believe the voltage regulator is on the firewall,if it looks like I described,then it is a regulator,replace this part(voltage regulator)and it will solve your problem.I hope this was some help,please let us know,thank you.

Oct 15, 2009 | Ford F-250 Cars & Trucks

Not finding what you are looking for?
Cars & Trucks Logo

109 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

60667 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21936 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...