Question about 2005 Nissan Armada

2 Answers

2004 nissan armada low idle then won't start

I left house and accelerated which caused the vehicle to hesitate. Ran an errand got back turned off engine. Got back into vehicle an hour later and the vehicle started hesitantly and seemed to muffle itself out. Tried to start it again and briefly stayed running and then shut down completely. Won't start at all now. Help!

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

I had the smae problem with mine last week, it turned out to be the IPDM Independent power distribution moduel, looks like a big fuse box. I would take it to a side mechanic and have them fix it instead of going to the dealer it took like 45 mins to take the old one out and put the new one in. If you go to the dealer they are sure to charge something crazy. Hope that works for you.

Posted on Feb 25, 2009

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Hi... i have armada 2005, the prob is when i accelerate it doesn't go beyond 2000-3000 rpm

Posted on Jul 05, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2004 Nissan Armada wont grab a gear


I'm assuming automatic transmission. Check your fluid level immediately. If low(hopefully the issue) add required fluid, start vehicle and idle a minute to pump fluid back through system and try putting in gear again. If this solves the issue then you most likely have a leak some where. If fluid level is ok, you will need to see a transmission specialist.

Aug 07, 2015 | 2004 Nissan Armada

1 Answer

Engine ticks over but no acceleration



ENGINE HESITATES WHILE ACCELERATION

LOSS OF ACCELERATION


It can be fuel pressure issue or it's the problem with accelerator pedal or its clogged filters causing there.

There are many other possibilities. I suggest you to go through the list of help links mentioned below, these will help you to confirm where the actual fault lies: -------

Jerks and Hesitates During Acceleration?

http://technoanswers.blogspot.in/2012/07/2004-dodge-town-country-jerks-and.html

-----------

Loss of acceleration?

http://technoanswers.blogspot.in/2012/02/loss-of-acceleration.html

---------

Headlights flickering and car hesitates to start?

http://howtobyme.blogspot.in/2012/02/headlights-flickering-and-car-hesitates.html

--------

How exactly the Vehicles Accelerator Cable works?

http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-cable.html

-------------

How exactly Vehicles Accelerator Pump Diaphragm Works?

http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-pump.html

--------

2000 Toyota Avalon: Engine Lean Codes and Knock Sound on Acceleration?

http://whatisbyme.blogspot.in/2012/05/2000-toyota-avalon-engine-lean-codes.html

---------

2004 Toyota Avensis: Acceleration And Deceleration makes noise on Front End?

http://whatisbyme.blogspot.in/2012/05/2004-toyota-avensis-acceleration-and.html

---------

Wheel hop under hard acceleration?

http://technoanswers.blogspot.in/2012/04/wheel-hop-under-hard-acceleration.html

--------

2009 Chevy impala accelerator pedal sensor?

http://technoanswers.blogspot.in/2012/02/2009-chevy-impala-accelerator-pedal.html

---------

Nissan Pathfinder stalls and bucks on Acceleration?

http://technoanswers.blogspot.in/2012/02/nissan-pathfinder-stalls-and-bucks-on.html

--------

Acceleration lag problem?

http://repairhelpcenter.blogspot.com/2012/01/acceleration-lag-problem.html

-------------

These details will help.

Thanks.

Feb 04, 2013 | 2007 Kia Magentis 2.0

1 Answer

Mazda 323 bj not exccelerating


ENGINE HESITATES WHILE ACCELERATION

LOSS OF ACCELERATION


It can be fuel pressure issue or it's the problem with accelerator pedal or its clogged filters causing there.

There are many other possibilities. I suggest you to go through the list of help links mentioned below, these will help you to confirm where the actual fault lies: -------

Jerks and Hesitates During Acceleration?

http://technoanswers.blogspot.in/2012/07/2004-dodge-town-country-jerks-and.html

-----------

Loss of acceleration?

http://technoanswers.blogspot.in/2012/02/loss-of-acceleration.html

---------

Headlights flickering and car hesitates to start?

http://howtobyme.blogspot.in/2012/02/headlights-flickering-and-car-hesitates.html

--------

How exactly the Vehicles Accelerator Cable works?

http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-cable.html

-------------

How exactly Vehicles Accelerator Pump Diaphragm Works?

http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-pump.html

--------

2000 Toyota Avalon: Engine Lean Codes and Knock Sound on Acceleration?

http://whatisbyme.blogspot.in/2012/05/2000-toyota-avalon-engine-lean-codes.html

---------

2004 Toyota Avensis: Acceleration And Deceleration makes noise on Front End?

http://whatisbyme.blogspot.in/2012/05/2004-toyota-avensis-acceleration-and.html

---------

Wheel hop under hard acceleration?

http://technoanswers.blogspot.in/2012/04/wheel-hop-under-hard-acceleration.html

--------

2009 Chevy impala accelerator pedal sensor?

http://technoanswers.blogspot.in/2012/02/2009-chevy-impala-accelerator-pedal.html

---------

Nissan Pathfinder stalls and bucks on Acceleration?

http://technoanswers.blogspot.in/2012/02/nissan-pathfinder-stalls-and-bucks-on.html

--------

Acceleration lag problem?

http://repairhelpcenter.blogspot.com/2012/01/acceleration-lag-problem.html

-------------

These details will help.

Thanks.

Dec 31, 2012 | Mazda 323 Cars & Trucks

1 Answer

- stumbles when stopped and accelerating at low speeds


ENGINE HESITATES WHILE ACCELERATION
LOSS OF ACCELERATION

It can be fuel pressure issue or it's the problem with accelerator pedal or its clogged filters causing there.
There are many other possibilities. I suggest you to go through the list of help links mentioned below, these will help you to confirm where the actual fault lies: -------
Jerks and Hesitates During Acceleration?
http://technoanswers.blogspot.in/2012/07/2004-dodge-town-country-jerks-and.html
-----------
Loss of acceleration?
http://technoanswers.blogspot.in/2012/02/loss-of-acceleration.html
---------
Headlights flickering and car hesitates to start?
http://howtobyme.blogspot.in/2012/02/headlights-flickering-and-car-hesitates.html
--------
How exactly the Vehicles Accelerator Cable works?
http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-cable.html
-------------
How exactly Vehicles Accelerator Pump Diaphragm Works?
http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-pump.html
--------
2000 Toyota Avalon: Engine Lean Codes and Knock Sound on Acceleration?
http://whatisbyme.blogspot.in/2012/05/2000-toyota-avalon-engine-lean-codes.html
---------
2004 Toyota Avensis: Acceleration And Deceleration makes noise on Front End?
http://whatisbyme.blogspot.in/2012/05/2004-toyota-avensis-acceleration-and.html
---------
Wheel hop under hard acceleration?
http://technoanswers.blogspot.in/2012/04/wheel-hop-under-hard-acceleration.html
--------
2009 Chevy impala accelerator pedal sensor?
http://technoanswers.blogspot.in/2012/02/2009-chevy-impala-accelerator-pedal.html
---------
Nissan Pathfinder stalls and bucks on Acceleration?
http://technoanswers.blogspot.in/2012/02/nissan-pathfinder-stalls-and-bucks-on.html
--------
Acceleration lag problem?
http://repairhelpcenter.blogspot.com/2012/01/acceleration-lag-problem.html
-------------
These details will help.
Thanks.

Dec 07, 2012 | Cars & Trucks

3 Answers

When maintaining speed of about 50mph,2004 pacifica hesitates and will cut off while in park sometimes.check engine light is not on


ENGINE HESITATES WHILE ACCELERATION

LOSS OF ACCELERATION


It can be fuel pressure issue or it's the problem with accelerator pedal or its clogged filters causing there.

There are many other possibilities. I suggest you to go through the list of help links mentioned below, these will help you to confirm where the actual fault lies: -------

Jerks and Hesitates During Acceleration?

http://technoanswers.blogspot.in/2012/07/2004-dodge-town-country-jerks-and.html

-----------

Loss of acceleration?

http://technoanswers.blogspot.in/2012/02/loss-of-acceleration.html

---------

Headlights flickering and car hesitates to start?

http://howtobyme.blogspot.in/2012/02/headlights-flickering-and-car-hesitates.html

--------

How exactly the Vehicles Accelerator Cable works?

http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-cable.html

-------------

How exactly Vehicles Accelerator Pump Diaphragm Works?

http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-pump.html

--------

2000 Toyota Avalon: Engine Lean Codes and Knock Sound on Acceleration?

http://whatisbyme.blogspot.in/2012/05/2000-toyota-avalon-engine-lean-codes.html

---------

2004 Toyota Avensis: Acceleration And Deceleration makes noise on Front End?

http://whatisbyme.blogspot.in/2012/05/2004-toyota-avensis-acceleration-and.html

---------

Wheel hop under hard acceleration?

http://technoanswers.blogspot.in/2012/04/wheel-hop-under-hard-acceleration.html

--------

2009 Chevy impala accelerator pedal sensor?

http://technoanswers.blogspot.in/2012/02/2009-chevy-impala-accelerator-pedal.html

---------

Nissan Pathfinder stalls and bucks on Acceleration?

http://technoanswers.blogspot.in/2012/02/nissan-pathfinder-stalls-and-bucks-on.html

--------

Acceleration lag problem?

http://repairhelpcenter.blogspot.com/2012/01/acceleration-lag-problem.html

-------------

These details will help.

Thanks.

Nov 28, 2012 | Chrysler Pacifica Cars & Trucks

1 Answer

1998 mercury cougar rx8 155000m Hi the few problems my car is having is when I first push in the pedal it has a hesitation and won't immedieatly accelerate. It'll finally **** and take off after...


ENGINE HESITATES WHILE ACCELERATION

LOSS OF ACCELERATION


It can be fuel pressure issue or it's the problem with accelerator pedal or its clogged filters causing there.

There are many other possibilities. I suggest you to go through the list of help links mentioned below, these will help you to confirm where the actual fault lies: -------

Jerks and Hesitates During Acceleration?

http://technoanswers.blogspot.in/2012/07/2004-dodge-town-country-jerks-and.html

-----------

Loss of acceleration?

http://technoanswers.blogspot.in/2012/02/loss-of-acceleration.html

---------

Headlights flickering and car hesitates to start?

http://howtobyme.blogspot.in/2012/02/headlights-flickering-and-car-hesitates.html

--------

How exactly the Vehicles Accelerator Cable works?

http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-cable.html

-------------

How exactly Vehicles Accelerator Pump Diaphragm Works?

http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-pump.html

--------

2000 Toyota Avalon: Engine Lean Codes and Knock Sound on Acceleration?

http://whatisbyme.blogspot.in/2012/05/2000-toyota-avalon-engine-lean-codes.html

---------

2004 Toyota Avensis: Acceleration And Deceleration makes noise on Front End?

http://whatisbyme.blogspot.in/2012/05/2004-toyota-avensis-acceleration-and.html

---------

Wheel hop under hard acceleration?

http://technoanswers.blogspot.in/2012/04/wheel-hop-under-hard-acceleration.html

--------

2009 Chevy impala accelerator pedal sensor?

http://technoanswers.blogspot.in/2012/02/2009-chevy-impala-accelerator-pedal.html

---------

Nissan Pathfinder stalls and bucks on Acceleration?

http://technoanswers.blogspot.in/2012/02/nissan-pathfinder-stalls-and-bucks-on.html

--------

Acceleration lag problem?

http://repairhelpcenter.blogspot.com/2012/01/acceleration-lag-problem.html

-------------

These details will help.

Thanks.

Nov 28, 2012 | Cars & Trucks

1 Answer

My truck is lagging when I drive.. Everthing works it just feels slower then normal.. It's a Chevy Tahoe 1999 2 door..


ENGINE HESITATES WHILE ACCELERATION

LOSS OF ACCELERATION


It can be fuel pressure issue or it's the problem with accelerator pedal or its clogged filters causing there.

There are many other possibilities. I suggest you to go through the list of help links mentioned below, these will help you to confirm where the actual fault lies: -------



-----------


Acceleration lag problem?

http://repairhelpcenter.blogspot.com/2012/01/acceleration-lag-problem.html

------------

Jerks and Hesitates During Acceleration?

http://technoanswers.blogspot.in/2012/07/2004-dodge-town-country-jerks-and.html

-----------

Loss of acceleration?

http://technoanswers.blogspot.in/2012/02/loss-of-acceleration.html

---------

Headlights flickering and car hesitates to start?

http://howtobyme.blogspot.in/2012/02/headlights-flickering-and-car-hesitates.html

--------

How exactly the Vehicles Accelerator Cable works?

http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-cable.html

-------------

How exactly Vehicles Accelerator Pump Diaphragm Works?

http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-pump.html

--------

2000 Toyota Avalon: Engine Lean Codes and Knock Sound on Acceleration?

http://whatisbyme.blogspot.in/2012/05/2000-toyota-avalon-engine-lean-codes.html

---------

2004 Toyota Avensis: Acceleration And Deceleration makes noise on Front End?

http://whatisbyme.blogspot.in/2012/05/2004-toyota-avensis-acceleration-and.html

---------

Wheel hop under hard acceleration?

http://technoanswers.blogspot.in/2012/04/wheel-hop-under-hard-acceleration.html

--------

2009 Chevy impala accelerator pedal sensor?

http://technoanswers.blogspot.in/2012/02/2009-chevy-impala-accelerator-pedal.html

---------

Nissan Pathfinder stalls and bucks on Acceleration?

http://technoanswers.blogspot.in/2012/02/nissan-pathfinder-stalls-and-bucks-on.html

--------

-------------

These details will help.

Thanks.

Nov 27, 2012 | Cars & Trucks

1 Answer

Engine hesatates when accellerate


It can be fuel pressure issue or its the problem with accelerator pedal or its clogged filters causing there.
There are many other possibilities.I suggest you to go through the list of help links mentioned below,these will help you to confirm where the actual fault lies:-------
Jerks and Hesitates During Acceleration? http://technoanswers.blogspot.in/2012/07/2004-dodge-town-country-jerks-and.html
-----------
Loss of acceleration? http://technoanswers.blogspot.in/2012/02/loss-of-acceleration.html

---------
Headlights flickering and car hesitates to start? http://howtobyme.blogspot.in/2012/02/headlights-flickering-and-car-hesitates.html

--------
How exactly the Vehicles Accelerator Cable works?

http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-cable.html

-------------
How exactly Vehicles Accelerator Pump Diaphragm Works? http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-pump.html

--------
2000 Toyota Avalon: Engine Lean Codes and Knock Sound on Acceleration? http://whatisbyme.blogspot.in/2012/05/2000-toyota-avalon-engine-lean-codes.html

---------
2004 Toyota Avensis: Acceleration And Deceleration makes noise on Front End? http://whatisbyme.blogspot.in/2012/05/2004-toyota-avensis-acceleration-and.html

---------
Wheel hop under hard acceleration? http://technoanswers.blogspot.in/2012/04/wheel-hop-under-hard-acceleration.html

--------
2009 Chevy impala accelerator pedal sensor? http://technoanswers.blogspot.in/2012/02/2009-chevy-impala-accelerator-pedal.html

---------
Nissan Pathfinder stalls and bucks on Acceleration? http://technoanswers.blogspot.in/2012/02/nissan-pathfinder-stalls-and-bucks-on.html

--------
Acceleration lag problem? http://repairhelpcenter.blogspot.com/2012/01/acceleration-lag-problem.html

-------------
These details will help.
Thanks.



Nov 23, 2012 | Cars & Trucks

1 Answer

I have a 2004 Nissan Armada 4x4 Off Road 5.6 Liter with 80k miles. Heater only blows passive-warm air once vehicle is warmed up and driving. I pulled out the glove box, the hoses from the Core are...


i have a 2006nissan pathfinder ,and i have to turn up heat to max and then turn back to 20 or so
cause if i set it at 20 it does not warm up
so try leaving high for a short period then lower it back to your optimum setting

Feb 11, 2011 | 2004 Nissan Armada

Not finding what you are looking for?
2005 Nissan Armada Logo

852 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

yadayada
yadayada

Level 3 Expert

60792 Answers

Phil Lovisek
Phil Lovisek

Level 3 Expert

705 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...