Question about 1983 Buick Regal

1 Answer

83 regal keeps cutting off in traffic

My 83 regal keeps cutting off in traffic and cranks right back up i've changed everything from the feul pump to the spark plug and spark wires even the distributor and module but it's still doing the same thing i need some help

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 2,920 Answers

Its going to be something in the steering column...my regal did the same thing to me and i ended up having to put in a new column

Posted on Feb 19, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Feul problem


Lots of things could cause a no-start, Hendrik. Is your "Check Engine" light on? If so, please have someone get the OBD error codes from the car's computer.

Does it crank but not fire?

If it doesn't crank, check the battery condition, battery connections, ground connections to frame and engine block, starter solenoid, starter motor.

If it cranks, doublecheck your fuel pump installation. Make sure the new fuel pump is properly connected and properly electrically grounded. Look for a fuel pump fuse. Check for proper fuel pressure at the fuel rail, check the fuel flow rate. Check for spark, check or replace spark plugs, distributor cap, rotor, plug wires. Check valve timing, replace timing belt or chain if necessary. Check compression.

Aug 03, 2014 | 2001 Kia Sportage

1 Answer

My 99 buick regal cranks over and starts but has trouble running. If you give it gas to help it through the start up it levels out and runs fine. Fuel pump is good, I've changed spark plugs and wires,


sounds like a stuck open EGR valve to me , take it off of a cool engine and spray some carb cleaner around the seat see if any leaks through to the other side. If it does The valve is bad. Also check out your throttle body for carbon and gumming. W/ engine off spray an appropriate carburator
cleaner into the opening and clean throttle plate and bore with a rag until shiney. put all the air cleaner hoses back together and hold throttle to floor momentarily until engine starts, then rev up half way and release throttle twice quickly, now allow engine to idle idle should be stable and smooth. If not then check for other sources of vaccume leaks.

Apr 18, 2013 | Cars & Trucks

1 Answer

The car will crank but it will not start any suggestions??


Definitley NOT an O2 sensor(they don't even do anything for the startup).What happens if you shoot some starting fluid in it?

Oct 07, 2012 | 1997 Chevrolet Cavalier

1 Answer

Car wont stay running and i thought it was feul pump or fuel filter. i replaced both and it still wont run. it will crank sometimes but cuts right off like its not getting fuel, at least thats what i was...


not value cover gasket leak out around spark plug not to inside piston. but cut right off how hot? no water in oil? or filled up piston? maybe head crack. fuel pump pumping? crack line not went eng hot. ture key on look or someone look 10lb of pressure comeing out fast.water no. antifreeze yes.

Sep 24, 2011 | 1996 Saturn SC

1 Answer

Only starts half the time


If it cranks and you got fuel pump and filter changed, then have a look at the ignition components also, like spark plugs, coils, spark plug wires. also make sure the wiring for the fuel pump is not loose or anything. Hope it helps and let me know if you need more advice. Please don't forget to rate the answer it helps with my rating, thanks!

Apr 21, 2010 | 1995 Buick Regal

1 Answer

FUSE KEEPS BLOWIN (STARTER, IGNITION, & FUEL # 8 FUSE)


you need a new starter I just went through this problem had my starter changed and have not blown any fuses in days....oh and by the way getting to the starter was not and easy task.

May 28, 2009 | 1999 Dodge Stratus

1 Answer

83 regal not cranking


If you have replaced the distributer then the timing could be off. Did you set the distributer rotor in the same position when you took it out? If not then you will have to readjust it. But first try to loosen the hold down clamp and turn it very lightly at a time and try to crank. If it gets worse then go the other way very little at a time, and try. Be sure to tighten the clamp before each try.

Feb 17, 2009 | 1999 Buick Regal

1 Answer

Galant Special Edition 1994 Motor does not start


this maybe caused by no fuel or faulty fuel pump, ignition coil, wire and plug crank position sensor. first check for spark by removing on spark plug wire and put a spark plug in the spark plug wire boot, donot touch the plug only the boot have someone crank the car over. if you see spark, that part of the ignition is good. if not, check the coil resistance if should 40 to 80 ohm with a volt meter pf not replace. if ok, but no spark check the igniton control madule make sure the coil and module are receiving current. if not check the fuse that feels them. if it is ok, check distributor cap and rotor. if rotor and cap are fine, check for fuel at either the fuel filter, the fuel return line or removing some spark plug and see if they are wet. if there is no fuel check the fuel pump and the fuse and relay that control the pump. if there is fuel with high pressure but there is no spark, check the crank sensor for signal with a volt meter while cranking the vehicle

Jan 02, 2009 | 1993 Mitsubishi Galant

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

213 people viewed this question

Ask a Question

Usually answered in minutes!

Top Buick Experts

yadayada
yadayada

Level 3 Expert

60960 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Buick Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...