Question about 1988 Chevrolet S-10

1 Answer

89 s10 has fuel fire everything fine except injector pulse

Ran new wires to computer changed injector and replaced computer
injector has power to it. before i changed computer injector was always on pouring gas, now still has power will not pour gas unless i ground it by wire that goes to computer then it pours still no pulse. accidently found this when i was using a test light to see if the circuit to the injector was completed test light lit up and injector started pouring.
this has got to be a simple ground or something because the truck ran fine (other than a small miss) prior to replacing cap rotor plugs and wires. any ideas on what wires that go to what could affect the computer grounding this circuit.? have already ran every wire in this circuit new. from computer pink wire runs to a pig tail that splits to ecm fuse, egr solenoid, and injector. blue wire runs straight to computer. thanks in advance as i am at a loss on this one.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 15 Answers

Have you checked the wiring diagrams on the repair manual?

Posted on Feb 21, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1989 caprice with 350 tbi injectors won't pulse anymore


If you have spark, the computer is getting the signal to pulse the injectors.
If you have power but no ground pulse, you may have fried the driver in the computer again.
You could get a used computer from a junk yard to test it.
There could be a short in one of the injectors or the harness at the computer, or a break in the circuit from the computer, and that could kill the driver in the computer.

Jan 18, 2013 | Cars & Trucks

1 Answer

No injector pulse on daihatsu feroza


injector pulse is just controlled by the ecm or computer as some would say,u said u replaced wires? did u have a fire or melt wires? ecm is known to go bad on these,had a few of these trucks back in the day.

Oct 05, 2012 | Cars & Trucks

1 Answer

1989 chevy 2.8l v6 MPFI injectors have no signal on the noid light. The car starts with starting fluid sprayed into intake and actually runs until starting fluid is consumed. if I place a rag in the intake...


look for a bad ground, you can try running a new ground from the battery to the body, i had an 89 corsica that would not fire until i ran the new ground wire.

Oct 01, 2012 | 1989 Chevrolet Corsica

3 Answers

Hi I have an 87 s10 blazer 2.8L 4x4 and does not want to spray fuel into the throttle positioning sensor but fuel goes to and from it, I've checked the fuses replaced the fuel pump, it will fire with ether...


One side of the injector plug at each of the two injectors has 12 volts key on engine off.
The other side is grounded by the PCM computer to fire the injectors.
Put a test light across one of the injector plugs while cranking, Watch for flashing.

Jan 27, 2011 | 1987 Chevrolet Blazer

2 Answers

89 Chevy s10 does not get gas to engine replace fuel pump, fuel filter, fuel injector.starts when I pour gas in engine


Sorry to say this but its the computer. to checkit you will have to buy a noid light and put it in the injector harness.. if it does not blink when you turn it over then the drivers are out in the computer. It can not be fixed. replace the computer. Just remember that injectors rarely go out. I have replaced two or three of them. computers do I have replaced twenty+.

Nov 18, 2010 | 1989 Chevrolet S-10 Blazer

1 Answer

I have a 1996 jeep grand Cherokee with the 4.0 inline 6 and I have 48lbs of fuel pressure at the fuel rail and we used a pulse tester on the injectors and they showed that I have no power to them what...


You need to check with a test light now, and see if you have voltage at any of the two wire's going to the injector, if you do have voltage, reverse test light at battery and check other wire, that will be ground pulsation, if you have voltage and no ground, ground is control by the computer, computer will need to be replaced.

Aug 23, 2010 | Jeep Grand Cherokee Cars & Trucks

1 Answer

Got a good one. my 91 coupe original 5.0 car. motor is new. it ran for two days then went to fire on third day and now will crank and crank but wont fire. got 42psi on fuel pressure 148psi compression on...


the fuel injectors are fired by computer producing a ground signal to them. so its unlikely they are fireing at once.possible power supplie problem but that would cause no injector pulse.beings how the engine was just replaced i would go over every wire and all grounds to make sure they are not shorted or pinched under a manifold or something.if you pull the plugs and they are black then you are getting to much gas. in wich case i would check to see if the fuel pressure regulator diaphram may be ruptured.if you take off the vacuum hose to it and look for moisture from gasoline. or leave hose off and try to start it if gas squirts out that regulator is bad and needs replacement

Apr 15, 2010 | 1991 Ford Mustang

2 Answers

89 s10 2.5 has fuel and fire injector has power but no pulse


injector pulse is just controlled by the ecm or computer as some would say,u said u replaced wires? did u have a fire or melt wires? ecm is known to go bad on these,had a few of these trucks back in the day.

Feb 16, 2009 | 2000 Chevrolet S-10

1 Answer

No power to injectors


are they plugged in?
check the fuse

Dec 13, 2008 | 1992 Chevrolet S-10

Not finding what you are looking for?
Cars & Trucks Logo

276 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

63291 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21981 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...