Question about 1996 Dodge Avenger

1 Answer

Surges when you first stop and start going again

I have a 1996 dodoge avenger ls that act like it not getting gas. I replace sensors, wireset, plugs fuel filter egr valve and now thinking about replacing the fuel pump. Also the distrulator. I can stop at a light and the car pull off slow like it need more gas and than it speed up, once you get going it fine until you stop again. I change the wires out and run good for a day.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    MVP:

    An expert that gotĀ 5 achievements.

    Master:

    An expert who has achieved Level 3.

    Sergeant:

    An expert that hasĀ over 500 points.

  • Master
  • 450 Answers

Any air leaks check it out

Posted on Mar 17, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 1998 dodge avenger se 6 cyl,, an it wont start its not the battery or the Fuel Pump not the Starter it just dont have any spark it acts like its out of gas but has a haf tank all looks good an...


when you turn on key, do you hear the fuel pump run for a couple of seconds ? check fuses, & fuel pump relay,(it has a fuse also). fuel pump cannot be ruled out. next, your coil provides spark to plug wires, with an assistant, in drivers seat, pull off a spark plug wire from a spark plug, use a paper clip, insert into end of wire, with the helper turnning the key to crank engine, hold the wire w/clip about an 1/8 " from clean metal, to see if a spark occurs, wear gloves, or you may get jolted, if you know what I mean. if no spark, replace coil, I would replace plug wires also. remove spark plugs , if worn, replace. just do it !!! you need spark correct ? well then ! whens the last time you replaced fuel filter ? do it ! a new air filter will help also. air, fuel, spark all work together. go to parts store, if you can, see if they can pull any trouble codes . if you can't do the work mentioned above, it just might be your problem . now get to work , make it happen !!!!

Feb 17, 2013 | 1996 Dodge Avenger

1 Answer

How do you know if your spark plugs are the problem?


bad spark plug or bad wire will cause one cylinder not fire cause engine to surge.but change spark plugs and wires, if engine still surge have fuel filter changed, check fuel pressure weak fuel pump will cause engine surge.if you see check engine light flashing code scan for faulty TPS SENSOR OR FAULTY FUEL INJECTOR OR BAD IGNITION COIL.FAULT IN THE PCM.

Sep 23, 2012 | 1996 Buick Skylark

2 Answers

Was driving car it died and want start back replaced distributar plugs and several other parts


Try crank sensor dodges are notorious for that.i think it sits on the side of the ****** .under air box down low it's hard to see maybe pull up online to see

Apr 21, 2012 | 1996 Dodge Avenger

1 Answer

I hace a 2003 lincoln ls v8 3.9l. I was driving


Try taking the exhaust pipe loose at the manifold. I had a Chevy Suburban that acted the same way, it turned out to plugged catyletic converter. The converter wasn't letting the exhaust out, the truck had no power, it would stall and then start right up and great for about five seconds the run rough and quit. Once I disconnected the exhaust it started right up and ran great. You could also try taking the O2 sensors out (for test purposes) ahead of the converter that will give the exhaust a place to go

Jan 12, 2010 | 2003 Lincoln LS

1 Answer

1996 GMC Sonoma acts like the carbuater is clogged


Replace the throttle position sensor.

May 19, 2009 | 1996 GMC Sonoma

1 Answer

1999 Dodoge Avenger keeps stalling


is the throttle position sensor sticking.does the go from 1000 to 4000 rpm steady or is there a skip in the motion.usauly the hole starting back up by it self issue indacates a bad sensor

Feb 26, 2009 | 1999 Dodge Avenger

1 Answer

My 1997 Dodge Avenger's engine won't start


Try cam and/or crank sensor. If crank to cam timing isn't detected properly it'll crank all day but won't start. I had similar problem on my 2.5L V6 Avenger....drove home fine, no engine light, next morning it cranked, but wouldn't start. The crank sensor was faulty.

Jan 11, 2009 | 1997 Dodge Avenger

Not finding what you are looking for?
1996 Dodge Avenger Logo

95 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dodge Experts

yadayada
yadayada

Level 3 Expert

60541 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21927 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Dodge Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...