Question about 1999 Chevrolet Blazer

1 Answer

97 S10 4x4, 2 Wheel light does not turn back on immediately

When i push the 4 wheel hi button, the 2 wheel light goes off and the 4 wheel high light comes on, as it should. But, when i go back into 2 wheel, the 4WD light goes out, but the 2WD ling does not come on. Over a couple of days it comes on. By the "feel", it is shifting back, but just not turning the light on.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 7 Answers

I had a 2000 blazer do the same and it was a vacuum hose leak by a little box in the middle of the firewall.

On my brother's blazer the hose leak was under the top part of the driver's side fender.

Posted on Feb 24, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

97 yukon stuck in 4-wheel low. how do I get it in 2-hi?


select 2 high and reverse truck see does it come out

Feb 25, 2010 | 2003 GMC Yukon

1 Answer

4 wheel drive doesn't work


sounds like the shift motor on the transfer case is going bad.

Aug 29, 2009 | 2004 Chevrolet S-10

1 Answer

GMC Sierra 4 wheel drive won't disengage


i had the same issue change push button cluster

May 04, 2009 | GMC Sierra 1500 Cars & Trucks

1 Answer

1994 K1500 4 Wheel Drive Issue


No probably not, first check the fuse for the 4wd in the fuse box if that's OK its likely the actuator on the front axle..........providing the shifter handle moves to the proper location and if its push button the lights light in the switch when selected...the actuator plugs into the wiring harness and screws into the front differential.an easy remove and replace part even for a novice.

Dec 22, 2008 | 1999 Chevrolet Silverado 1500

1 Answer

4 wheel low works but 4 wheel high does not.


sounds like the encoder on the side of the trans on the drivers side

Nov 24, 2008 | 1999 GMC Jimmy

1 Answer

4-wheel high problem


reset the 4x4 computer by pulling out the courtesy lamp fuse and the ATC fuse for 1 minute then reinstall both fuses then cycle the key on and off 5 times. if this works please rate.

Nov 17, 2008 | 1998 Chevrolet Blazer

1 Answer

2004 Suburban 4 wheel drive


set as default most likely either that or computer error. please email me at meanness628@aim.com with any other info or questions

Sep 29, 2008 | 2004 Chevrolet Suburban

Not finding what you are looking for?
1999 Chevrolet Blazer Logo

303 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

61168 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...