Question about 1984 Ford Thunderbird

1 Answer

Turn my car on and no spedometer

Checked all fuses, sesor on trans is hook up

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 30 Answers

You have to pull the guage cluster out and check to see if the speedo cable is hooked up if it is and still doesnt work you should disconnect it from the back of the guage cluster and check to see if the tips are messed up some older cars that happens on the tip of the cable there will be a little square that fits into the cluster you will know what i mean when you pull it apart just make sure the corners are not rounded on it that should sum up your problem if they are you need a new cable if they are not reinstal the cable and make sure its tight and go for a ride and see if it works if everything is good it should work no problem

Posted on Feb 20, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Window won't roll down, powersteering doesnt work, spedometer doesnt work, ac doesnt work. all this happend when i charged the vehicle


Hopefully all you blew was some fuses. Need to check all fuses under dash & in relay/fuse box underhood. Easiest way, hook up test light to ground & test across all fuses. If blown 1 side of fuse will get power,but not the other side.

Jun 15, 2010 | 1998 Lexus Gs 400

2 Answers

My Spedometer and Tacometer have stopped functioning.


Sounds like a ground problem.Questions:
1) Do you have electrical or electronic troubleshooting skills and tools?
2) Can you read schematics?
3) Are you comfortable removing instrument cluster and working behind dashboard if necessary?

If all the above are true, then I might be able to hook you up with the help you need. However, it might be too much to post here.

May 24, 2010 | 1994 Volkswagen Jetta

2 Answers

Transmission not shifting


With the wheels off the ground ,does the spedometer work? No spedometer no shift. If the truck takes off in second gear,and no shift. You have lost power to the trans. It is in the default mode. Check and make sure that ALL tail light bulbs are good, Really, A blown tail light bulb of fuse will stop it from shifting

May 15, 2010 | 1996 Chevrolet C/K 2500

1 Answer

2007 dodge ram fuse problem


my 2008 dodge ram is displaying no fuse underneath the spedometer. it makes a clicking noise about 5 times and turns over fine. runs normal/drives normal. it delays when turning off (i turn the key off and it takes about 5 seconds to turn off) remote entry does not work.

Feb 12, 2010 | 2007 Dodge Ram Truck

1 Answer

My spedometer quit working and transmission started slipping at the same time on a 96 corsica whats wrong with it


you will need to go to a transmission shop and get the car hooked up to a computer to get the fault code to find problem, id say your gearbox may need repairing or the trans computer

Jan 19, 2010 | 2001 Ford Focus

2 Answers

I just replaced trans in 1996 dodge ram P/U with 318 and now it wont start turns over but wont start is there a crank sesor i unpluged maybe?


let me guess your asr is buzzing to that sounds like a bad ground that is tricky you might have to take it in. check the grounds and so thats the best i can do to help

Dec 21, 2009 | 1996 Dodge Ram

1 Answer

Hello, I have a 2001 dodge ram 1500 5.9 ltr 4WD. My spedometer stopped working. My check engine, ABS, and break lamps on the dash are all on. Shortly after my spedometer stopped working It seemed like my...


have you tried to replace the speed sensor in the rear end my 99 durango did basically the same thing speedo wasnt working right brake lights on dash check engine light on

Jul 27, 2009 | Dodge Ram 1500 Cars & Trucks

1 Answer

The fuel gauge, and spedometer, have turned off.


u may have a blown fuse check fuse box and look for blown fuse

Jul 06, 2009 | 2001 BMW 325

1 Answer

99 f350 fuse for the speedemeter


there is no speedo fuse . if it was a fuse the whole cluster would not be working . i think speed sensor with is on the trans . you should have a shop check this befor you start replacing parts

Jun 10, 2009 | 1999 Ford F350 Regular Cab

1 Answer

Dodge ram1500 brake light abs light spedometer odometer no work


you should have your vehicle scanned with OBDII.(on board diagnostics) . take it to a shop and tell them your engine light is on and they'll hook a computer to it and find out why

Feb 17, 2009 | 1999 Dodge Ram

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

63 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

63801 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21990 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...