Question about 1993 Isuzu Rodeo

2 Answers

NO POWER WHEN DRIVING

I have a 1993 Izusu Rodeo, 5 speed 4wd. problem; no power when driving it feels like a plug fuel filter or something.Changed ingnition wires, spakplugs and fuel filter.. please help

Posted by on

  • 1 more comment 
  • MISFITS Feb 23, 2009

    My rodeo had the same exact problem then my dad changed out the spark plugs and and the fuel filter then it ran perfect just like it did before...for about 3 days. Now it wont even run. We changed the ignition module and now none of my coils packs spark....dont know what to do someone help =/

  • duane534 May 11, 2010

    Which engine is it? For that model year, there was a 2.6L option that was, frankly, weak. A fine motor with amazing reliability but still only 120 HP.

  • Stan Moffett May 11, 2010

    does it backfire, and how many miles

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Fixed problem it was the ignition coil, now it runs very smoothly! thanks to all that helped
Jon.

Posted on Mar 17, 2009

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 3 Answers

If you fear a clogged fuel filter, change it. It's easily accessible and inexpensive.

Posted on Feb 21, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Multiple misfire on my 03 rodeo izusu. spark plugs and wires, coil pack,coolant sensor changed. Not sure what else there is I can do.Any one having the same issue ? Help


In brief, you need spark at the right time, fuel, and compression to have power.
You would need to know if you have all three on all cylinders.
This would include fuel injectors and engine valves.

Jan 30, 2013 | 2003 Isuzu Rodeo

2 Answers

Lacks power when excelerating


your second tak is farther away from the motor more line to leak air could be getting into the fuel line from the second tank and that is big loss of power and performance the issue i think you are haveing with the first tank is just the switch is probubly going bad.

Feb 16, 2012 | 1993 Ford F350

1 Answer

Replaced the MAP sensor, MAF sensor, fuel filter, no vacuum leaks, but my 2000 Izusu Rodeo LS 4WD still surges a little and sometimes stalls. What else could be wrong?


Let the vehicle warm up for 10 minutes at idle and shift it to Reverse if the RPM bumps up thats fine but if it dosent then replace the IAC idler air control valve.

Oct 15, 2011 | Cars & Trucks

1 Answer

2008 f250 5.4l 4wd crew cab short bed: out of warranty now. I feel it should have more power. Doesn't miss but feels very sluggish on take off and can't pull itself up a moderate incline without kicking...


Hi,
What's your millage ? I had the plugs changed on mine as well as the 2 fuel filters at 65K and totally solved the power problem pulling my 5er. On these 5.4, you should have spark plugs changed every 40k miles. They are still good, but become hard to pull out if you pass that millage.

Hope that will help,
Bernard

Jan 08, 2011 | 2008 Ford F 250 Super Duty 4WD

1 Answer

Tach. drop's to zero while driving 70 ?


I have had the almost same problem twice. A 'thump', like the engine missed a fire and tach drops. Seems OK after restart. Electrical? Timing chain slip?
Has 135,000 mile. Any clues?

May 15, 2010 | 1997 Buick Park Avenue

1 Answer

1995 Isuzu Rodeo intermitantly loses power at highway speed. I can speed up only by pumping the gas pedal. I replaced the fuel filter and continue to have same problem. Engine seems to shudder and lose...


Since you replaced the filter it sounds like a classic fuel pump problem. Don't know your car but best thing to do is buy a repair manual for your car like haynes or chilton's at your local AP store. Read up on it at the trouble shooting section and the RR section. Good luck.

Oct 19, 2009 | 1995 Isuzu Rodeo

1 Answer

While driving at highway speeds Rodeo slows down and loses power. If you pump gas pedal car will slowly pick up speed after downshifting. Some days no problems other days this lack of power is constant....


1st check your breather pipe on the fuel tank as it could be blocked and not breathing air into tank
This will happen after filling up with fuel and untill you haved used about 1to 2 gallons.
Other wise check fuel pump for either slight air leak or filter blockage...

Sep 27, 2009 | 1995 Isuzu Rodeo

Not finding what you are looking for?
1993 Isuzu Rodeo Logo

Related Topics:

225 people viewed this question

Ask a Question

Usually answered in minutes!

Top Isuzu Experts

yadayada
yadayada

Level 3 Expert

63801 Answers

Steve Hurc
Steve Hurc

Level 3 Expert

450 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21990 Answers

Are you an Isuzu Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...