Question about 1987 Nissan 300ZX

Open Question

300zx 94 wont start changed ecu crank sensor and no good

My 94 300zx wont start have changed ecu and crank sensor and ptu
and still have no luck its getting spark and is getting fuel also fuel pump is running fine got it going once sounded awfall but would only stay running when the rev's were high taking my foot from the pedal then it died
since then wont start also all major wireing is checked please
help going crazy was pluged in to diagnostic and showed primary ignition circut dose this mean anything

Posted by on

1 Suggested Answer

  • 33 Answers

SOURCE: my 94 300zx tt wont start changed ecu cas and ptu

check timing, see if belt may have slipped out of timing, and need pressure tester to test pressure where the fuel goes into the fuel filter. check for vaccuum leaks.

Posted on Feb 17, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 1988 300zx non turbo 3.0 just replaced the ecu thinking it was the problem but its not. My car will turn over and it sparks, tested the fuel pressure and it makes 42lbs so thats not the problem...


The pulse to switch the coils comes from the crankshaft sensor via the ecu. Pulse to switch injectors comes from the CAMshaft sensor via the ecu. Check injector wiring plugs and confirm there is an ignition live of 12v at one side. Other side should have an earth pulse when cranking.Once you know which is missing you can trace the fault backwards. ( if no ignition live then check wiring, relay, fuse etc) if no earth switching check camshaft sensor and wiring.

May 29, 2011 | 1988 Nissan 300ZX

1 Answer

WONT START WHEN COLD CRANKS FINE. HAS CODE 54 CAM


ok, any obd code means the sensor concerned is not detected by the ecu, or is way out of range of the normal signal the ecu expects. I would therefor check the electrical path between the sensor and the ecu terminals, it may be just a chafed cable or wire.

Jan 14, 2010 | 1997 Dodge Caravan

2 Answers

300zx wont start has spark plugs are wet


Wet spark plugs indicate cylinder flooding and the existence of a no spark condition.

Check your fuel and ignition systems for proper operation and repair/replace components as necessary.

Dec 25, 2009 | 1993 Nissan 300ZX

1 Answer

Starts when it wants too


If your car is the 1.6 they have two common faults -

Crank sensor & water coolant sensor for ECU (located in thermostat housing)

Not too expensive to get changed, fairly easy DiY


Dec 03, 2009 | Hyundai Motor 2003 Elantra

1 Answer

Car wont start


being 94' im sure it has high miles, cam and crank sensor common to fail over time do to wear and heat exposure. check the basic, make sure you getting fuel and sparks. fuel pump only work as long the engine is turning over due to the crank sensor sense the flywheel turning. crank sensor may be faulty. no sparks, check coil make sure is good and putting out 12v, auto zone can test it for free. good coil, than check cam sensor, cam sensor senses the cam turning and tell the ecu to tell the coil to disperse the sparks to the plugs. cam and crank sensors, there no way of testing it but replacing the unit unless you have the special equipment to test it; both is fairly cheap to replace, check ebay.

Oct 24, 2009 | 1994 Mazda MX-6

1 Answer

Ok i gotta 91 TT and i replaced the ignition coil connectors and the ignotion coils themselfs, now its seems as two of my ignition coils wont get power to them to create a spark on my sparkplug (of...


ptu (power transistor unit)

http://www.mdsmarthome.com/z/Z%20Tech/Z%20Tech%20PDF's/PTU%20Repair.pdf

the series 1 ptu goes out really often. you can repair it or buy a new one.

had the same problem with mine replaced the ptu and worked like new.

the ptu is on the passenger side timing cover with two connectors going to it.

Jun 30, 2009 | 1991 Nissan 300ZX

1 Answer

My 94 300zx tt wont start changed ecu cas and ptu


check timing, see if belt may have slipped out of timing, and need pressure tester to test pressure where the fuel goes into the fuel filter. check for vaccuum leaks.

Feb 16, 2009 | 1990 Nissan 300ZX

2 Answers

Car not starting


check the mass air flow sensor

Jan 25, 2009 | 1986 Nissan 300ZX

1 Answer

My 1987 300zx cranks but wont start.


I had the same problem last year mine turned out to be a crank sensor I don't know if that is your problem for sure mine wouldn't send any spark from the coil to the spark plug replaced crank sensor inside distributor and fired right up the dealership called it a cam sensor my book called it a crank sensor either way its in the distributor

Dec 16, 2008 | 1987 Nissan 300ZX

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

182 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

yadayada
yadayada

Level 3 Expert

60867 Answers

Phil Lovisek
Phil Lovisek

Level 3 Expert

705 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...