Question about 1999 Chevrolet Silverado 1500

1 Answer

97 Silverado Started then died for good

I started my truck this morning and when I put it in drive and took off the truck died. Turning the key produces no power to anything. (radio, locks, ignition) Any suggestions on where to look first?

Posted by on

  • christoph259 Feb 16, 2009

    I'll try that out when I get back to it. Can you think of anything else it might be off hand?

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 100 Answers

Check your battery connections for tightness

Posted on Feb 16, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

97 grand prix progressive prob,s RPM gauge mid stream drop to 0


Have the fault codes read. Replace faulty items. Use only genuine items as non-genuine replacement are not always compatible with the OEM fitted CPU units.

Jul 04, 2013 | Cars & Trucks

1 Answer

93 lebaron died while running, now clicks when being jumped.


From what you describe, my guess is that eventually you will replace the starter

Apr 24, 2013 | 1993 Chrysler Lebaron

2 Answers

My 98 chevy k1500 5.7 vortec started up fine i put it in reverse to bak up when i released brake it died an started bak up fine a few days later i died while driving so i replaced battery an altenator it...


Check your fuel pressure it should be 60-66 psi with key on engine off.If its not within these specs then replace the fuel pump and filter.Sounds like the pump might be weak.

Jan 08, 2012 | 1999 Chevrolet Silverado 1500

1 Answer

This morning my 2000 Z71 Silverado 1500 had trouble starting. It took about 3 attempts, then started sputtered and die. On the 4th attempt I pumped the gas, held the engine rev about 3500 then it was fine....


May be a problem with the mass air flow sensor located on the air cleaner assembly. Dust particles sometimes collect on the very small resistors on the MAF Sensor. Buy some electronic dust spray you use for computers and spray the resistors. Be carefull not to touch them, they are very sensitive. Thanks.

Apr 18, 2011 | 2000 Chevrolet Silverado 1500

1 Answer

I have a 1997 Chevy Malibu (140K miles). The car was well maintained by prior owner. I have experienced the antitheft problem where I get locked out and have to wait 10-15 minutes. That has occurred...


i to have had some FUN with this darn system and replaced ignition cylnder(dealer has to program)can help usally for a few years ....but i dont want to swaer thats the samething causeing yours......feel free to repost

Dec 21, 2010 | 1997 Chevrolet Malibu

1 Answer

I have a 97 f350 with overdrive problem


I had the same thing happen to my 97 f350 7.3. It then started to slip badly. Took it to the dealership. I had to put in a new tranny. They also said that if you tow or drive steep terrain then it would be a really good idea to get a bigger inter cooler for the tranny. The whole thing started because it got over heated. Hope this helps a little

Aug 25, 2009 | Ford F-350 Cars & Trucks

2 Answers

I have 1998 Chevy Silverado with over 200,000 miles. One morning I started it up just fine, backed out of the drive way, and it just died. I turned the ignition to off, and turned it back on and parked it....


Check your battery terminals. They may be corroded or just loose. If you get it running again have the battery and charger tested at an Advance or Autozone.

Hope this helps.
Rich

Aug 19, 2009 | Chevrolet Silverado 1500 Cars & Trucks

Not finding what you are looking for?
1999 Chevrolet Silverado 1500 Logo

Related Topics:

137 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

63242 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21981 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...