Question about 1999 Ford Explorer

1 Answer

1999 Ford Explorer XLT - Code P1131

I cleaned the original MAF sensor 4 times and every time it would return to normal for a day or two and then run rough again. I think it was because I disconnected the battery. I replaced the MAF sensor with a rebuilt one...same symptoms. What's the next step - oxygen sensor? Which one?

Posted by on

  • Anonymous Mar 15, 2014

    2005 ford mustang 4.0 what two wires do they go to MAF sensore

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

P1131 code is a o2 sensor

Posted on Feb 16, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Rough idle


This could be the O2 sensor or the MAF sensor. Try disconnecting the MAF sensor and if the idling seems normal, the MAF sensor is bad. Yet, it is always better to get the codes read if the CEL in blinking.

May 08, 2013 | Cars & Trucks

1 Answer

1997 Mercury Mystique check engine light on


A few things ,97;tune up, fuel filter,air filter,clan throttle body,put in tank some fuel injection cleaner good one not cheap.

Mar 26, 2013 | 1997 Mercury Mystique

1 Answer

2003 Pontiac Vibe - 4 Cyl. 150k miles. Ignition coils keep going bad - every 4-6k miles. Coil 1 has been replaced 4 times, Coil 3 once. Coil 4 twice in the past year (20k miles). All spark plugs


Install new spark plugs, 4 new coils & replace the oxygen sensors

O2 Sensors are only good for 100,000 miles, then slow
down or quite

No idea why the coils do not last 5 or 6 years

Cylinder #1 is always at the front on a 4 cyl

Go to Rock Auto --Buy Wells Coils,NGK Double
Platinum Plugs & NTK O2 Sensor

Those parts are expensive because you have a Totota
Motor I guess

Clean MAF Sensor with CRC MAF Sensor Cleaner

Jan 08, 2013 | 2003 Pontiac Vibe

1 Answer

P1151 code polo


Hi there:
DTC P1151 is due to a failing MAF (Mass Air Flow )sensor. Before to replace some part, I suggest to clean the MAF. If the MAF code comes back on then replace it.


Hope this helps; also keep in mind that your feedback is important and I`ll appreciate your time and consideration if you leave some testimonial comment about this answer.

Thank you for using FixYa, have a nice day.

Jul 13, 2012 | Volkswagen Polo Cars & Trucks

1 Answer

I received a p0102 code,maf sensor,i replaced the maf,i erased the code and my 1997 jimmy 4.3 still runs rough,but when i disconnect the maf the truck runs fine and the code returns,when i reconnect the...


When you disconnect the maf the computer relies on other sensors to determine correct fuel/air mixture, this is why the truck runs smooth. In my experience when the maf is connected and it begins to run dough it's because the wiring to the sensor is damaged.

Mar 06, 2011 | GMC Jimmy Cars & Trucks

1 Answer

Repair a4 audi 2004, mass air flow sensor, catalitic converter, car stalls when accelerate.


hi this might not be the MAF but the MAP sensor as this is the thing that normally gives you this sort of fault, the MAF adjusts the air and fuel mix but the MAP adjusts the air and fuel mix and also the timing via the ECM , normally if it is the MAF it will just idle rough and still run as normal, but jerky and bogs down but does not stall, so if anything i would opt for the MAP sensor first before the MAF...hope this helps

Sep 20, 2010 | 2004 Audi A4

1 Answer

Locating maf sensor


I think it may be the battery or the alternator not the maf sensor.Sounds like its not charging thats why it runs rough when you are running multiple things at the same time.Have your battery and alternator checked first.Hope this helps

May 04, 2009 | 2001 Volvo S40

3 Answers

2000 bonneville w/3600 v-6 and 99000 miles never had problems, original owner. stalls sporadically but no codes come up on diagnostic. acts like a loose connection, feels like running out of fuel. NEED...


i had the same problem a few months ago. check your fuel filter. mine was on the car for some time and after replaceing it, car runs great. hope this helps. i would also check your air cleaner. if to dirty will run rich and with a dirty fuel filter your car will stall.

Mar 23, 2009 | 2000 Pontiac Bonneville

5 Answers

2000 kia sportage ex, 4 cyl.


Yes there is a sensor that controls Fuel/air ratio.It's called a MAF (mass air flow sensor)
But I think you should have the EGR (Exhaust gas recirculation)valve checked
and The TPS (throttle position sensor)maybe dirty.

Although may things can cause this issue,I would look at the items above first.


Please rate this a blue fixya

Feb 13, 2009 | 2000 Kia Sportage

Not finding what you are looking for?
1999 Ford Explorer Logo

Related Topics:

845 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

70387 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Ron Lankford

Level 3 Expert

5386 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...