Question about 1996 Jeep Grand Cherokee

1 Answer

1996 j/c hardstarting. First start usually ok when engine cold.

Recent tune-up. water pump replaced recently but was running a bit hot for a short period of time when pump went out. Ran fine for a week after w/p replaced. Now hard starting. re-checked plugs and all ok except one slightly oil fouled. No characterisitcs of blown head gasket that i can see. Can coolant temp sensor cause this and why?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Jeep Master
  • 22,041 Answers

The cylinder behind the water pump is the one thats fouling up no doubt.Sensor cannot cause this hard starting unless it controlling the auto start ,have one of these pieces of metal??? in for repair at the moment ,losing power steering fluid ,what a rust bucket and petrol drinker must drink more petrol than er indoors drinks tea.The one that would know for sure is emmisionwiz,a straight water temperature sensor will not cause this problem on its own but some motors like VW golf have two sensors and the second one in would cause this sort of problem as its controlling the fuel enrichment side of the ECU programming.Just dont have enough product knowledge to tell you what one to change ,sorry .Ask me about a morris minor or a ford zodiac

Posted on Feb 13, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I turn the key on start position let the key go but stil start but dosent run enles i step on trutel


This is a symptom that indicates the auxiliary air valve that opens to help the engine get more air and fuel when it is cold is not opening or its air passages are plugged.

Normally if it is the aux air valve it only gives this trouble with starting when the vehicle is cold. If it starts ok when the engine is hot from recent running. That makes it more likely.

Mar 21, 2015 | Cars & Trucks

1 Answer

Hardstart hot cold ok


don't want to start after it sets about 30 min.,if it does start it will run rough and then die.let it set and get cold it will start.What is the the trouble?

Jan 15, 2013 | 2001 Buick Regal

1 Answer

When i start the car it drives ok but after warming up a bit the car loses acceleration and starts to boggle?


check for a bad fuel pump relay. it maybe geting hot and shutting down. it may be a bad coolant tempurature sensor also, that sends info to ecm.The engine will think it was still cold, even though it was not, causing all kinds of things to run draggy. thats why it runs ok when its cold. it sends wrong info to computer. thinking its cold, when in reality its warm. have a good day !!

Mar 19, 2011 | 1996 Ford Probe

2 Answers

Land Rover Discovery 1996 3.9 V8i Cooling Problems


you need to replace the heater core and pressure text the radiator cap, replace if it leaks down go to a parts store to do this also you need to replace freeze plugs if you don't they will blow and ruin the engine,a slo check that the water pump is not bad, loosen the pump belt and see if you can wiggle the water pump with fan connected, if you have any play replace the water pump. and add new anti freeze.

Jun 18, 2009 | 2003 Land Rover Discovery

1 Answer

1996 sl1 water pump went out...replaced then it super overheated....thermostat must have stuck....then it worked fine except now it won't start cold I have to push start it. Then it is hard to start on...


Be sure your coolant level is OK first. When a water pump or other cooling system part is replaced air blocks in the system are not uncommon. If the engine overheated, this could have fried the coolant temp. sensor (ECT) causing the hard starting. (It might think the  engines always hot) ECT are pretty cheap. Just replace it and see what happens.

Mar 20, 2009 | 1996 Saturn SL

1 Answer

1996 Jeep cherokee, leaking coolant when cold/ hot ok.


waterpump houseing/shaft seal is on the way out hence the water/coolant, running along the block. when hot the seal does so, when cold and depressurising seal doesnt.

Jan 25, 2009 | 1999 Jeep Cherokee 4WD

3 Answers

Engine running hot after thermostat installed


This is a Classic Sign of a Dead Waterpump.

Jan 22, 2009 | 1996 Chevrolet Cavalier

2 Answers

I have water leaking from the engine, but don't know where from. The radiator has been changed the water tested for emmissions, pressure tested and still water is leaking. The heating blows hot when...


if you see the water leaking form the front side of the engine usually from the water pump since the pump is not running you also wont get heat, bit when you pressurise the sys you are forcing the hot water into the core and you have heat, it is the water pump.

Dec 04, 2008 | Honda Accord Cars & Trucks

Not finding what you are looking for?
1996 Jeep Grand Cherokee Logo

123 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jeep Experts

yadayada
yadayada

Level 3 Expert

70365 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6878 Answers

Are you a Jeep Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...