Question about 1995 Honda Passport

3 Answers

Battery went dead while engine was running

Low voltage was showing on dashboard, Indicator lights came on, Voltage got so low the engine stalled.

Posted by on

  • naza01x May 21, 2009

    I have the same problem, I live in Cancun need to change the alternator but it is very difficult to get a new alternator, there is the possibility of putting an alternator compatible.

  • Anonymous Mar 12, 2014

    Toyota yaris 1lt engine dashboard lights,rear lights,indicated lights not working battery not charging eighther

×

3 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 4 Answers

Before wasting money, what about a loose belt?

Posted on Nov 24, 2012

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 142 Answers

Sounds like your alternator is not charging. Check the battery and see how much voltage you have. Usually when the low voltage light comes on, it is your alternator. You can check to see if the altenator is charging by jumping the car off and then checking the voltage, you should have over 13 volts while the car is running. If not then your alternator is bad.
Please rate this and let me know if it helps.

Posted on Feb 11, 2009

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,902 Answers

Get your alternator checked out or just replace it. sounds like the alternator is not charging the battery on your vehicle. You can take it out and take it to a local kragen or autozone and they will test it for free to see if it is good or not

Posted on Feb 11, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My cluster all lights come on and gages fluctuate while driving


so what works and what not.
so far we have cluster issues
does car drive, ok day and night.
and all accessories?
did engine stall driving?
did Head lights dim? on, driving?
my guess is the engine stalled or idled below 300rpm
and the ECU went to Key on self test mode, (they all do that)
watch the RPM guage? see that needle, ?
if it goes below 300 rpm that is engine stall.
or worse
This cars cluster is really just a digital display
so if the PCM cant talk to the cluster, the cluster will go nuts.
for freeze.
We use a scan tool to see whats up.
or use the cluster self test covered in the shop manual.
the cluster has 2 fuses that can be cracked/loss or corroded.
the cars battery can go weak.
if the charge/battery light glows, engine RPM good
then the alternator systems is failing
if the volt meter (if opted) in cluster drops below 14v, and engine is still running, the same, alternator system failure
or even a loose belt at the alternator.
if the battery voltage drops too low , all electrics go nuts.
and engine stalls.
what dies first with low battery , is luck of the draw....
so what was battery voltage
and engine RPM at the point of failure.??????????

Feb 27, 2016 | 2011 Jeep Liberty

1 Answer

Battery light


Its probably the alternator.
The warning light comes on anytime alternator output drops below 12 volts.
I should also tell you, you can't check an alternator by running the engine with the battery disconnected. The alternator needs the battery in series for the diodes to work. What you did could have damaged the alternator and also the engine computer. Only generators can be checked by disconnecting the battery.

Feb 22, 2014 | Toyota Avalon Cars & Trucks

2 Answers

New battery keeps going dead no low voltage light


Have the vehicle taken to one of many places that will test the Alternator output etc--narrow it down first without replacing that.

Voltage may drop enough to prevent starting without triggering the low voltage issue.

Jun 14, 2012 | 1997 Ford Escort

1 Answer

2004 chrysler sebring 3.0 stalls and will not idle. Engine lite came on and scanner said TPS low voltage on one side. I replaced TPS and it temporarily idled ok. Engine light is now off. Runs fine except...


This is where proper diagnosis comes in...as the TPS sensor voltage low because of a failed TPS sensor? Or was the TPS voltage low due to low battery voltage at the control module? Did you bother to check for the proper voltage at the TPS sensor connector before throwing parts at the problem? If the battery voltage goes low, it is NORMAL for the engine to not idle correctly. Low voltage at the control module can cause the computer to lose all of its "learned" data. It will have to "re-learn" how to idle the engine. This can sometimes take a few days. This is exactly WHY I keep telling people to not be disconnecting batteries in an attempt to "clear" computer fault codes.
If your battery has been going dead, you need to properly test and diagnose your battery and charging system. If this system is not working correctly, there is NO WAY your computer network can function correctly. - this MUST be diagnosed and repaired FIRST!

May 18, 2012 | 2004 Chrysler Sebring

1 Answer

Battery light on 2006 Kia Sportage


Check the voltage coming out of the alternator with engine running it should be 13.0-14.7 volts.Usally when the battery light comes on the voltage is to low or not charging.If voltage is below 13.0 volts or higher than 15 volts then the alternator is faulty and will need to be replaced.

Jan 19, 2012 | 2006 Kia Sportage

1 Answer

2005 GMC Canyon - service engine light came on - then the battery light came on - took it to the dealer. The battery was replaced and the service engine light went out. The truck still had low rpms at...


Sounds as if your alternator is not charging the battery. The battery is the main source of your engine "spark". the alternator is across the leads to supply charging to bring your battery up to the 13.2 volts that is available. Of course the alternator will run your auto if it is producing voltage, i.e. jump start, or push start. It takes a certain voltage to run your computer which monitors the battery and if that voltage is not sufficent to produce the timed spark, (battery runs down), then the vehicle will not fire on all cylindars.

Jan 22, 2011 | 2005 GMC Canyon

1 Answer

After i changed my alternator, my check charging system light and battery light comes on, also, my idle is very low now. when I pull up to a stop, truck stalls, I checked my alternator output and its at...


Was the light on before you changed the alternator? Check a couple of things: Check the connections if one is loose you may be running mainly off the battery but still show it's charging. Have you checked the battery under a load? Try checking the battery voltage with the car off and turning on the headlights. What does it read? 12.2 sounds like you may have a dead cell or if you have a bad connection you may be draining it. Sometimes a battery may show correct voltage but when load is applied it drops like a rock. if this happens replace the battery. Did the idle change when you changed the alternator or has it always been low?

Dec 29, 2010 | 2004 Ford F150

2 Answers

Engine stalls(dies-down) upon blinking the headlights...


you have a bad ground,or a battery voltage that is so low,that the 20 amps from the high beams circuit is pulling the voltage down so low that the ignition can not run properly.
put on the rear defogger,does it do it? if not,look for the ground junction common to ignition and the high beam circuits.

Sep 09, 2009 | 1995 Cadillac DeVille

1 Answer

1996 chevy S-10 Went almost dead while driving lost lights


The alternator has failed and is not charging the battery. Vehicle has run on battery only until voltage was too low to keep engine running.

Mar 29, 2009 | 1985 Chevrolet S-10

2 Answers

Hi, Irratic revs when idle


You need to reset the throttle body. Sometimes you can do this by going out to your car and turning the key to the "on" position. Don't crank the engine - just turn it to on. Let it sit like this for 15 min. Your throttle body shoulld reset. Good luck. Check out audiforums. c o m or audiworld for audi spec issues. Good luck!

Feb 04, 2009 | 1998 Audi A4

Not finding what you are looking for?
1995 Honda Passport Logo

173 people viewed this question

Ask a Question

Usually answered in minutes!

Top Honda Experts

yadayada
yadayada

Level 3 Expert

61037 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Honda Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...