Question about 1992 Jeep Cherokee Briarwood

1 Answer

Loss of oil presure

Hi I have a 92 laredo with a 4.0 litre. I was driving it and lost all oil pressuer for about 5 10 min. after regaining pressure there is now a tick coming from the engine. there is oil in the engine.

Posted by on

  • AJ Blishen Feb 11, 2009

    would it not be more then a pressure sending unit, because this happend at the same time as the ticking started.

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 229 Answers

One of your pressure sending units has failed. You will have to get this professionally repaired unless you are a REALLY GOOD mechanic. It involves tearing down the top part of the motor. That sound your hearing is a sticky valve and this occurs because of top end oil deprivation. Get it fixed soon and you will be ok. If not it will burn up valves and you don't want to go there$$$.

Posted on Feb 11, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

VZ commodore alloytech motor, oil in coolant but no water in oil


Just because you have no water in the oil, you cannot rule out a head gasket issue or a cracked head. Do a bleed-down test.

Aug 14, 2014 | Cars & Trucks

1 Answer

VZ commodore alloytech motor, oil in coolant but no water in oil


It could be a crack or head gasket, when the engine is cold the steel is contracted and there is little water pressure, when you start the engine the oil pressure comes up quick and stays above the coolant pressure, I believe the radiator cap is set at 19-23lbs before it pushes past it. When the block heats up the steel expands and opens the crack or pushes by the head gasket.

Aug 14, 2014 | Cars & Trucks

1 Answer

My 92 eldorado has a ticking sound when car drives the noise came out no where from the passager side is it my oil pump it gets lounder when gas is apply


What is the oil pressure when ticking starts? How many miles on engine? How often do you change oil? What oil do you use? What brand filters do you use? Is this a Northstar engine?

High mileage Northstars (and others) will have tappet noise as they wear. You might try adding a quart of Marvel Mystery oil at next oil change, but if low oil pressure is the problem, try changing to a slightly thicker oil, say 20-50. If you don't know what the oil presure is, install a mechanical guage. I had a freind with a low pressure problem on very high mileage car who began using straight 50W oil and car ran another 3 years/60K miles before dying.

Jul 19, 2014 | 1992 Cadillac Eldorado

1 Answer

Low oil presure while driving


im sorry there is no pressure off.
running pressure is low because.
1: wrong oil, or AF in oil, or brake fluid from jiffyboobs. or water.
2: fuel in oil , bad bad bad.
3: dumping additives it it. bad.
4: BEARINGS IN ENGINE SHOT. (warn bad)
5: THE GAUGE FIB'S.

I NEVER NEVER NEVER trust car gauges, i use MINE>(in hand)
i also test my hand gauges, (ask)

Jul 08, 2014 | 1994 Isuzu Rodeo

1 Answer

Oil presssure loss


Check oil. Presure sensor

Aug 24, 2012 | Dodge Dakota Cars & Trucks

2 Answers

When starting a cold engin the oil pressure light comes on. there is no noise of valves. the light stays on for aprox 2 to 4 minutes before the presure gage shows presure.


As long as there os no obvious noise you can either pull and try to clean pressure switch or replace the OP switch. Sounds like it's gummed up or connections have corrosion and it takes a little heat to make good contact.

Apr 01, 2011 | Ford F-150 Cars & Trucks

1 Answer

Can anyone tell me what the oil pressure should be for a 2002 chryler concorde. 3.5 litre single overhead cam, 24 valve?


Hi!!
THE OIL PRESSURE SHOULD BE CHECKED REMOVING THE OIL PRESSURE SENSOR AND INSERTING A MANUAL OIL PRESSURE GAUGE. AFTER TEST, USE TEFLON TAPE TO REINSTALL THE OIL PRESSURE SENSOR
5 PSI. MIN AT IDLE 45 TO 105 PSI. AT 3,000 RPM
A HELPFUL - 4 THUMBS - rating for this solution would be greatly appreciated. Thank you for using FixYa.

Oct 22, 2010 | 2002 Chrysler Concorde

1 Answer

Have high oil pressure reading when driving goes down to 55-60 when sitting at light,2000 jeep grand cherokee laredo 2-wheel drive 4.0 litre engine


the 1st thing that needs to be done is have a mechanical oil pressure test gauge hooked up to confirm the actual reading, the electronic gauge many times is incorrect.

Feb 16, 2010 | 2000 Jeep Grand Cherokee

1 Answer

92' Honda Accord


Hi, Here is thi information that you are looking for.

92 Accord with vacuun hose disconnected from the fuel pressure regulator is 40 to 47 Psi. At idle.

With hose connected 30 to 38 Psi. At idle.

I hope this resolve your question.
Thank you for use fixya.com

Jul 09, 2008 | 1992 Honda Accord

Not finding what you are looking for?
1992 Jeep Cherokee Briarwood Logo

92 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jeep Experts

yadayada
yadayada

Level 3 Expert

60541 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21927 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Jeep Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...