Question about 1999 Ford Escort

2 Answers

99 ford escort se gets no power and stutters.

When i start my car it will start fine. but when i press the gas to go must of the time it stutters and doesnt want to go. I can push the gas pedal down all the way and go nowhere sometimes. Also if i am driving on the interstate when i get up to about 50 to 55 mph the car will **** pretty hard sometimes. I have replaced the fuel filter and that did not help. Any information on what it could be would be helpful.

Posted by on

  • 2 more comments 
  • jd2126 Feb 09, 2009

    it doesnt seem to be a missfire. My dad looked at checked all my spark plugs and they appear to be fine. Also the check engine light is not on. I can give it gas and it will act like it doesnt want to accelerate and then usually if i just keep pushing the accelerator it will pick up speed. It seems to be the worse when i start it up and go at slow speeds it will **** when i try to give it gas and i have to ease up for it to stop jerking. It seems to also do it around 50 mph. Once i get on the interstate and get up to abput 65 -70 it seems to run fine. but once i get off and have to stop it returns to having the same problems.

  • Michael Gutwein May 11, 2010

    this studdering, is it like a missfire? also do you have any engine lights on and if so take it to get a code. it will help you diagnois the problem.

    Or is it like a drivetrain problem? like: if you give it gas and the engine revs but doesnt go anyfaster. car feels smooth running but wont accelerate.



  • pam woolwine
    pam woolwine Oct 10, 2013

    iM HAVING THE SAME PROBLEM, WHAT DID YOU DO TO FIX IT? IVE HAD 5 FEOPLE LOOK AT MY CART AND THEY CANT FIGURE IT OUT. PAM

  • jd2126 Oct 12, 2013

    My issue ended up being the timing belt.

×

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 702 Answers

When was the last time the timing belt was replaced on it? The cam timing may be retarded back from belt stretch creating this problem. Another thing to check out is if your catalytic converter may be partially plugged up.

Posted on Feb 09, 2009

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Try looking into a vacuum leak. I had a 99 Escort ZX2 that had a bad PCV valve hose and it was doing the same thing. Replaced hose for $20 and ran perfect.

Posted on Mar 27, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1998 Ford Escort Se 2000cc SOHC will difficultly start the first time then has to set 30 - 40 minutes before it will start again


Holding the gas pedal to the floor will cause the PCM to put the fuel injection system into clear flood mode , cutting the amout of fuel going into the engine . Pumping or pushing on the gas pedal while cranking the engine over does nothing but allow more air into the engine , it's not giving it more gas . The computer has a set program it follows at start up . It's not like a carburetor ! Fuel pressure regulator .

Apr 27, 2017 | 1998 Ford Escort

2 Answers

99 Ford Escort ZX2 2.0L Car will start but won't stay running unless you keep giving it gas


I had the same problem. My car sat for a few days and when i went to start it i heard an extremely loud pop (kind of like a backfire). After that it would start and sound fine, but die 2 seconds later. Thank god my bf is a mechanic he knew instantly that the pcv valve hose that connects to the intake manifold unplugged itself. He plugged it back in and it runs fine now. I didnt however get a check engine light, but i only tried to start it twice before he fixed it because i was scared it jumped time.

Feb 26, 2012 | Cars & Trucks

1 Answer

Escort starting problems


Hey Tam_kc71!

The catalytic converter is very notorious in going out on Fords of any year or make - No rotten eggs smell nothing - They will go out. Get that checked and I bet that is your problem. Not that hard to replace yourself.

May 13, 2009 | 1998 Ford Escort

1 Answer

I have a 99 Ford Escort, cranks but doesn't catch


Startermotor has a problem. Please dismantle and free that pinion on axle stuck. Easy job.

Apr 16, 2009 | 1999 Ford Escort

1 Answer

99 For Escort Will not start


might be your timing belt pull the cover off and make sure the belt is turning

Mar 10, 2009 | 1999 Ford Escort

2 Answers

99 Expedition - Stutters and loses power when accelerating


My was doing the same thing, it was an EGR valve and a misfire on the #2 cylinder which required a new spark plug and a coil pack
t

Mar 06, 2009 | 1999 Ford Expedition

Not finding what you are looking for?
1999 Ford Escort Logo

Related Topics:

659 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

70347 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Ron Lankford

Level 3 Expert

5386 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...