Question about 1982 Alfa Romeo Spider

1 Answer

79 spider veloce 2000 start

It sat for 25 years and only has 14k miles. recently dumped/changed all fluids, all filters.
New fuel pump. Started and ran. Stalled 3-4 times after 15 minutes when driven. Looked under- saw catalytic glowing bright xmas red ! So mix coming out was super rich... Let it cool overnite. Next day and since; it fires up for 2 seconds- stalls, fires up- stalls, once it fired and ran for 1 minute and stalled, and on and on. Engine is getting fuel for this initial ignition and then dies. Exhaust must still be rich with fuel. Checked fuel lines to Spica pump and its flowing good into and out of it. All air/vac hoses connected. going nuts. whats next? thx

Posted by on

  • 5 more comments 
  • eran Feb 07, 2009

    more? i wish i knew what to tell. By the way, your comment was cutoff after "antifreeze also..."

  • eran Feb 08, 2009

    i thought the cat was plugged but when it does run for 20-30 seconds once in a while and i got my hand on the exhaust pipe, i feel a real nice, free flow. so i keep thinking about fuel flow, maybe injectors, maybe some control switch somewhere??

  • eran Feb 08, 2009

    thinking about getting rid of the cat converter alltogether. Although the car was born in NJ it is now in florida and where no one will ever look to see if it meets pollution regs. If the cat is gone it may just make it happier and allow better echaust flow regardless. So next week its the chop saw to the exhaust pipe...

  • Jerry Koski
    Jerry Koski May 11, 2010

    Say another thing I have seen several cats plugged and still flowing exhaust out.. so keep that in mind .you might drop the exhaust and run it for a bit and make sure . you might run some chemtool through the fuel system to clean it up also.. just another thought.. which you might have already done.. setting sure hurts one doesnt it. its worse than driving it all the time I believe .. brakes go also seals and fuel problems .. thanks Jerry

  • Jerry Koski
    Jerry Koski May 11, 2010

    sorry 25 years wow . it could be pluged up with something

  • Jerry Koski
    Jerry Koski May 11, 2010

    strange you say the cat is bright red ? and it set for 14 years ? is it possable you have a clogged exhaust system ? just wondered if maybe some mice got in there and made their home or something like that ?? just a thought.. Jerry

  • Joseph Lukas May 11, 2010

    Hey I want to know more! I know these cars really well. Do the belts and hoses and antifreeze also

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Alfa Romeo Master
  • 2,778 Answers

Hello Eran,

Normally I would jump at the opportunity to point
to the catalytic convertor as your trouble...
(or rusty muffler (has nothing to do with mileage)).

But so hot ... so fast leads me to think it is
being over fueled... If you can beg, borrow or buy a simple mechanics stethoscope you can listen to the injectors clicking.

Pick out anyone that sounds different and clear it by spraying
BERRYMANS Chemtool (see below)...
((handle it carefully... can take the PAINT off (pronto))).

Once you have eliminated the black smoke
(stuck injectors) the engine should be running
smooth enough to identify what other issues...

I would try to then OPEN the exhaust system above the catalytic converter to see if the engine runs better. Obviously you cannot drive (or even heat up the engine in that condition... but it might
tell you if the converter is STILL FAILING.

USE lots of liquid WRENCH (good 6 point wrenches)
and take your time...

Else:
Take it to a muffler shop for analysis
(just know your prices BEFORE you go)...

Hope this helps.

1979 ALFA ROMEO SPIDER 2 0L L4 Muffler RockAuto

Posted on Apr 03, 2017

Ad

4 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
3dmaster
  • 183 Answers

SOURCE: car ignition problem

Yes exactly,

You got the correct point of problem,

so you have to remove this spark plug & wiring than cleanings up with some cleansing materials that can do easily than try to do all this with same with your car's ignition system ,

it will definatly solved ,

THNX

Posted on May 18, 2008

picatudo
  • 239 Answers

SOURCE: 1978 Alfa Spider

replace primer pump inside tank

Posted on Jan 03, 2009

SOURCE: Car stalls after one half hour driving in hot weather (80's).

It may be runnig to hot, try to change the thermostat for a colder one and try it.

Posted on Jul 09, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2000 Mazda 626


Sixteen year old car with only 40K miles must not be driven often, or sat for some time. I would suspect fuel system issue, such as bad pump, clogged filter, bad regulator or faulty injectors. Start by testing fuel pressure.

Jun 20, 2016 | 2000 Mazda 626

1 Answer

97 tahoe 5.7 vortec starts but wont stay running after new fuel pump, fuel filter, fuel supply lines, fuel pressure regulator, and fuel injectors because it wouldnt start


hello my wife has came home and said she smell gas so started the truck and the sending unlt rusted out and pumped gas on the driveway. so i replaced the tank and the sending unit and also changed out all the lines and filter up to fierwall all three lines are from a kit and fit well. i reused the year old bosch fuel pump .the truck seams like the fuel pump is bad again.
i have 55 to 60lbs and does not change much has i rev the engine. the truck starts right up and does not miss abeat and idales great.the fuel pressure does not fall when i shoult off the truck and held 50pis for about 30min and slowly fell so i dont thing there is any leaks at the spider . i through that the cats are plugged but they are only 1 yery old and has a magnaflow system. anyway i did a vacume test at the intake and started to rev the engine and pulled a hard increse . i owned this truck all of it's life and has only 76000 miles . i have no check eng lights and all 4 of 02 sensors are acdelco and were change when installed the exchust .still bogs at 2200-2300 rpm

Dec 04, 2013 | 1997 Chevrolet Tahoe

1 Answer

Powerglide transmission


Ouch...sat too long and the transmission fluid is probably like molasses... Try pulling the tranny pan, dump the fluid, clean the pan and change the filter and refill with DEXRON fluid. Also add some SeaFoam transmission additive. Start it up and when engine is at operating tempuature, SLOWLY put it in all gears. Shift back and forth, back and forth (with your foot on the brake !). Hopefully the new fluid and the SeaFoam will clean up the internal parts. If and whne the car is driveable, drive about 100 miles and then dump the fluid, filter and refill. Add another can of SeaFoam. Hope this helps....
Good Luck

Nov 10, 2013 | Chevrolet Cars & Trucks

1 Answer

I bought a 00 ford f150 with a 5.4 v8 it has sat for a number of years the story is that the truck started haveing runabilitys ishues so he parked it 2 or 3 years cleaned tank new fuel pump new fuel...


HAVE YOU CHANGED OR CLEANED THE FUEL INJECTORS? ALSO TRY SOME STUFF CALLED "SEA FOAM" I'VE BOUGHT IT AT ADVANCED AUTO PARTS BUT I'D BET IT'S AROUND OTHER PLACES. I PUT THAT IN A 73 CHEVY TRUCK WITH A CARBURETOR THAT SAT FOR MANY YEARS AND IT CLEANED IT UP AND RAN GREAT!!! I WAS VERY SURPRISED!

Apr 08, 2017 | Ford F150 Cars & Trucks

1 Answer

Is there a fuel pump reset switch for 1999 pontiac montana?and where is it?


It is a very well know fact, that only Ford
Products, have ever had a Fuel Safety Shut Off Switch

Jul 03, 2012 | 1999 Pontiac Montana

1 Answer

2001 dodge ram1500 /accelerates slow even w/peddle to the floor


How many miles on that rig? The 4.7 motor is a great motor.

Sounds like a fuel starvation issue. Might also be a trans issue. Does the trans seem to be shifting properly?? Could it be starting in 2nd gear which is the "limp mode" for Chrysler trannies?

Apr 21, 2010 | 2000 Dodge Ram 1500 Truck

1 Answer

'92 Chevy pu V8 will not start spray in starting fluid and it starts then starts rest of day. sits over night have to go back to spraying with starting fluid. What is the problem? How do I fix it? '92...


With your Clarifications I suggest having the Fuel Pump Pressure Tested as one other gentleman suggested that it is most likely bleeding down overnight. Another possibility would be the Fuel Filter being clogged. The factory recommendation is to change fuel filters every 30,000 miles. Many people do not even know a Fuel Filter exists on their vehicles. Some years back they were near or in the carb. Weak Ignition would be the last thing to look into as the vehicle runs somewhat normally once started and running for a while. Modern vehicles have Electric Fuel Pumps inside the Fuel Tank. This is somewhat expensive to replace but necessary maintenance after many many miles. Good Luck!

Sep 19, 2009 | 1999 Chevrolet Silverado 1500

1 Answer

Stalls out about every 10 miles or so,let sit bout 5min,restarts


have you changed the plugs and leads, if you don't know the last time it was started there is a few things you need to take into account, engine oil and spark plugs fuel filter even the fuel in the tank empty and replace, coil and the points ( if upgraded there is no coil and points as been converted) you would also need to clean out the carburetor as old fuel drying can block or limit fuel entering the engine. change air filter. even standing an engine for a year or 2 these parts can degrade as they have not been used. also change the water and flush the system and refill with coolant/antifreeze.

May 23, 2017 | 1985 Plymouth Gran Fury

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

56 people viewed this question

Ask a Question

Usually answered in minutes!

Top Alfa Romeo Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

yadayada
yadayada

Level 3 Expert

76846 Answers

ROBERT GARCIA
ROBERT GARCIA

Level 3 Expert

907 Answers

Are you an Alfa Romeo Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...