Question about 1996 Ford Escort 4 Door

2 Answers

Escort 1998 1.8 zetec mis firing

Hi when driving along engine jumps/mis fires. when stopped car revs go up and down sometimes staying at 1400 revs for about couple of min before dropping or trying to stall at 500 revs. spent about 400 so far. plugs ht leads,air flow meter,igniction box,idle control valve,feul filter,cleaned earth points around car as thought lambert sensor. car wont pick up on computer dionog... someone said feul inj cam actuator but where is it. help i want a smooth ride always had fords but this one letting me down! my focus is brillant! i have the same problem with my 1996 escort it jumps and misses but the rev's dont go up or down i was told it could be the coil breaking down under load ?

Posted by on

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

Cam belt worn? had same prob.

Posted on Feb 17, 2009

Ad
  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

Hello, did you try changing your coil pack

Posted on Feb 07, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Mechanic can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Mechanic (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2004 land rover discovery bosh engine shakes whole vehicle when start up for a while then goes away. sometimes shakes while driving. sometimes while coasting, sometimes when idling in park and sometim


have the lifters removed and check for leak down and blocked oil holes and worn plates, broken springs. have the injectors checked for blocked tips . Have the fuel manifold pressure tested to ensure adequate fuel pressure is maintained as that also causes misfiring.

Mar 02, 2014 | Land Rover Cars & Trucks

1 Answer

Nissan 1400


distributor cap and rotor problem - there is your problem. If you do not put those suckers back in the same exact position, with the exact same markings, it will cause the car to fire the spark plugs at different times, causing miss fire and some times no firing at all.

Jan 04, 2014 | Cars & Trucks

1 Answer

My 96 ford taurus revs high when starting then works it way from 1500 or more down to 800 but fluctuates from 800 to a little over 1000. When putting car in rverse or drive from park engine revs up to...


You need to clean the IAC again and also the throttle valve and bore, use only CRC brand Throttle body cleaner. After they are thoroughly cleaned disconnect the battery for 5 min's and then drive the car in varying condition for a few days. If that doesn't cure the issue you have more serious problems and will need a scan tool to look into the readings from the MAF, TPS and ECT sensors. High idle cold start is normal then slowly dropping after a few minutes. I assume you never had a check engine light. Correct?

Mar 24, 2017 | 1996 Ford Taurus

1 Answer

Gauge issue


Hi Nadhem, I believe you have an electrical short circuit somewhere along the lines. Check them out and look for anything touching the body where the insulation has rubbed through. Regards John

Apr 29, 2012 | Cars & Trucks

1 Answer

Alfa 156 mis-firing


Hi i had the same prob with my 99 alfa 156. It seems that there could be a problem with the air sensor on the induction kit. If you remove the sensor and use some brake cleaner to clean it. Use gloves on dnt touch the sensor its self, and dnt use a rag or a cloth on it. Install it again after 5 or 10 mins and start the car up. It should work fine. If it does the trick check your air filter as it might be damaged and not working properly. I checked mine and found there was no filter in it at all. I found a cone filter works better for the car.

Jul 06, 2010 | 2000 Alfa Romeo 156

1 Answer

1995 GMC Sonoma with a 4.3L vortec code w.


check for vacuum leak at the intake area,also check EGR vale may be stuck open.

Apr 09, 2009 | 1995 GMC Sonoma

2 Answers

Engine revving


try cleaning the petrol cap. it breaths round the key hole. i boiled mine. sometimes if there is not enough air in the tank. pure fule goes into the carb. and makes the car race. take fule cap and boil it in water. you can use steradent in cold water if you prefer. muck gets stuck in them.
liz.

Mar 07, 2009 | 2000 Renault 181

1 Answer

Escort 1998 1.8 zetec mis firing


try using a gauge to measure fuel delivery pressure but this tool may only be available to the dealer or a big garage,best advice in a case like this is put car in dealers as you cant read the the ECU readings as the OBD II connector cable doesnt have manufacturers pin connections.Have a funny feeling this problem is a concoction of different faults,but try checking gauze filter on bottom of pump in the fuel tank or for porosity on the flexible connections that connect the plastic fuel lines to the unit on the tank .

Oct 04, 2008 | 1998 Ford Escort

Not finding what you are looking for?
1996 Ford Escort 4 Door Logo

347 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

77169 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22265 Answers

fordexpert

Level 3 Expert

5575 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...