Question about 2000 Ford F150 Flareside SuperCab

4 Answers

Missing and stumbling during acceleration

I have a 2000 Ford F-150 with a 5.4 Triton V-8. About two weeks ago I suddenly had a hard time starting my truck but it started. On that same day I noticed that the truck with stumble and shutter upon acceleration but would smooth out once the accelerator was let up on. The next three or four days, the truck ran fine. Now it has returned to the same problems on a consistent bais. The truck starts fine and runs fine for about 5 minutes and then starts to vibrate and shutter/stumble upon acceleration but smooths out once the accelerator is let up on.

Posted by on

4 Answers

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

4.2 ltr missing. 2000 truck, f150. Changed plugs, wires. Ran great for 2 weeks. Started again. Changed coils. Got worse. Changed fuel filter, did nothing. Added injector cleaner and fuel cleaner, nothing. Checked EGR, o.k. It is getting worse. Had new gas about the time it all started.

Posted on Jul 08, 2011

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 14 Answers

You should be poping a p0303 code with can be several things ,bent vavle, plugs, a coil, plugged cat but it acting same as my truck did and i found a dirty/bad injector was the problem (if she is missing under medium/heavy accerlecation only) rebuilt injecters about 80-90bucks for the set but the basics first pluged air filter, ect....

Posted on Aug 05, 2010

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 9 Answers

My '99 5.4 F150 is doing the same thing. Stumbling under medium acceleration and runs fine when idling or cruising at a steady speed. But when it comes to quick acceleration, or pulling uphill, it just wants to stutter and shake. I've replaced plugs with no result, but the dang thing wont give me a code to tell me what coil pack is out. Sounds like a bad design flaw to me.

Posted on Oct 26, 2012

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

Probably one or more of your coil packs are defective. I had the same problem recently. Have someone do a scan and that will tell you which one is going bad

Posted on Feb 07, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2001 5.4l Triton. Why is there a misfire on cylinder 4?


Bad coil pack on 5.4liter F150's? and do they all need to be ...

www.lawnsite.com > ... > Trucks and Trailers
7 posts - ‎5 authors 01-02-2009, 12:11 PM ... so my 2000 F150 v8 5.4 triton is a great truck as I think anyone with one with one will agree. The only recurring problem seems to be the coil packs will go bad all of sudden, causing misfiring and a very bumpy ride. ... happened a few years ago, I replaced them all and the truck was good for 3 years.

Aug 12, 2015 | Ford F-150 Cars & Trucks

1 Answer

1998 f 150 4.6 stumbles hard /wont take fuel.


Don't understand the last sentence. I would clean your air sensors. They may not be reading the air correctly.

Apr 13, 2013 | Ford Cars & Trucks

1 Answer

WHAT ARE COMMON PROBLEMS WITH 2000 MERCURY SABLE


I HAVE A 2000 SABLE SUDDEN LOVE THE CAR. ABOUT TWO MONTHS AGO STARTED MISSING A BIT. THEN LAST WEEK JUST DIED. I REPLACED THE HARD FUSES ON THE BATTERY BOX. RESET THE PUMP. IT ACTUALLY FIRED THEN DIED OFF AGAIN. WHAT MAKE IT DO THIS. IF THE FUEL PUMP IS UNDER THE BACK SEAT OR THE GAS TANK. OR COUD JUST BE MY PLUGS. E.T.C. HELP ME PLEASE A S A P .

Nov 22, 2012 | 2000 Mercury Sable

1 Answer

I have a 06 ford f150 with the triton 4.6L v8 I need to know if it is the 3v or not any visual clues would be helpful


Unless I am missing the product years, the 3V 4.6 V8 was not in the F-150 until the 2009 and newer MY F-150s. Up to 2009, the 4.6 L v8 was the 2 V design that was used from 1997 to 2008.

The 3 valve 4.6L V-8 started in the 2005 Mustang and then was introduced to other models.

Nov 24, 2010 | 2006 Ford F-150

1 Answer

Ford f150 lariat year 2000 4.6 engine stumbles during acceleration


My ac was working great put heat on now my ac won't get cold.

Nov 08, 2010 | 2000 Ford F150 Flareside SuperCab

1 Answer

Can't keep coils working


Have you replace spark plugs? They may be overworking the coil packs. I would recommend the motorcraft spark plugs.

Jan 26, 2009 | 2000 Ford F250 Super Duty Crew Cabs

Not finding what you are looking for?
2000 Ford F150 Flareside SuperCab Logo

3,001 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

60867 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...