Question about 1999 Buick Century

1 Answer

Buick 1999 century replaced the sensor light and still comes on.

When I replaced the sensor I added coolant to the bottle but I did not run the engine until my wife went to work the next day. Could that be the cause of the light coming that the coolant in the bottle went to the radiator. I just checked the coolant in the bottle and it is still on the line limit.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 87 Answers

Your buick century has a low coolant level sensor located in the passenger side of the radiator , sometiomes the sensor get covered with coolant sludge and will show that the cooling system is not filled , sometime the radiator is just still low on coolant . check the radiator when the engine is cold ( IF HOT WAIT !!! 30 mins ) and make sure the level is above the sensor.

Posted on Feb 06, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My radiator cooling fans on my 1999 Buick Century will not come on. I have checked the fans and they are good, just getting no power. I have replaced the coolant temp sensor to no avail.


Have you checked to see if a fuse has been blown that operate the fan? Check your fuse box and book for the info concerning your radiator fan or any fan operation. That's a good start.

Aug 31, 2014 | 1999 Buick Century

1 Answer

How to reset low coolant sensor on 1999 buick century


Your cooling sensor is in the white plastic coolant tank that is on your firwall under the hood. If you fill it with coolant and the light continues to stay on. try and slap it a few times and see if that resets it. it could be gunked up. if that doesnt work fill the tank with radiator flush and let it sit for a little while and then flush the tank and refill with coolant.

Oct 11, 2010 | 1999 Buick Century

1 Answer

My 1997 buick century limited temp. guage kept going up. I added water and it stopped but now when im on the highway the low coolant light comes on. It goes off when i get off the highway. is that my...


I think your buick has a pressure coolant system so you may have air in the system and need too bleed it and for the light coming on while on the highway most likely low coolant when your driving the higher rpm the more coolant is drawn into the motor and triggering the light from coolant reservoir running low on coolant

Nov 10, 2009 | 1997 Buick Century

2 Answers

1999 buick century 3.0 v6 engine cooling fan not turning on soon enough allowing the engine to run hot. Is this a sensor control problem that is an easy replacement?


u need to buy the special coolant to your car i have the same car whit the same problem and is cause to the incorrent cooland the cooland to your car is the  DEX-COOL  if u dont find that u need some hit       (silicate-free) 

Apr 29, 2009 | 1999 Buick Century

2 Answers

How do I change the fuel filter in a 1999 Buick Century Custom?


Philly, the fuel filter is attached to the frame in front of the gas tank, under the driver side of the car. You must relieve the pressure in the fuel line before you start, and it is also recommended that you disconnect the neg. battery cable. After disconnecting the neg. cable, remove the gas cap. Next, look under the hood on the fuel rail for a shrader valve (like the type on a bicycle tire). Place a rag under the valve, remove the cap, and press the valve in with a plastic pen to relieve the pressure in the line. You can now go under the car to remove the filter. You can disconnect the fuel lines easily with an inexpensive plastic disk made for this purpose (only a few $ for several sizes at a parts store). Be careful of fuel in the line that will drain out, no smoking or sparks during this procedure. Should be 1 bolt securing filter to frame. Note arrow on new filter, and install in the correct direction. Replace cap on shrader valve, put gas cap back on, reconnect battery cable. The low coolant light is probably a faulty sensor signaling that it's low, when it's actually ok. Look for wires coming from the reservoir bottle, you should be able to find the sensor at the end of the wires to replace it. If you change the fuel filter in a garage, leave the door open for air circulation, gas fumes can explode easily, having the door open will help dissipate the fumes.

Apr 05, 2009 | 1999 Buick Century

1 Answer

1999 buick century


is there coolant in the system ? if there is go to the coolant bottle there is a sensor in the bottom of that bottle if there is any thing beside coolant in that bottle it will cause the sensor to act erraticly. if there is no coolant our low coolant then the sensor is working you need to look for a leak

Feb 06, 2009 | 1999 Buick Century

1 Answer

How to replace a coolant level sensor, 2000 buick century


The coolant level sensor is located on the radiator. If you are looking at the engine from the front of the car it will be on the left side. There will some kind of clip holding it in the radiator. Removed the clip and pull the sensor out. You will lose coolant so try to swap it out quick or drain some of the coolant out. Once new sensor is installed, install clip to keep the sensor in place and reconnect the wires to the sensor. Crank the engine and make sure the coolant level is full. This should correct your problem.

Dec 20, 2008 | 2000 Buick Century

Not finding what you are looking for?
1999 Buick Century Logo

729 people viewed this question

Ask a Question

Usually answered in minutes!

Top Buick Experts

yadayada
yadayada

Level 3 Expert

64052 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21990 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Buick Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...