Question about 1999 Chevrolet Silverado 1500

1 Answer

Rebuilt engine 5.7 l 1998

Engine starts easy timing checked 4 or 5 times , rev engine wil rev instantly will acelerate instantly b ut when you slow down to a stop engine stalls and hard to start then runs fine again
Atfirst code p0341 would come up but now its not.
Do I need a new crank sensor.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I broke down and purchased a new crank shaft sensor . It cost $15000 hated to spend it because everbody told me they just don't fail , and why would it when it worked fine before the motor was rebuilt. IT FIXED IT.

Posted on Feb 04, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Stalls out/loss of power w/ small backfire on acceleration right at 4000rpm.


Whens the last time you changed the fuel filter. It gets clogged up and causes your exact symptoms. You have the pressure, just not the flow.

Dec 02, 2015 | Cars & Trucks

1 Answer

Mercedes 300E starting problems


If the problem is only on cold start check cold start injector, it cuts out after the engine worms up .a faulty thermostat can delay worm up.

May 11, 2014 | Cars & Trucks

1 Answer

2006 Suzuki forenza. sometimes it takes a long time turning engine over to start. when it does start, the tach revs up to 4 and won't slow down. when you shift the car into gear, it shuts off. when it is...


bad idle, and surges.
gets better, does that mean it idles at the correct regulated RPM
HOT? 800.?
and does the engine coolant hit 180 to 200 F and hold there.?
Sounds like the ISC valve is stuck open, clean it.
ISC means, idle speed controls.
also air leaks, vacuum leaks can do this on speed density, EFI.
Im not sure which EFI you have, too lazy to look that up.

which engine do you have, and what country, ?
as a mech, i open hood and look, on the net , i cant do that.
so.... no real help

Sep 11, 2013 | 2006 Suzuki Forenza

1 Answer

Transmission on 2009 Nissan Versa Hatchback SL


dont go to mr transmission. I have had to go back 15 times then i finnaly sold the car because they recked it. sounds like a speedo sensor or the sterio installer cut the wrong wire

Mar 13, 2013 | 2009 Nissan Versa Hatchback

1 Answer

My escort rs 2000 is mifiring at low revs and is slow at picking up than normal help lol.


When was the last time the timing belt replaced. What happens is the camshaft starts retarding itself and the valves are opening and closing at the wrong time in which can very well cause misfiring and definitely loss of power. It has been replaced, take a look at your plugs/wires. Check the condition of the air filter, it may be getting plugged up and air can't get into the engine causing the engine to load up and low rpm.

Mar 28, 2010 | 1996 Ford Escort 4 Door

1 Answer

It shifts slow and doesn't seem to have much power


Sounds like the catalytic converter is about ready to go bad. When the cat goes bad the car struggles to start, then when you try to acelerate its very slow. Start your car and have a friend rev the engine. Put your hand close to the tailpipe. I am willing to bet that not much pressure comes out when engine is reved up. I had mine replaced about a year ago. This sounds exactly like the same problem I had. The local pontioac dealer changed mine out for free. Check back I am interested in the results.

Dec 12, 2009 | 2002 Pontiac Grand Prix

1 Answer

My mercedes ML 270 automatic diesel


check your gearbox oil level sound like gearbox is in limp mode and may need a service

Sep 23, 2009 | 1999 Mercedes-Benz E-Class

1 Answer

1993 chevy k1500 4x4


Have you by any chance, monitored fuel pressure from start-up to warm-up point where it will not rev? Would not be uncommon for fuel pump to start acting up, about the same time engine gets warmed up.

Feb 03, 2009 | 1993 Chevrolet K1500

1 Answer

Car running problem


Ok Slow deceleration rev responce was part of the ECU software to keep the emissions down ,however if this has only just started you can try to reset the IAC valve ,the procedure is as follows.

Turn ignition key on ,unplug the IAC valve ,turn the key off ,replug the IAC valve. do this 3-4 times .Then start the engine while holding the gas pedal to 2000 rpm ,then slowley let the go of the gas pedal till the engine idles .

The IAC valve is located on the throtle body and has 4 wires to it.

Sometimes the throtle body needs to be cleaned and then reset.

Jan 02, 2009 | 1999 Daewoo Lanos

1 Answer

1.6 vitara


hey, check your coolant level on your radiator, take note I said " radiator not coolant reservoir.

there could be low coolant level that causes it.

Jun 24, 2008 | 2001 Suzuki Vitara

Not finding what you are looking for?
1999 Chevrolet Silverado 1500 Logo

250 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

63572 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21981 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...