Question about 1999 Ford Expedition

1 Answer

My 1999 Ford Expedition Front heater

My front heater blow cold some time warm air i dont know wat the problem

Posted by on

  • estlian Apr 25, 2009

    where is the ac service port located to recharge the system on a 99 ford expediton

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 486 Answers

EITHER VALVE STUCK TO ALLOW WATER IN MATRIX OR YOU HAVE AIR BLOCK IN IT. TAKE OFF TOP HOSE AND RUN MOTOR, TOP UP RAD AT SAME TIME, USED A DESCALANT IF WATER MUDDY /RUSTY LOOKING

Posted on Feb 02, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Have a 2004 ford expedition, heat will blow out rear vents but blows cold air out the front.


you need to have automatic ac and heater control checked out at a garage problem could be in the mode switch or electrical problem causing front blend door actuator not working properly.your vechicle has the EATC SYSTEM which is computer control need diagnostie equipment to fix.

Dec 11, 2011 | 2004 Ford Expedition

1 Answer

2002 Ford Expedition Rear Air, It currently blows only warm air.


if front air is cold i would have it checked for a clogged expansion valve in the rear unit

Feb 04, 2011 | 1999 Ford Expedition

1 Answer

Front heat works, but rear blows cold air only


With your front heat working the most likely cause for the rear heat not to work is that there is an obstruction in the line that is preventing the warm coolant to get to the rear heater core or the rear heater core itself is plugged and not circulating. Another possible cause could be low coolant level where the system has enough coolant to provide the front system with enought warm coolant but not the rear system. Hope this helps

Dec 30, 2009 | 2004 Ford Expedition

3 Answers

Why does my Heater blow cold air in the front


its the blend door behind the glove box. I had the same problem

Nov 11, 2009 | 1998 Ford Expedition

1 Answer

No back heat in Expedition, Blows cold air but front works fine


Shelly,

Buy used parts at car-part.com. Look on page with * to find the cheapest part. Coud be your temp blend door (#2) may not be moving back and forth. Or, you are not getting hot water to the rear heater core.

3d53924.gif
You may have to crawl under the truck and feel the heater hoses to see if they are hot. You will find a group of 4 lines, 2 for heater and 2 for a/c. If hot, you know hot water is getting back to the heater core. If not, there may be a hot water vave that's not working. Not sure if EXP. has a water valve for rear.

Let us know what you you find. Good luck.

Feb 22, 2009 | 2000 Ford Expedition

1 Answer

Ford Expedition 2002 Front Heater blows cold air below 45 MPH


impeller is made of plastic on teh water pump and its slipping and spinning on the shaft renew before weather warms up as engine will overheat

Dec 31, 2008 | 2002 Ford Expedition

Not finding what you are looking for?
1999 Ford Expedition Logo

312 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

61168 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...