Question about 2003 Lincoln Navigator

1 Answer

Battery Dead Want to see if anyone has had this problem. I went to get into my 2003 NAV and there is no power to the car. It worked 24 hrs before with no problem. Same thing a few years ago and the battery had to be replaced. This will be the third battery. Another problem the keyless entry and remote does not work and I cannot get into my car...Is there a way to get into the engine manually or a way to get into the car. Manual locks were taken off this car during customizing.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    New Friend:

    An expert that has 1 follower.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 73 Answers

If you reach up in the front of your grill from the ground you should see a cable running to the front of the car. It might be hard to see so you might have to feel up there. You pull on the cable and it will pull your latch to open.

Posted on Feb 03, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2003 elantra no power


Have u checked the main fuse in the car? Should b like an 80amper, good luck!

May 31, 2014 | 2003 Hyundai Elantra GLS

1 Answer

Someone broke in to my car (TSX 2004); the car doesn't want to start anymore. Head lights come on, there is no power to the radio and the starter doesn't want to turn the engine... How do I get the ca


charge the battery.
so that wnen rested it reads 12.6vdc. then it will start.
also check all fuses in both fuse boxes.
they might have tried hot wiring things (like on TV) and blew fuses.
the battery is first. no power, all toys and EFI go , dumb.

Jan 20, 2014 | 2004 Acura TSX

1 Answer

My bmw 320d alarm went off and the key fob now doesn't work. Also the rear lights stay on along with all the warning lights on the dash board. Has anyone had the same problem and knows the solution.


new one on me this. I would suggest you disconnect the battery for 24 hrs to let the ecu etc reset, but make sure you have a radio code if needed. Then reconnect and see how you get on. You can easily resync your fob by inserting key in door lock, turn to lock and at the same time press the lock button and to unlock do exactly the same.

Nov 04, 2013 | BMW 3 Series Cars & Trucks

2 Answers

Nissan primera no heaters no sat nav no radio or cd plus the doors wont lock any solutions thanks


check all your fuses and relays could also be a short in a wire somewhere.

Feb 20, 2013 | 2003 Nissan Primera

1 Answer

I have a 2000 Nissan Altima GXE, have changed altenator and left battery unhooked for 24 hrs. Now I can not keep car running, donot have inside working lights or anything to do with the power system...


the battery should be dead by the way you describe it...so just jump start the car from another car...if that doesn't work then you might need a new battery if the battery is too old...like 4-5 years old...
Good Luck!

Oct 13, 2010 | Nissan Altima Cars & Trucks

2 Answers

My voyager wont start it seems the alarm has stuck on , when i turn key nothing new battery fitted ,led light for alarm does not flash anymore /gear/milage lights do not come on ,i have taken battery off...


This may sound a bit simple but check the starter solenoid function by running an external wire to the thin wire terminal from the positive post on the battery.

If the starter does nothing then the starter is bad.

What your describing is a typical solenoid / starter problem. Given the car is now 10 year old, it is quite possible that either the solenoid or starter has failed.

Thanks for using FixYa!

Kelly

Feb 15, 2010 | 2000 Chrysler Grand Voyager

2 Answers

My car alarm is preventing my car from starting w/ a dead battery


check remote batt..if that dont work unhook car batt for 24 hrs. should reset

Nov 29, 2009 | 2001 Honda Civic

1 Answer

1996 Ford Taurus GL 2000 3.0L 4V Battery Issues?


you need to get a adapter from any auto store that can handl e load you want

Jul 09, 2009 | 1996 Ford Taurus

1 Answer

Battery problem


You either have a circuit somethere in a system or the alternator does not do a good job (Failure of the diode bridge or voltage regulator in the alternator). Also if your vehicle has an average run time (to go to work) of less than 20 minutes, your alternator will not have the opportunity to recharge the battery fully. You can check it for free in Autozone (battery votage and alternator charge).
Also check the battery connectros and alternator connectors for deposition
Good Luck

Jan 17, 2009 | 2006 Honda Element

Not finding what you are looking for?
2003 Lincoln Navigator Logo

Related Topics:

110 people viewed this question

Ask a Question

Usually answered in minutes!

Top Lincoln Experts

yadayada
yadayada

Level 3 Expert

60792 Answers

Fordexpert

Level 3 Expert

5331 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Are you a Lincoln Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...