Question about 1994 Ford F150 Styleside Supercab

1 Answer

When i stop at a red lite or put it park my engine idles up high

It does it just for a moment, i have a 1994 f150 4x4

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Ford Master
  • 4,369 Answers

Check your Idle Air Control Valve (IAC) to see if it's working ok, and set your idle hard stop.

Posted on Feb 25, 2009

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Mechanic can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Mechanic (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 1 Answer

SOURCE: 2005 F150 Engine Noise

I had the same problem, weather was cold but only -15 nothing severe. It ended up needing tensioner pulley and for $60 plus labour I was on my way.

Posted on Jan 07, 2009

fizzerdan
  • 12 Answers

SOURCE: 1994 s10 service engine soon light

Have you had the truck scanned for codes? If so, what was the code, codes? Why did you replaced those listed parts. Can you hear any hissing noise coming from the engine or engine compartment?

Posted on Sep 04, 2008

  • 1 Answer

SOURCE: Idle surge 1994 cadillac seville

I have the same problem i found out that it is my cruis control has a leak in the hose and if you just disconect it you will no longer have cruis control but it should stop the problem

Posted on Mar 03, 2009

  • 1 Answer

SOURCE: 1994 gmc 4x4 non engaging high range four wheel

ita a fuse i just fixed min i had same problem

Posted on May 17, 2009

  • 1 Answer

SOURCE: high idle in park and nutreal

what is thye correct idle rpm in park 1999 amigo

Posted on Mar 28, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Have a 1993 ford explore six cyl starts good but put in gear a it stall right away ?


In park or neutral not much load on the engine, when you put it in gear, there is a load. How may miles on the engine? How long since a tune-up? Any applicable trouble codes? Check and clean the idle air system and throttle body, see if it helps? Check cylinder compression. If the compression is way low, it may be tough trying to get it to run correctly.
In the old days, carbed engine, no computer, sometimes we'd set the idle in drive, at least it was driveable, it wouldn't die every time you stopped at a stop sign or red light. Yeah, when you put in park or neutral, the rpms would go high. Sometimes, your just trying to keep it on the road, if possible.

Aug 27, 2017 | Ford Cars & Trucks

1 Answer

94 s10 blazer 4.3 cpi


Could be a vac leak, dirty throttle body, or faulty idle air control valve.
Is the check engine light on ?

Jul 04, 2012 | 1994 Chevrolet S-10 Blazer

1 Answer

My car slams when put into drive. is it the idle


Yes, sounds like the idle speed is too high. If you keep driving like that, you will fry the torque converter / turbine. Since idle is computer controlled, you will have to take it for service tune up. There is one possibility that the rich, high rpm idle used for cold start is not disengaging properly after the engine warms up. Air conditioning will raise the idle speed by a couple hundred rpm, so avoid using it until you have the problem fixed. BTW.....warm engine rpm in idle, and neutral should be around 700-800. Anything over 900-1100 will result in a hard shift into 1st gear and dragging at stop lights.

Feb 16, 2010 | 2002 Chevrolet Malibu

2 Answers

Idle surge 1994 cadillac seville


I have the same problem i found out that it is my cruis control has a leak in the hose and if you just disconect it you will no longer have cruis control but it should stop the problem

Oct 22, 2008 | 1994 Cadillac Seville

Not finding what you are looking for?
1994 Ford F150 Styleside Supercab Logo

Related Topics:

225 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

77499 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22306 Answers

fordexpert

Level 3 Expert

5622 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...