Question about 1995 Chevrolet S-10 CA Edition

1 Answer

Hello, I have a 1995 chevy s-10 2.2 L. I replaced the plugs and plug wires due to a bad miss. Now, it runs better, but still has the miss, though not nearly as bad. I want to insure that someone didn't have the wires in the wrong places in the first place. Is the # 1 cylinder towards the radiator? and the ignition coil, reading from left to right 2314? Thanks, John

Posted by on

  • jritch Feb 01, 2009

    Thanks, so is the #1 towards the radiator or the firewall?

  • jritch Feb 01, 2009

    EXCELLENT !! Thank you SO much...............

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 132 Answers

The firing order is printed on top of the intake manifold

Posted on Feb 01, 2009

  • Allison Hulbert Feb 01, 2009

    it is towards the radiator

×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

Every time it starts raining truck starts missing and cutting out it's a 97 f 150 ford 4.6 motor.


Possibly a plug wire or cracked distributor cap. I'd take a spray bottle and while it's running (be careful not to get your body parts in danger of the fan) spray some water on the cap area. If everything seems fine, you could spray down each plug wire at a time. See if you find the culprit that way. For a vehicle so old, if you haven't done a tune up lately. It's probably a good time. Replace the distributor cap and rotor. Plugs and wires.

Mar 27, 2016 | Ford Cars & Trucks

2 Answers

Where do my OBD1 connections run in a 1995 chevy 1500?


You might be better off to go to a junkyard and take the connector and about 10 or 12 inches of the wiring with it.

Nov 28, 2013 | 1990 Chevrolet K1500

1 Answer

I have a 1995 Chevy S10 4.3L Engine. What would cause the engine to miss during acceleration??


Have you changed the spark plugs this year ?
Is the check engine light on ?
How's the cap rotor and wires ?
A miss under load is normal when one of the spark plugs is weak or they are not getting enough voltage from the coil. Also, a weak injector or problem with the fuel system can cause a miss.

Jul 31, 2012 | Cars & Trucks

1 Answer

The truck is working like has miss fire I replaced all tune up, when disconnected the MAP sensor the engine the failure is less wiht the check eng light on, I replaced the new genuine MAP and is same...


Check to see if any of the new wires are bad, same goes for the plugs. Throw the old plugs and wires on and see if it still is missing. It's possible to purchase wires that have bad boots or plugs that are cracked from shipping from warehouse to store. I have encountered this problem before in my 92 chevy pickup and it was indeed a bad set of plugs that I purchased and didnt thoroughly check to see if they were indeed good. When the engine light comes on normally it might run a bit better since the computer goes into closed loop, kind of like a fight or flight thing so that it can keep the vehicle running.

Jan 15, 2011 | Chevrolet C1500 Cars & Trucks

1 Answer

Starts and runs rough with black smoke as flooded


when you replaced the plugs/wires. Did you do the cap and rotor too
Also have your timing checked

Jul 10, 2009 | 1988 Chevrolet Blazer

1 Answer

Engine miss


if you have only one cylinder getting that excessive fuel it indicates that the computer thinks that that cylinder is not sparking and thinks no fuel is the proble. this is due to a timing issue. even though you replace the injector which was most likely not the problem to begin with. in order to get spark the coil has to energize you more than likely have a bad coil pack.replace the coil and your miss will no longer exist.

Apr 19, 2009 | 1995 Chevrolet Cavalier

1 Answer

1995 ford windstar missfiring


Did you try fuel filter. test the pressure in each cylnder could be a bad valve

Apr 09, 2009 | 1995 Ford Windstar

1 Answer

1994 chevy s 10


The couple across the street from where I live, had the same problem. He also changed plugs and wires and even the coil. I told him to replace the rotor bug and distributor cap and all started running smoothly again. Looking at the bug and cap nothing looked bad other than a little wear. It even checked out using a meter. Only thing I could think of was that there may have been some hairline crake robbing the spark and causing it to missfire.... Don't really know.

Jun 11, 2008 | 1994 Chevrolet S-10

2 Answers

1995 buick regal custom missing


you might have bad plug wires replace wires and saprk plugs

Jun 09, 2008 | 1995 Buick Regal

Not finding what you are looking for?
1995 Chevrolet S-10 CA Edition Logo

140 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

60960 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...