Question about 1997 Chevrolet C1500

1 Answer

When engin warms losses all power if floored it just sputters!

Have a 1997 z71 350 v-tech 5.7 .I have been easy on this truck from day one it has not been over worked or run down like most 97s bout a year ago noticed loss of power. after engin warms it just spits and sputers. i have learned if u slowly ease in to peddel u can get around in it still runs very well if is a really cold out side and will hardly run at all on a hot summer day. i have tried new spark pugs,wires,cap,button,pcv valve,fuel filter air filter,fuel pump,water pumpand all the tune ups i can think of ! new catilaic converts and even running with out them. temp never goes over 200. no engin light on. I think some kind of relay or sensor but dont know where to start.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Chevrolet Master
  • 71,525 Answers

Have u replaced the MAF sensor?, that is what this sounds like, when they fail they cause a severe loss of power but don't turn on the check engine light, a quick way to test it is to disconnect the sensor and idle the engine for a moment then drive it, if it runs better the sensor is the problem. Here is a photo.

.when engin warms losses all power if floored it ju - f83d538.jpg

Posted on Jan 30, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 1996 Ford Explorer 5 speed six cylinder 4 wheel drive feels like when I put on a gas is losing powers


4.0l Engine loss of power. Garage has no idea. - Ford Explorer and ...

www.explorerforum.com > ... > Elite Explorer 911!

May 17, 2010 - 19 posts - ‎11 authors
4.0l Engine loss of power. ... 1996 Explorer XLT Supercharged 347 w/ BW4406 Build Thread, 8000K ... 1999 Ford Explorer Sport [new playtoy] Intermittent loss of power
11 posts
Feb 9, 2013
93 4.0 expo rough idle power loss ((PLEASE HELP))
19 posts
Nov 12, 2011
Sputter/Stutter and Loss of Power
19 posts
Jun 2, 2010
Loss of Power on Hills (NEED HELP!)
11 posts
Apr 9, 2009
More results from www.explorerforum.com

Dec 25, 2015 | Ford Cars & Trucks

1 Answer

Do you know what the problem may be?


Ford Focus cutting out and losing engine power, mileometer going ...

www.rac.co.uk > ... > Technical and Maintenance Questions
RAC Limited 10 posts - ‎6 authors
About five weeks ago, after driving for 1/2 mile, my car cut out with no warninh ... 26-08-11, 12:04 #1 ... I have a 51 Ford Focus 1.6 petrol, about 77000 miles on the clock. ... to check it wasn't anything I was doing, and whilst it wasn't half as bad, he did ... My main concern is the power failures causing the car to actually cut out ...Missing: kuga ‎11600 ‎stutters

Petrol in a diesel car - Guide and Videos - Auto Fuel Fix

My Escape is sputtering / losing power. - Ford Forums - Mustang ...www.fordforums.com/f59/my-escape-sputtering-losing-power-191329/Old 07-08-13, 07:22 PM Thread Starter. Escape2009. Registered User. Join Date: Jul 2013. Posts: 5. My Escape is sputtering / losing power.Engine power loss and sputtering - CarGurus

Dec 01, 2015 | Cars & Trucks

1 Answer

Loss of power upon take off


What year is the car and is the check engine light on ?

Feb 16, 2014 | Lincoln Town Car Cars & Trucks

1 Answer

1991 F350 w/460 cu starts but runs rough until warm.


sounds like auto matic choke problem try a manual choke

Jan 02, 2014 | Cars & Trucks

1 Answer

Sounds like a diesel on a cold day


could be a knock sensor or rockers knocking until oil warms up and oil pressure seals the lifters

Sep 27, 2012 | 1995 Chevrolet Silverado 2500

1 Answer

My check engine light is on again and keeps sayin bank 1 and bank 2. The autozone said to replace both O2 sensors. So I did. Check engine light came back and now in the mornings when I start it, it starts...


I would start to look around For a new vehicle. Drinking antifreeze and running ruff? Sounds to me like u either A cracked a head or B have a bad head gasket. Now neither of these are easy jobs. Both cost alot even I u DIY. Not in just parts but machine shop charges. If it was me, and if it was paid off, I would look for a new vehicle and drive it till it dies completely which by the sound of it won't be long sorry for the bad news

Mar 24, 2011 | 2001 Ford Explorer Sport Trac

1 Answer

I have a 97 chevy cavalier with a 2.2 liter engine and an automatic trans. i replaced the head gasket and it ran fine for about a month. Then it suddenly started sputtering and stalling, it also had a loss...


you need to take the car to a muffler shop and have the catylitic converter changed... the converter is stopped up not letting the exaust leave the engine thus stopping it.

Jun 12, 2010 | 1997 Chevrolet Cavalier

1 Answer

Engine is back firing substantial loss of power irratic sputtering


check the fuel pressure at the engine, also check the map sensor

Jul 30, 2009 | 1997 Jeep Grand Cherokee

1 Answer

Engine Floods after brief start and run when cold -then shut off


Local mechanic determined engine was flooded and started it by holding throttle to the floor and cranking 5-7 seconds - then the engine sputtered to life. It has run perfectly before and since and I'm at a bit of loss to understand why this occurred this one time - so far. It's been driven now 5 days with no problems.

Nov 19, 2008 | 1996 Honda Odyssey

Not finding what you are looking for?
1997 Chevrolet C1500 Logo

177 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

71338 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22059 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7018 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...