Question about 1997 Chevrolet Cavalier

1 Answer

1997 z71 5.7 350 stalls after warming up (bout 10min. of driving)

Runs great on a really cold day! runs worse as it gets hotter! when its cold it will burn the tires off then the more gas u give the less power it puts out and if you floore it it`ll fall on its face.temp gage never goes over 195 witch should be normal. i have changed spark plugs,wires,button,cap,air filter,and a 185 deg.thermostat. new catalic conv. and tried running without any on. engin light is not on so no codes to find. problem has going on for over a year .none of my local shops can figure it out. some say tourk converter, transmission cooler, im not a mechanic but i think its some kind of relay swich or sensoir but dont know where to start. thanks for your time!

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 132 Answers

All of these trucks do that

Posted on Jan 30, 2009

  • Allison Hulbert Jan 30, 2009

    I have two of these same trucks out in my driveway and they both do the same thing. They have always done it.

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I changed cam phasers and runs great when cold. When it warms up it stalls at stop lights and gets difficult to restart


have vechicle code scanned bad engine coolant temperature sensor will cause vechicle to stall out and hard to crank when cold.

Sep 11, 2012 | 2004 Ford F150

1 Answer

94 trailblazer runs really rough for awhile after sitting ,after running awhile its starts to run fine (worse on cold days) help please!!!


Have a pressure bleed down test run on the fuel pump, that is the most common problem that causes this condition.

Aug 23, 2012 | Cars & Trucks

1 Answer

Hi it's grand cherokee 4.0 2004. it's -5 outside while driving on the hwy temperature goes up to almost 100, and then slowely down to 80-85, what could that be?? thermostat or something else


yes thermostat. it is running really cold. replace with a hotter thermostat or you can put a piece of cardboard in front of radiator with bout a dozen small holes in it.

Dec 29, 2010 | 2004 Jeep Grand Cherokee

1 Answer

Problems accelerating


the engine tickover is too slow when the engine is cold its running on cold start, ie:choke,, after it warms up the engine slows down this is what is causing it to stall in gear,, get some one to hold the brakes hard on and with the engine running in gear ajust the tick over till its reving at 750 - 850 rpm the revs will go up a bit when its out of gear,, before you pick a gear to go into push the foot brake down to stop the car lurching,,,

Feb 19, 2010 | 1997 Cadillac DeVille

2 Answers

My pathfinder stalls after it warms up and will not start until a few hours later. it will run find when u first start it then after awhile it will start heasitating until it stalls i tried replaceing the...


Guessing gets expensive. Is the check engine lamp ON? If so, there will be stored trouble codes that are necessary to propely determine the cause of the stall. Catalytic converters do not unplug when cold, if they are plugged, they are plugged at all temps and vehicle runs worse the more gas you give it but may idle OK. Typically, stalls after warm are electrical failures, often computers, or solid state components that fail when they heat, and cool off over tyme. Ignition components are highly suspect generally, as are sensors. crankshaft position sensor especially is common to fail only warm on most vehicles.

Sep 09, 2009 | 1997 Nissan Pathfinder

1 Answer

1997 nissan Pathfinder once warm rpms drop when


The sweet smell is your engine coolant,check for a leak under the hood,look for green fluid,Have your catalyst checked,for the other problems,and your fuel presure checked,or change the fuel filter.Either of these should help a little.

Jul 22, 2009 | 1997 Nissan Pathfinder

1 Answer

I have a 1986 Dodge 600, With a 2.4L I have done a complete tune up on the thing a new fuel pump, timing set on the car and I still have a problem. When you start the car when the car is cold it runs like...


make sure choke on carburetor is open when engine is warmed up.if all is good .carburetor is lean float bowl is low.in fuel .because the fuel pump weak or fuel filter stopped up.make sure idle speed is correct.

Apr 25, 2009 | Dodge W150 Cars & Trucks

1 Answer

When engin warms losses all power if floored it just sputters!


Have u replaced the MAF sensor?, that is what this sounds like, when they fail they cause a severe loss of power but don't turn on the check engine light, a quick way to test it is to disconnect the sensor and idle the engine for a moment then drive it, if it runs better the sensor is the problem. Here is a photo.

.f83d538.jpg

Jan 30, 2009 | 1997 Chevrolet C1500

1 Answer

1987 4x2 idling really fast when cold and stalling


Its idiling fast cause ur choke is on it mabey broke and flooding the engine check your choke valve

Nov 22, 2008 | 1987 Toyota Pickup

1 Answer

Please Help 97 Chrysler Cirrus Stalling out


Could be alot of things. If it runs good when cold and gets worse when warm, at low RPM, it may be the EGR valve. May just need cleaning. A plugged fuel filter won't cause the light to come on, but it will cause a lean condition, which will. Possibly a bad crank sensor, they have been known to have trouble at the connection, check it to make sure it's clean and tight. it's on the pass side, at the rear, were the motor & trans bolt up. first things to do are to make sure the battery connections are clean and tight. Then replace the filter..Please click on this link its the service manual ,,,

http://www.autozone.com/shopping/repairGuide.htm?pageId=0900c152800895f2



Good luck..

Sep 15, 2008 | 2000 Chrysler Cirrus

Not finding what you are looking for?
1997 Chevrolet Cavalier Logo

94 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

70346 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6864 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...