Question about 2005 Ford Escape

1 Answer

Car started chuging when started ,

Then just chugging around the cul de sac.No warning lights came up.No trouble before that morning.Now its at the garage and they are trying to solve the problem. They say coils,sprark plugs,PCM or processor.

Posted by on

  • lindarom Jan 30, 2009

    WENT OUT TO START MY ESCAPE, WOULDN'T START. WHEN IT DID START IT RAN LIKE **** AND SOUNDED LIKE IT WAS MISSING. AT THE SHOP NOW. MECHANIC WAS TALKING ABOUT THE COIL, PLUGS,FULTY FUEL INJECTORS, THE CAT CONVERTER. HE TOLD ME TO TAKE IT BACK TO THE FORD DEALER AND IT'S GOING TO COST A COUPLE OF THOUSAND.

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 3,533 Answers

It sounds like you got some bad gas, fuel filter is plugged or it is out of time

Posted on Jan 29, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why does my 1986 volvo 240 chug with low power in the morning?


sounds like the mixture is not correct for a cold engine operation
choke still on to far or not on at all or ECM is not adjusting mixture for engine temp conditions
run fault codes if ECM operated or check choke if carby

Jun 06, 2016 | Volvo Cars & Trucks

1 Answer

Ran my 92 GMC 4-3 out of gas put gas in it it chuged for few then was fine went to station filled it up it started fine drove 1.2 miles made a fight turn on accelerator it started chugging and died


Mike fuel filter may be dirty and plugging after running tank so low or possibly fuel pump has now weakened and is failing. Have vehicle scanned o see if diagnostic codes are stored to help diagnose.

Apr 15, 2016 | GMC Cars & Trucks

1 Answer

Engine light on and chugs going up hill no more than 20 mph


possible plugged catalytic converter ! Have exhaust back pressure tested ! Have fuel pressure test done as well an have DTC'S - diagnostic trouble codes check !

Jan 10, 2016 | 2006 Chrysler PT Cruiser

2 Answers

Chugging issue....


the fuel pump is going bad

Dec 01, 2012 | 2002 Ford Taurus

1 Answer

2005 Trailblazer EXT Engine Stalling


check all ignition fuses make sure they are in tight.check make sure ignition module wires intact.check battery if you have the maintance free delco battery make sure the eye is green in it.if not replace the battery.bad battery causes stalling problem.

May 10, 2009 | 2005 Chevrolet Trailblazer Ext

2 Answers

Chugging


Hi it's me rosemary2729 with a solution.
Firstly I took the car to a garage who said that they could change the plugs + air filter + fuel filter + oil etc. and if that didn't work could then try other things until they solved it. This sounded like a ticket to print money. I then decided to get a man who comes to the house and who carried out one of these diagnostic checks. He said it was the lambda sensor which is at the engine side of the catalytic convertor on the exhaust. Of course, the lambda sensor on this car model was not of the standard cheap type. The diagnostic man said about £300. On ebay I got one for £62. All internet instructions said a 15 minute job. However to save my husband of having to struggle under the car got a garage to do the job, which took 10 mins and cost £10. Car now runs like a dream, no flat spot and no chugging.
Rosemary2729

Apr 04, 2009 | 2001 Toyota Corolla

1 Answer

Chugging and power lose


Major tune up and change the crank sensor and the camshaft sensor. Also look at the wire harnes for both they have a problem shorting out. Mostly the harness to the crank sensor at or above the oil filter. This wire shorts because of heat and needs to be rerouted and insulated. Also, make sure you have all your gaskets inside of the intake maniflods and throttle body is secure with no air leakes. Change all your senors on this car that seems to be the trouble with this car is the sensors........runjoe

Feb 12, 2009 | 2002 Chrysler PT Cruiser

Not finding what you are looking for?
2005 Ford Escape Logo

Related Topics:

321 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

60541 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21927 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...