Question about Mercedes-Benz M-Class

Open Question

I have a 2008 Stavic ( Rodius ) when the engine gets hot the car cuts out, Engine is hard to start once started lucky to get into Drive and then have to quickly go to tiptronic manually select 1st gea

The mechanics have replaced Engine Temp sensor cleared the computer a number of times showed Accelerator Pedal fault 3 times even after being replaced Glow Plug fault on numerous occasions have also checked Air flow Meter EGR Valve tightened battery terminals. Car cuts out when you take your foot of the accelerator and turn into a corner the engine dies you loose Power Steering Brakes then the car is hard to start and won't idle if your lucky you can get the revs up and they hopefully you can juggle it into Drive and then into the manual mode to get home. This has been happening for about 2 months my wife who liked her car now hates it with a passion as she feels that she may kill someone or herself the car is now collecting dust in my garage

Posted by Anonymous on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
  • 3 Answers

SOURCE: 1997 Mazda 626 (2.0 liter): The check engine or

sounds like the head or head gasket is blown. your cylinders may be getting coolant in them which will not only cause the motor to lockup, but also cause bent rods and valves. check your oil dipstick and transmission dipstick to see if it looks like water or coolant is presant, also check the coolant to see if it smells like gas or has any kind of oil in it, if so, your head is likely blown.

Posted on Dec 05, 2009

Ad
samtoler
  • 666 Answers

SOURCE: 1996 Dodge Ram 1500 4x4 5.2L engine. Truck stalls

idle air controll motor is bad

Posted on Jun 18, 2010

  • 1 Answer

SOURCE: 1996 Dodge Ram 1500 4x4 5.2L engine. Truck stalls

Hi, I have the same problem, I'm sorry I can't help, but if you figure it out please let me know.

Posted on Jul 11, 2010

  • 1 Answer

SOURCE: Code P0401 EGR Insufficient Air flow detected - 2000 Toyota camry

how I change the EGR valve assist switch for toyota camry 2000

Posted on Aug 19, 2010

jturcotte
  • 8266 Answers

SOURCE: i have volvo v40 1.8 gdi 2002 ,it cuts out it

agree, idle control valve is a stretch. I would check the EGR valve for proper operation and clean the hoses if they are dirty. If not that, maybe the MAP sensor is off. Does it cut out when you open the throttle or even when you just stop at the intersection?

Posted on Feb 26, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I have a 02 buick century.I was driving and it overheated.I kept starting it and would drive a little ways and it cut back off and makes a noise.What is wrong with it?


you may be out of anti freeze, your thermostat is stuck shut, or your water pump may be broken (possible noise you are hearing).

Feb 01, 2015 | 2002 Buick Century

1 Answer

I have a 2005 Nissan Hardbody 3.3l V6 4x4. In the morning, you start and drive for long hrs no issues. The problem starts after switching it off, and when its hot. It cuts off, you crank up until batt


Sounds like a "HOT SOAK" problem.
Starter gets hot,it lacks power to crank the engine.

Possible "Vapor lock".

Check for engine codes.Possible bad temp sensor for ECU.

If fuel delivery is suspect ,try starting fluid into intake when "no start" occurs to diagnose fuel problem.

May 19, 2014 | 2007 Nissan Hardbody 3000TD

1 Answer

My car won't start.Out 10 attempt to start the engine you gonna be lucky if the engine start. And take note that when the engine run, evryhing seems to be okay. No check engine light, no engine hesitation...


Sounds like a loose connection. Check your connections to the battery for a good clean connection, and that they are tightened down. You may also have a battery that's going bad- that happens after a while. The battery can not hold a sufficient charge to start the engine, as that takes a huge drain on the battery to turn the starter. Once the engine is running, the alternator is supplying the needed power, and the battery is just being charged (which wont help if it's bad).

Apr 07, 2014 | 1997 Honda Passport

1 Answer

Engine cut out while drive


This sounds like it could be the coil needs replacing this is typical of coil problem. Hope this helps Best wishes, Malcolm Campbell.

Jun 20, 2017 | Vauxhall Astra Cars & Trucks

1 Answer

Loud noise coming from the engine check gauges light on ran hot would not start until last night started up but still has a loud noise like something is lose


If the engine ran hot [overheated] long enough then there may be some internal engine damage such as a scored piston or damaged cylinder head. If the engine was hot enough when it was shut off or stalled it may have had to cool down for a while before it would restart. You might get lucky and the noise is being caused by something simpler such as a water pump bearing or drive belt pulley. I'd start by checking both the oil and coolant levels then inspecting the water pump and drive belt for any faults. If the noise is coming from inside the engine then you'll most likely need to have a service facility take a look at it to see where the noise is coming from. Good luck, hope this helps!

Sep 08, 2011 | 2003 Dodge Durango

1 Answer

I have a 2000 Jetta 4 cylinder, 2.0 engine. It starts fine when it has not been started but once the engine gets hot and car is completely turned off it won't start. It sounds like it wants to start but...


Hi.. I had a very similar problem recoverrd to are workshop by the A.A around a month ago.
Exactly the same problem (left to cool started.? Once worm or hot engine just turning over ?)
Afdter reading all known folts and finding nothing to do with what I'd wanted. It took some time ?
Cutting it sort if found when I replaced a intermittent faulty fuel relay and run till engine hot (untill cooling fan cut in) Then turned off engine .. on turning key to see if this had cured my problem?
The engine started frist turn of key after repeating this a number of times .. this car was now starting fine (whether hot or cold)
Problem fixed..
Hopefully this will be of some help to yourselves
Hears hopping
Don Milward Premier Garages

Sep 22, 2017 | 2000 Volkswagen Jetta TDI

1 Answer

My car mitshubishi galant 2000- 4 cylinder. once


SOUND LIKE BAD COOLANT TEMPERATURE SENSOR IT WILL CAUSE HARD TO START PROBLEMS WHEN ENGINE HOT.

Jul 26, 2010 | 2000 Mitsubishi Galant

1 Answer

Hard start when engine hot


Clean the temperature sensor wire connector.
Replace the temp sensor.
Check the condition of the sensor wire cut(s) or short onto the engine block.
Monitor the fan operation with the hood open during warm up (0-15 minutes.) It should ran after the engine coolant temp get above 195F +.

Check,clean or change the air filter and breather element.

Dec 13, 2009 | 2002 Kia Sportage

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

31 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

yadayada
yadayada

Level 3 Expert

76051 Answers

Michael Contreras
Michael Contreras

Level 2 Expert

166 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...