Question about Cars & Trucks

Open Question

My ESP light is on in my 2011 sabb 9.3 turbo sedan. I'm loosing engine pressure and my engine light is staying on. What's the solution?

Posted by Anonymous on

Ad

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
  • 84 Answers

SOURCE: 01 Beetle turbo - ESP light

There must be faults if these lights are coming on. Check these first. (Scanner needed) Sounds alot like a boost hose is pierced or loose. Check all of them from the turbo to the intercooler and then to the motor. Also check closely the intercooler might be pierced too so small you won't see. Check all the clamps are tight around all these hoses. Many times both lights come on if your map sensor on the intercooler isn't getting good readings but rarely is the problem the sensor.
You might have a strange air sound at first then the car will go into limp mode and you loose all power.
If everything is good there check the mass air flow sensor.

Posted on Oct 31, 2008

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

The dasboard lights won't come on and engine does not crank


Engine not starting (does not crank) but all dash lights working ...

www.benzworld.org > ... > Mercedes-Benz Sedan Forums > W203 C-Class

Jan 18, 2011 - 10 posts - ‎4 authors
However, when i turn the key all the way, the engine does not even try to ... if its the battery, won't the car at least try to start up? i can't get it to ... 08 C300 won't start
10 posts
Jan 26, 2012
Vito W639 115cdi engine won't start
10 posts
Mar 9, 2011
1996 E320 Wont Start No Ignition Click
6 posts
Oct 3, 2010
98 ML320: No start, no crank; is it the AAM?
8 posts
Sep 16, 2009
More results from www.benzworld.org

Mercedes-Benz C-Class Questions - My car won't start, it ...

www.cargurus.com > Questions > Mercedes-Benz > C-Class

CarGurus

Jan 07, 2016 | Mercedes-Benz C-Class Cars & Trucks

1 Answer

How do I reset the oil change notifier?


Don't really know about the Sabb's. But if you don't have a rest in the fuse panel. Then turn the ignition on, press the fuel pedal three times within five seconds. The light should flash, when it stops, turn the ignition off. this should reset it.

Oct 14, 2014 | 2011 Saab 9-5

1 Answer

2005 sabb 9-3 sabb heater doesn't blow hot air. blowers work fine.


The valve regulating the water flow to the heat exchanger could be broken. It needs to be replace.

Jan 20, 2013 | 2005 Saab 9-5 Sedan

1 Answer

I just got a 2002 95 sabb with 95k on it the check enjine light came on, ran diagnostics on it and it didnt come up with anything for a sabb only a bmw somthing about troubleshooting p1181 is this a...


1) make sure there are no leaks / loose hoses in the air intake system 2) Clear the MAP sensor which is to the front of the passenger side of the car just under the hood. Big square thing inline with air intake. 3) Get a known good MAP sensor and see if code is still happening.

Aug 11, 2010 | 2002 Saab 9-5

2 Answers

2001 saab 93 oil lite stays on


Have the oil pressure checked to make sure that the light is correct,or change the oil sending unit.

Apr 16, 2010 | 2001 Saab 9-3

1 Answer

01 Beetle turbo - ESP light


There must be faults if these lights are coming on. Check these first. (Scanner needed) Sounds alot like a boost hose is pierced or loose. Check all of them from the turbo to the intercooler and then to the motor. Also check closely the intercooler might be pierced too so small you won't see. Check all the clamps are tight around all these hoses. Many times both lights come on if your map sensor on the intercooler isn't getting good readings but rarely is the problem the sensor.
You might have a strange air sound at first then the car will go into limp mode and you loose all power.
If everything is good there check the mass air flow sensor.

Oct 29, 2008 | 2003 Volkswagen New Beetle Convertible

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

51 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

76132 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...