Question about 2000 Chevrolet Blazer

1 Answer

Won't start got gas, new cap & rotor

Posted by on

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 10 Answers

Out of curiosity have someone crank the motor while another strikes the bottom of the fuel tank with a rubber hammer.Sometimes when brushes in fuel pumps get weak this will help it at least start.If that doesnt work try fuel pressure tester to see what the pressure is. Some models need a certain amount to even try starting.

Posted on Feb 04, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I did a burnout in my 1995 camaro and it died going into third and now it won start. i have new plugs and wires plenty of gas a new fuel filter new oil and filter an new air filter and cvp valve and


if you have LT1 engine there is a chance the screw on you opti rotor came loose,if that is the case,you need new rotor if lucky or whole new opti,either way,even if you end up buying brand new opti,before installing ,take cap off,take the rotor screw off,put some blue lock tight on screw then put it back on,it is a bad habit of lt1 engine opti

Aug 16, 2014 | 1995 Chevrolet Camaro

1 Answer

Replaceddist,rotornowwon t start


Do you mean you fitted a complete new distributor ? ie did you remove the dissy from the engine or was it just the cap and rotor you renewed ?If you removed the complete assembly,when refitting it will need to be timed up .

Oct 18, 2012 | 1992 Honda Civic

1 Answer

Won't start fuel pump replaced new tank and relay have fuel after fuel filter runs if I put fuel down throttle body. this is on a4,3.


Nephew had similar problem on different vehicle - had spark to plugs, limited gas, everthing else checked. I did one thing first - check for two fuel filters - one in the tank was only screens and one in the line itself. Found a little in line filter just outside of engine compartment under car next to frame that looked like it had never been changed - partially clogged - replaced it.Almost ran but would not keep running. I had rotor and cap pulled - found that the screw holding rotor in place was loose. The rotor edge next to plug wire leads was chopped up and the cap's plug wire leads were heavily oxidized. Replaced them and got it running but a little rough. Pulled the spark plugs and found gaps from 25 - 100 ---replaced the plugs with correct gapping and it ran really well.

Aug 25, 2011 | 1991 GMC S-15 Jimmy

5 Answers

Truck wont crank. we have put new distributor cap, rotor button, coil pack, plugs, wires, and fuel pump. we also checked our firing order.


you said you repl dist cap that means you don't have a crank sensor you have electronic ing module. remove your elec ing module have it tested most auto parts stores could test your module, or check your coil at the neg terminal. should have power. if not you lost your primary volt from your batt.your secondary power is coming from your electronic ing module from the module to the pos terminal on the coil, when the eng cranks,from the coil to the dist cap , from the dist cap center to the rotor then out to the plugs,this all happen pervided the timing belt or timing chain is ok. the cumbustion chainber needs 3 things , thats fuel, air, and spark.

Apr 17, 2011 | 1996 Chevrolet K1500

2 Answers

My `93 subaru legacy 2.2 turns over but won`t start


Could be as simple as a new rotor and distributer cap. As the rotor and contacts inside the cap wear, it will take more and more revolutions to get it to catch.

Sep 04, 2009 | 1995 Subaru Legacy

1 Answer

96 tacoma, ran fine, parked it and now it won,t start. Has fuel, new fuel filter, new battery, acts like it wants to but will not completely fire up. HMMMM.


are you sure you getting fuel even though you have new fuel filter, check all fuses under the dash to fuel pump and relay under the hood, are you getting sparks? check rotor, cap, coil...make sure you getting 2 important items, gas and fuel to the engine. hope that help some

Jul 12, 2009 | 2001 Toyota Tacoma

Not finding what you are looking for?
2000 Chevrolet Blazer Logo

Related Topics:

52 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

61249 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...