Question about 2005 Chevrolet Venture

1 Answer

Both front and rear heater fans don't work, mechanic says it is an ignition switch?

Heater fans quit working, temp control and ac also. Mechanic says it is an ignition switch.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Chevrolet Master
  • 5,332 Answers

Both "blower" fuses are fed by the ignition switch. If there is no power to those fuses than the switch is the likely problem.

Posted on Jan 22, 2013

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2009 buick lucerne, heater/ac fan intermittent working, then quit. Have already replaced climate control panel, blower resistor and blower motor. Still nothing. Anyone?


My Lesabre did that and I am not sure how my mechanic did it but he said it would cost an arm and leg to repair it so he hooked up a separate switch under the dash and everything worked after that. a seventy five dollar fix is better than three hundred. See if your mechanic has an idea. He said the off and on part of the automatic switch was not working but after he put an off and on switch in the line the climate control worked.

Dec 16, 2016 | 2009 Buick Lucerne

1 Answer

No air in front but i have air in rear is there a belt in front ??


Can you hear the front ac/heater fan? They use the same AC compressor so that should be okay. The fan switches fail quite often on those. That controls how much air is pushed by the fan for AC, heat and defrost. The switch is attached to the fan knob on the dash.

Aug 29, 2014 | 2005 Chevrolet Suburban

1 Answer

Temp control problem - worked mint until pro mechanic changed leaking heater core. Heater controls are now a mess. Pro mech who fixed heater core, is still trying to figure it out. Help me help pro me


there is a few things to check .. the linkage on the side if it's misplaced. look for the temp control motor connector not connected or misplaced and check the vacuum hose to vacuum pack if they are at the right place and when you move the mode switch if vacuum pack work could misplace the vacuum hose

there is many system d?pends the year
hope it help let me know

Jan 28, 2014 | 1996 Pontiac Grand Am

1 Answer

Cooling fan will not turn on


The cooling fan is controlled by sensors in the cooling system so providing that you can move the fan blades easily and you have current getting to them I would be having a code reading to check for failing sensors. As to the a/c problem the compressor operation is controlled by 3 switches 1 switch is the heater fan must be on as well as the ac switch --2 is a switch that turns the compressor off if the head pressure is excessive and 3 is a low pressure switch that turns the compressor off if the pressure is too low (no gas). have a ac mechanic check out the system for leaks

Jul 14, 2013 | 2008 Mercury Milan

1 Answer

Where is the AC sensor in 2005 Jaguar S Type located


the water heater control valves are front right down low behind the radiator and are electricaly operated ,the AC pipe that runs under the engine but above the sub frame could be corroded out as this is a common fault with these cars ,also the electrical solonoids that shut off the heaters can corrode up as well but i have known them to stick open.

Aug 14, 2017 | 2005 Jaguar S-Type

1 Answer

Have 97 honda accord 2.7 i've done everything, relays, fuses, temp sensors, radiator, jumped the fans with direct wire to battery, work fine, tried to run ac see what it would do but nothing ar all...


i am confused you have not mentioned your problem but it sounds like your engine cooling fan is not working? if so try replacing the cooling temp sending unit located on or near the thermostat housing. in fact disconnect it while engine is running and it should turn fan on in a few seconds.goodluck

Sep 03, 2011 | 1997 Honda Accord

1 Answer

My 2000 chevrolet venture fan didn't work on 1, 2 it only works from 3-5, but when i get to mechanic he said the coolant temp unit need to be change. Can you pls tell me what might cause the problem?


I am assuming you are talking about the ac heater fan? You need a new fan speed resistor, I think your mechanic is confused and this you are talking about the engine cooling fan? Let me kno please rate

Aug 02, 2011 | 2000 Chevrolet Venture

1 Answer

I have numerous proglems. I have a 2000 intrique. The right back signal light blinks very fast, doesn't work in the front. The ac blower works fine but blows warm air.A mechanic , someone my hysband...


Your rear turn signal flashes fast because the front is not working. Most likely you have a burnt out bulb in the front. If your A/C compressor can be turned over by hand and doesn't lock up or make any clanking sounds it's probably alright. The compressor will not run if the system is low on refrigerant. If you're having problems with the A/C and heater controls, that would be the first ting to repair. It doesn't sound at all like any electrical problems.

Jul 20, 2011 | 2000 Oldsmobile Intrigue

1 Answer

Cruse control


Does your blower fan work on your heater/ac or your rear defrost work it could be the igniton switch were you put the key in. Turn the car on and off several times once you notice the cruise will not work and see if it starts to work if it does than it is the ignition switch this just happen to my 2003 century.

Sep 14, 2008 | 2003 Buick LeSabre

Not finding what you are looking for?
Cars & Trucks Logo

133 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75066 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7754 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...