Question about 1999 Ford Ranger SuperCab

1 Answer

1999 Ford Ranger bottom hose and radiator is cold but top hose is very hot while blowing water out the overflow..what are possible causes?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Ford Master
  • 3,904 Answers

I would check the water pump on this one.

Posted on Jan 21, 2013

  • sfcbama
    sfcbama Jan 21, 2013

    the water pump isn't leaking and everything was working fine until we replaced the elbow that the temp sensor goes into

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

1999 Dodge 1500, After driving 30 miles the heat is barely warm. Heater core hot both inlet and outlet and the bottom of the heater core is hot, top rad hose warm, bottom rad hose cold, Radiator cap u


sound like the impelled in your water pump may have failed. Or your system is air bound. Try to open the rad cap when its cold and let it run and see if air bubbles come to the top

Oct 04, 2014 | Dodge Ram 1500 Cars & Trucks

1 Answer

1999 ford ranger 3.0 heater wont get hot. blend door is working. truck blows whatever the air temp is out side with heater on hot.


That means either you have a vapour lock, your water pump has failed, or your thermostat isn't opening. It is not easy for a non-mechanic to put coolant into a vehicle... more often than not you get a vapour lock. Sometimes this happens if you don't check your overflow bottle daily, (or weekly). If you have no habit of checking your tires, your oil, your brake fluid, your signals, transmission fluid etc then it is easy for you to neglect your overflow bottle. If the coolant gets all the way to the bottom then your radiator will start emptying daily into your overflow bottle and causing you problems.

Oct 20, 2013 | Ford Ranger Cars & Trucks

1 Answer

I have a 1991 Ford Ranger 2.9,and I am having a heat problem I did change the thermostat but no heat yet,this is what I found so far. I checked top radiator and its hot,the bottom hose on radiator is cold....


ok in the engine compartment look at the radiator with the engine cold NOT ON" squeeze the hose with your fingers and feel if hose is crunchy or brittle if is possible a block could have happen locations /points at the vacuum heater valve gate on the heater hoses or a clogged up lower heater hose get a water hose and back flush the heater's hoses normal travel of water is from bottom to top so put the water hose to the tophose and flush backward and try to move the heater valve by finger and see if you get flow (mind you with hoses of the radiator DONT CRANK YOUR ENGINE)

Sep 10, 2013 | Ford Cars & Trucks

2 Answers

Lower radiator hose stays cold after running for hours


could be you fitted the thermostat in the wrong way around ,or the plastic impeller on the water pump with a steel drive shaft has failed they end up with the drive shaft spinning but the impeller is not turning ,go for the thermostat first though .

Feb 08, 2012 | 1991 Ford F150

1 Answer

Overheating


CAR OVERHEATING FIRST CHECK FOR LOW COOLANT IN THE RADIATOR COOLANT OVERFLOW JUG.IF COOLANT LEVEL IN OVERFLOW JUG LOW REFILL ADD COOLANT BACK TO THE FULL COLD MARK.PUT RADAITOR CAP ON COOLANT OVERFLOW JUG START ENGINE LET IT IDLE UNTIL IT OPERATING TEMPERATURE.MAKE SURE TOP RADIATOR HOSE GETTING HOT WHILE ENGINE WARM UP.IF TOP RADIATOR HOSE DONT GET HOT WHILE ENGINE IDLING YOUR THERMOSTAT COULD BE STUCK CLOSE CAUSING CAR TO OVERHEAT.IF TOP HOSE IS GETTING HOT.CHECK FOR COOLANT LEAKS CHECK TOP RADIATOR HOSE AND BOTTOM RADIATOR HOSE FOR LEAKS.CHECK FOR LEAKS AT THE RADIATOR CORES AND PLASTIC SIDE CONTAINERS.IF ALL IS GOOD ENGINE OVERHEATING WHILE IN A LONG TRAFFIC LINE, COOLANT FANS NOT COMING ON.COULD HAVE FAULTY ENGINE COOLANT TEMPERATURE SENSOR OR BLOWN COOLING FAN FUSE OR RELAY.COULD HAVE PCM FAULT.MAKE COOLING FAN ELECTRICAL CONNECTORS AND WIRING NOT DAMAGE OR BROKEN.

Jul 17, 2011 | 1999 Oldsmobile Alero

1 Answer

My truck is blowing cold air out the back vents and after about a minute of driving, the front air conditioner starts slowly blowing heat until if feels like the heater is full blast.....people have said...


There are a couple of different things that could cause the loss of heat. First make sure your radiator and overflow tank are full and at there specified levels. Run the engine till it reaches operating temperature( between 180 and 220 degrees). Feel the upper radiator hose and lover radiator hose , they should both be HOT , this lets you know your thermostat is working. If the top hose is hot and lower hose is cold. Replace the thermostat. If they are hot, check to see if both heater core hoses are hot ( 2 5/8 in black hoses heading into the firewall). If one side is hot and one side is cold, replace the heater core. If both are hot, you may have a broken cable or vacuum diaphragm that moves the direction control valve from hot to cold. Below are some example diagrams to help aid you in your diagnosis.

Apr 12, 2011 | 1997 Ford Expedition

2 Answers

No heat bottom radiator hose stays cold and top hose gets hot. installed new thermostat and nothing changed.


You should check for a valve in the heater hoses, and if the vehicle is running cold - below the normal mark on gauge.

Jan 17, 2011 | 1985 Ford Ranger

4 Answers

Running hot


Too many possibilites. Even old spark plugs can make it run hot. Slipping belts also possible. Bad thermostat is common. Retarded ignition timing can do it. Problems with the radiator fan motor/relay/sensor can do it. Low coolant is possilbe. Head gasket is worst case scenario. I would not suggest a flush this new. But you could run a pressure check on the radiator. See if it holds pressure. Also verify with a thermometer, because the gauge could be off instead.

Mar 04, 2010 | 2002 Ford Taurus

Not finding what you are looking for?
1999 Ford Ranger SuperCab Logo

198 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

fordexpert

Level 3 Expert

5546 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...