Question about Cars & Trucks

1 Answer

Oil psi unit on 1971 LT1 - Cars & Trucks

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Cars & Trucks Master
  • 21,873 Answers

What is your question ?

Posted on Jan 21, 2013


1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 1994z-28 after it running about 20mins it start spitting and spatting every few seconds. what is this?


Trouble with my new- to- me '94 z28 already - CamaroZ28.Com ...

www.camaroz28.com > ... > LT1 Based Engine Tech
Apr 9, 2012 - Couldn't reach the other side before running out of time. .... Does the carstart up after it has sat for a while and cooled off? 1994 Z-28 LT1 A4, Supercharger 6 psi, 3.73 Gears, GMPP 1.6 Rockers, LT4 Springs, ... Ten minutes into a drive it willstart to sputter and then die, ... so nice!...for about 20 minutes.

how long does it take to heat up?? - LS1TECH

ls1tech.com/forums/lt1-lt4.../1371680-how-long-does-take-heat-up.html
Jan 8, 2011 - 1994 z-28 m6 procharged all the goodies ... to get hot lol.. change back to stock if you want it to run a regular temp ... I hit the freeway almost immediately afterstartup so the car doesn't really get a chance to "get hot". ... To answer the original question my old LT1 took about 15-20 minutes to blow warm heat.

Dec 01, 2015 | Cars & Trucks

1 Answer

Low oil pressure lt1


You have verified this with a mechanical test gauge at the oil pressure sending unit port?

Apr 26, 2013 | 1996 Chevrolet Corvette

1 Answer

If my oil sending unit is out will my truck break down


yes,it reads oil pressure only,if its out as long as it was working fine before it went bye bye your fine,you won't blow up engine or break down.

Nov 28, 2012 | Cars & Trucks

1 Answer

How do i tell if i have a bad oil pump or a bad oil sensor


If oil level in engine is at proper level, I wouild suspect oil pressure sending unit, does vehicle have an oil psi gauge on dash,,,if so what does it read. if oil psi reads well then it may be an oil level sensor. if you have access to a manual oil pressure gauge, you can remove the oil psi sensor and install manual gauge to get a true reading of what oil pressure is while running. if manual gauges shows low psi, then you may be looking at an oil pump.

DW Mylin

Nov 27, 2012 | 2006 GMC Envoy

1 Answer

NO OIL PRESSURE READING ON DASH


remove sending unit and install mechanical gauge to see oil pressure psi if psi reads ok- change sending unit again if psi to low less then 6 replace oil pump och.

Sep 18, 2012 | 1990 Toyota 4Runner

1 Answer

Oil pressure gauge is reading 80 psi. I had the


The oil sending unit is located on the engine block behind the drivers cylinder head area.You have to climb up on the motor to see it cause it is hard to see behind the wiring harness.You may also want to purchase a new sending unit because it is very long and you might need to buy the sending unit socket to replace it.Hope this helps.Good luck.

Jul 20, 2010 | 2003 Chevrolet Silverado 1500

1 Answer

Oil pressure gauge not reading on my 1994 jeep wrangler. oil is full just the guage has no pressure and not alot of power


The oil pressure specification for your engine is 13 PSI at idle hot, 37 to 75 PSI at engine RPM higher than 1600. I suspect your oil pressure gauge sender unit or gauge is inaccurate. I would have a known accurate mechanical oil pressure gauge temporarily screwed into the present oil sender unit to verify actual pressure.

If you have the correct pressure I would replace the sending unit first.

Sep 23, 2009 | 1994 Jeep Wrangler

1 Answer

My oil pressure switch pegs at 80


that sounds gd far as oil pressure does it have the lt1 motor

Nov 23, 2008 | 2002 Chevrolet Corvette

2 Answers

Oil pressure gauge reads 80(pegged),,oil tepm is 207....car runs great


it is probably the oil sending unit if you have access to a direct reading oil pressure gauge put it on and if oil pressure is reading normal replace sender

Nov 05, 2008 | 2000 Chevrolet Corvette

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

17 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

75117 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...