Question about 1994 Geo Tracker

1 Answer

Not firing fuel pump quit then after that was repaired it isn't firing

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 34 Answers

How is your fuel pressure after the fuel pump replacement? (requires adapters and a gauge.) You also can use "test fuel" (like starting fluid) to help determine if the problem is fuel or ignition. Just be careful as the stuff is explosive. For more in depth trouble shooting you might want to visit a Suzuki forum. (Your Tracker is a rebadged Suzuki Sidekick.)

Posted on May 22, 2014

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 207 Answers

SOURCE: It will crank and run

hi u could have ablocked fuel filter try replacing it if u have and motor is carburetered check were fuel line fits onto carby theres often a fine gause filter inside the bango fitting hope this helps

Posted on Sep 13, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

96 T100 (3.4), will only run for 2-3 seconds then quit, change fuel filter, pump, cam sensor and crank sensor still won't run, but will run on ether. Where to go next?


What you are telling me is the engine is firing the plugs but not getting fuel.
When you changed the fuel pump and filter, did you check the fuel pressure at the rail ?
Are the injectors getting power and ground pulse ??

Dec 21, 2012 | Cars & Trucks

1 Answer

Van idles fine but when going the the road giving it gas it acts as if it isn't getting the proper gas ... it back fires....repleaced fuel filter and pump, crank and cam sensior


sounds like the timing is off. check the firing order to be sure your plug wires are on the correct positions on the coil packs. if that checks out, possibly a timing chain may need replaced. i hope this helps
don k.

Jul 24, 2012 | 1999 Plymouth Voyager

1 Answer

Have a 2000 GMC Yukon Denali. Won't fire.


Make sure that the belt isn't extremely tight and they the belt tensioner isn't liked up by pulling in the belt. It should move and spring right back. Make sure engine isn't locked up. And please explain what happen with the vehicle. The fact that you replace plugs and wires and fuel filter for a car that's not turning is throwing me off. So right now we are going all over the place. But definite look at belt and tensioner I've seen a few times that a bad tensioner will make the belt wrap around tighter inhibiting the engine from turning.

Jun 26, 2012 | GMC Yukon Denali Cars & Trucks

1 Answer

Turns over but won't fire


If a starter is able to crank the engine but it won't start you usually have either an electrical or fuel problem. It's also remotely possibly that it's compression.If an engine has proper fuel, spark and compression, it will start when you crank it. So your challange is to find out which part isn't working right. Start with fuel. Spray a little starting fluid into the air intake while someone tries to start the engine. If it starts briefly when you're spraying starting fluid, you probably have a fuel delivery problem. That could be injectors, fuel pump, fuel filter, relay, fuse... who knows what until you check into it.If it doesn't start with starting fluid, check the spark. Pull a plug wire and attach it to a spare sparkplug and set the plug on a solid metal part of the engine. Have a helper crank the engine while you watch the plug. If you have a good spark, it might just be out of timing.In any case, you'll need to start isolating the problem. Find out which part isn't working then you'll know what to replace/repair.

Jun 25, 2012 | Cars & Trucks

1 Answer

97 geo 1.3 intermittent start


If it starts with starter fluid, there is nothing wrong with the ignition, so `the sensor query is not applicable. It is a fuel starvation problem. You say no fuel from pump and pressure good, which is it? If the pump isn't working, it can't build pressure. If the pump is working and it does have proper pressure, you may have a problem with the injector circuit not working. Post back with your answer. I'll try to help you solve it.

Jun 09, 2012 | 1997 Geo Metro

1 Answer

Fuel pump leaking oil


Sounds as though the pump isn't seated properly. I know the one bolt is hard to get to, however, if the pump isn't seated properly, it won't bring fuel up to the pump. May possibly need another gasket as well. But, from what the symptoms sound like, it's not getting fuel from the tank to the pump and most likely from the pump not seated properly.

Jan 03, 2012 | 1987 Suzuki Samurai

1 Answer

It quite after backfiring has fire but it's like it isn't getting gas.


if you spray intake cleaner into the intake with the air snorkel off and it starts then i would say you have a fuel pump problem.the backfiring was probably caused by the motor all of a sudden going lean.you will have to check the fuel pressure with a gage it should be about 35lbs pressure to run the car.if the pump needs replacing change the fuel filter.

Sep 16, 2011 | 2002 Chevrolet Venture Passanger

1 Answer

It will crank and run good for a little while then it will skip a few times then cut off, we've narrowed it down to fuel. It is firing but isn't getting fuel, not the fuel pump because it seems to...


hi u could have ablocked fuel filter try replacing it if u have and motor is carburetered check were fuel line fits onto carby theres often a fine gause filter inside the bango fitting hope this helps

Sep 13, 2011 | 1991 Geo Tracker

1 Answer

Fuel pump not turning on. Won't fire but will turn over. swapped out relay, still not fire.


Try banging on the fuel tank, and then quickly try to start it, if it starts your fuel pump is almost dead and will need replaced soon.
If it doesn't start, test for power at the wiring connector on top of the fuel tank. This test requires 2 people, because the fuel pump is only powered for a few seconds when the engine isn't running. If you have power, then the problem is in the fuel pump (completely failed or bad wiring connection on the pump/inside the sending unit)

Aug 24, 2011 | GMC Jimmy Cars & Trucks

1 Answer

I need to know where I can find the fuel reset button.


Although many Ford vehicles have a fuel pump inertia swtich that can be reset if tripped, there isn't a fuel reset button on this vehicle. Power for the fuel pump is supplied by a 20 amp fuse [#6 in the relay center I believe] and the power is routed through the fuel pump relay which is controlled by the Engine Control Module and then sent out to the pump. I rarely see a blown fuse or bad relay but do see a lot of pumps that wear out an quit working.

Apr 23, 2011 | 1996 Oldsmobile Eighty Eight

Not finding what you are looking for?
1994 Geo Tracker Logo

142 people viewed this question

Ask a Question

Usually answered in minutes!

Top Geo Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8210 Answers

Are you a Geo Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...