Question about Hyundai Genesis

Open Question

Hyundai getz lack of power

Engine runs and revs up ok, until its put under load, it isnt misfiring, have changed cat, throttle body, cam sensor and crank sensor too, have changed coil packs and sensor on inlet manifold too but no difference.its the 1.1, gsi getz on a 53 plate.

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
  • 19 Answers

SOURCE: S10 pickup misifirng when light highway load

I had to rebuild my engine at 97000 miles cuz of low engine oil pressure and bad berrings

Posted on Jan 09, 2009

Ad
Brian032472
  • 150 Answers

SOURCE: 2001 MPV Runs Rough at Idle and Low end Throttle

This could be a bad fuel injector. Lean implies low fuel to the cylinder which will cause a misfire.

Posted on Feb 01, 2009

Brian032472
  • 150 Answers

SOURCE: 2001 MPV Runing Rough at Idle & low end Throttle

the lean condition is the big clue here it indicates a lack of fuel which is causing the mis-fire on #3. I would suspect a fuel injector is clogged or not getting a pulse from the PCM. ( pulse is the electronic signal)

Posted on Feb 01, 2009

  • 64 Answers

SOURCE: 1999 volkswagen stalled

first check cylinder 1 , spark plug, ht leads, coil,

then clean the trottle body with carb cleaner

if that does not work replace the throttle body, comes complete, and do a basic setting on it with diagnostic machine

Posted on Feb 19, 2009

Mikey108
  • 475 Answers

SOURCE: 2002 Jeep Grand Cherokee Lardo misfiring

You say you changed the cam sensor. A1391 code is a crank sensor on the top of the trans. bell housing.

Posted on Feb 24, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

What causes engine miss at idle under load?


I'm not sure what you mean by "under load", maybe with a/c on, etc. Also is it really an engine misfire or a rough idle. If it really is a misfire, a scantool at your local parts store should be able to read a code for that. Sometimes a rough idle could be due to just a cracked or disconnected vacuum hose or dirty throttle body. You didn't say whether it runs ok at highway speeds. Sometimes a rough idle can be cleared up a lot with throttle body service or injector flush. Sorry, this is the best I can do with information provided.

Jul 16, 2014 | 2002 Hyundai Santa Fe

1 Answer

How to fix f85 codes in cadillac


this is what i found about code f85




QUESTION: 1991 Sedan Deville, 4.9 port injection
Car runs great until outside temp reaches 92 deg. or above. the car will start to cut out under load (take off or hill. if i pull over the car will idle fine rev the engine to a steady high rpm and it will cut out. i had a code e44 (o2 sensor rich)so i replaced o2 sensor with no effect. the other code received was f85 (Throttle body service required). I have checked all connectors and hoses attached to the throttle body. all ok. looking inside throttle body there ar two tubes under the flaps one is totaly restricted with a black buildup and the other partly blocked. Not sure what these tubes do and if that could cause engine to cut out when hot and under load. any ideas?

ANSWER: You found your problem which is this black residue which when hot turns to a jelly substance and blocks the idle air passage. You need to clean all that residue from the throttle body and do not forget to spray the small hole in the side of the throttle body just behind the throttle plate.

Dec 05, 2012 | Cars & Trucks

1 Answer

Engine backfiring and loss of power with throttle pushed in slightly


Need to put the cat back & the Oxygen Sensors

The O2 Sensors are for adjusting fuel trim

Can't use the vehicle the way you have it & it is
against Federal Laws to remove Emissions Equip.

Sep 19, 2012 | Cars & Trucks

1 Answer

I have a 1997 lumina with 3.1L. the problem started with loss of power under load and p0300 code. check coils and vacuum leaks both OK.change spark plugs and wires.[same problem] check compression OK.


Since you changed the sensor we will assume it is working. When you disconnect it you put the computer in limp mode which stops it from using sensor values. If code 300 is the only code we will assume the coolant temp sensor and others are ok.
I would check fuel pressure with a gauge next.

Aug 21, 2012 | 1997 Chevrolet Lumina

1 Answer

1997 ford explorer Multiple cylinder misfire


I would want to know what the fuel pressure is on the rail. Sounds like the fuel pressure regulator has failed, or the return line to the tank is blocked.

Jul 26, 2012 | Ford Cars & Trucks

1 Answer

06 Hyundai Azera error code p0300, car ran rough at first then ok , check engine came on, Dealer put fuel injector cleaner in it. had problem a year ago and dealer said problem was accellerator pedal...


P0300 is a random misfire detected, and it would cause me to do a good tuneup-clean the throttle body, air filter, fuel filter, plugs, plug wires (if it has them), oil change (just because)-fuel injector cleaner is voodoo and the dealer proved that he did not know what was wrong when he did that in my opinion-while there is nothing wrong with throwing in a bottle of injector cleaner once in a while, it is NOT going to fix a misfire problem-that is probably an ignition issue that may be confounded by a bad fuel filter/air filter or leaking injector o-ring.

Jan 24, 2011 | Hyundai Azera Cars & Trucks

2 Answers

1999 Dodge Ram 5.9L 4X4 not enough fuel


check the fuel filter and the EGR valve

May 07, 2009 | 1999 Dodge Ram

4 Answers

VW Polo Map sensor fault code idling pooly


Hi, I have a 2001 polo 1.4 mpi it lackes power when you hit a hill it just dies, It has had new cat, fuel filter, fuel pump and throttle body, but is still the same it just dose not want to give me full rev's?

Mar 30, 2009 | 2002 Volkswagen Golf

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

172 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hyundai Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8273 Answers

Are you a Hyundai Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...