Question about 1999 Toyota 4Runner

1 Answer

99 4 runner v6 The engine pulsates at idle and during acceleration ,It goes up and down about 100 RPM and you can feel it under acceleration. what could be the cause?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 13 Answers

If this a petrol engine, you have an air leak some where on the intake manifold. Test with soapy water and a paint brush whilst engine is running at idle. check all connections to the manifold and when soapy water gets sucked away, you have identified your leak. Start with the air cleaner and work along system back to the manifold.

Posted on Jan 19, 2013

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 1 Answer

SOURCE: 99 toyota 4-runner low idle, and hard start in cooler weather

Take ur suv to the nearest high point...Get out of the suv, put it in neutral..and firmly push off of cliff. Problems solved. report it stolen the next morning.

Posted on Mar 17, 2009

  • 1 Answer

SOURCE: rav4 99 P0303 ( random misfire) and P0300 and P0302

Had the same problem on my brothers Rav4. We changed the Plug wires and the problem is corrected. He had changed the plugs a couple of months ago. We had the code read at Advance Auto, it came up P0300 Random misfire. His old wires looked fine also.

Posted on Jan 22, 2009

countrysi248
  • 443 Answers

SOURCE: STUTTERS DURING ACCELERATION

throttle position sensor .. this lets the computer know just where your foot is on the gas .. It gets worn out in that position because that is where it is used the most. I would check it first then go from there... they are priced reasonable .. always start with the least expensive first then go from there. thanks Jerry holler if you need more

Posted on Feb 05, 2009

  • 89 Answers

SOURCE: Idle surges when it warms up.

sounds like an engine management fault it will need to go on a computer

Posted on Jul 11, 2009

  • 1861 Answers

SOURCE: engine pulses up and down at idle. between 700

Most likely, a bad throttle position switch.

Posted on Jul 19, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

2004 mazda 3 starts but will not idle stalls under 2000 rpm


You need to plug it in to an engine diagnostic computer, it is probably a sensor that needs to be replaced. (Coolant temperature sensor is a probable cause) but you should plug in to engine diagnostic computer.

Apr 13, 2014 | 2004 Mazda 3 1.6

1 Answer

Gm 4.3 v6 upper engine noise at idle


Check ALL of your pulleys. Look closely at the tensioner pulleys with the belt off. If you feel any slack at all, replace it soon.

Feb 06, 2013 | 1997 GMC Sonoma

1 Answer

I have an 02 wrangler and the oil preasure goes down when Idling is that an oil pump going bad?


First we would need to know when this occurs. Asuming the oil level is at the full mark!. If the pressure goes up during acceleration and down at idle when engine is fully warmed up, then this is normal. An engine requires 10 psi of oil pressure per 1,000 rpm ( ex. 20 psi at 2,000 rpm, 25 psi at 2,500 rpm, and so on ) . If the gauge is moving back and forth erratically at idle , i would say the gauge is bad. If it drops to 0 while accelerating I would say your oil pump is bad. If from time to time it seems to work and other times it seems not to work, I would say the oil pressure sending unit for the gauge is bad. If the pump failed you would start to here a Knocking noise from the engine in a short period of time. Use the above scenario's to narrow down what it may be.

Oct 16, 2010 | 2002 Jeep Wrangler

1 Answer

Oil pump is going bad in my 1999 chevy lumina


First we would need to know when this occurs. Asuming the oil level is at the full mark!. If the pressure goes up during acceleration and down at idle when engine is fully warmed up, then this is normal. An engine requires 10 psi of oil pressure per 1,000 rpm ( ex. 20 psi at 2,000 rpm, 25 psi at 2,500 rpm, and so on ) . If the gauge is moving back and forth erratically at idle , i would say the gauge is bad. If it drops to 0 while accelerating I would say your oil pump is bad. If from time to time it seems to work and other times it seems not to work, I would say the oil pressure sending unit for the gauge is bad. If the pump failed you would start to here a Knocking noise from the engine in a short period of time. Use the above scenario's to narrow down what it may be.

Jul 02, 2010 | 1999 Chevrolet Lumina

2 Answers

99 toyota 4-runner low idle, and hard start in cooler weather


Take ur suv to the nearest high point...Get out of the suv, put it in neutral..and firmly push off of cliff. Problems solved. report it stolen the next morning.

Mar 10, 2009 | 1999 Toyota 4Runner

1 Answer

2006 HSE RR....engine pulsates slightly when light acceleration


1. Fuel Pump pressure too low
2. Dirty air or fuel filter
3. Plug wires running parallel for more than 6" )cross em over each other or you get crossfire)
4. Crack in Intake manifold or split end on one of your vacuum lines or vacuum cap plugs

Check 'em out and let me know!

Jan 27, 2009 | 2006 Land Rover Range Rover

1 Answer

Hesitation or stumble during acceleration


take your car for a tune up
if they are carburetor type motors you may need your carbie cleaned and a tune up
if you clean it your self with carbie cleaner it may increase in idle speed this is nothing to worries about it is a simple adjustment
with a carburetor type motor they tend to idle higher when their cold this is the automatic choke kicking in and normally it should happen till the car is a bit warmer and the accelerator has been depresses
although a car should idle at 800 rpm my paddok car dose when it is cold it idles at 1200rpm i like it this way as the car warms up quicker as i will not drive a car while it is cold
hope this helps
ricko

Oct 20, 2008 | 1989 Nissan Pathfinder

Not finding what you are looking for?
1999 Toyota 4Runner Logo

123 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

75817 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8180 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...