Question about 1998 Ford Escort

1 Answer

No power when accelerating, cold cranking,wants to cut off

First of all i replaced all new vacuum hoses fuel filter and tuned it up with new plugs and wires. It is beasty in the am to crank up...plenty of spark though.Then when you get it started..push the gas pedal and it moves in speed like it is bogging down. It has on occasion, like an on/off switch ran just fine, then it is like somone pushes a button and you have to drive with 2 feet or it will die at an intersection or wherever you try to stop...help pls??

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 2 Answers

Replace catalytic converter

Posted on Jan 26, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Is a subaru outback 2002 2.5 engine, hard to start cold and running rough under acceleration stall when push accelerator pedal and sometin]mes die no power. codes P0171 and P0130


Check the following items:
1. good clean air filter?
2. no leaks in the air filter box, cover closed properly?
3. connecting hoses attached to the air box properly?
4. pcv valve working correctly?

1. Change the air filter if you don't recall the last time it was done. I record the mileage on filter with a permanent marker. Put it in a location where its visible with the air box opens. Change the air filter every 2 years or 30000 miles which ever occurs first.

2. Ensure that the two parts are aligned properly and that all the clamps and hoses all fit correctly. A good way to find vacuum leaks is to use vaseline on the ends of any poor fitting hoses. Do one at a time and you can isolate the problem hoses.

3.The two vent hoses that attach the valve covers to both sides of the air box can become loose with age. Adding some screw clamps can solve a small leak. Replace the hoses if they are hard and dried out. Also inspect the throttle body connection part of the air box for loose clamps and fitment.

4.Pcv test is pretty simple. Start the engine, open the oil cap, then hold a piece of paper over the cap. If the pcv is working the engine vacuum should try to suck the paper in. If the vacuum is weak then clean or replace the pcv valve.

If the all the above checks are good then its time to replace the front oxygen sensor.


subaru-outback-2002-2-5-engine-hard-jpexgvk3oxgdbsp4v1qns3bm-4-1.jpg

Dec 18, 2014 | 2002 Subaru Outback

2 Answers

1991 acura legend wil not start every morning (hot or cold days) until i pump it 4 times and turn the key then pump it 3 times and turn the key then it starts then it is fine the rest of the day an night...


WELL I WAS GOING TO SAY REPLACE FUEL FILTER, CLEAN FUEL INJECTORS BY ADDING A CAN SEAFOAM TO 3/4 TO FULL TANK OF GAS.REPLACE SPARK PLUGS AND WIRES. DO A LITTLE TUNE UP SEE IF HELP COLD START CONDITIONS. IF CAR STILL TAKES A LONG TIME TO CRANK. FUEL PUMP FAILING THE CHECK VALVE IN FUEL PUMP IS ALLOWING ALL FUEL LEAK BACK IN THE FUEL TANK.

Jul 05, 2011 | 1991 Acura Legend

1 Answer

My '01 impala 3.4 v-6 flat spots when COLD, at around 20mph. the idle is ruff with random misfires. acceleration is overall poor. when HOT, most symptoms go away leaving only some slight acceleration...


depending on mileage, but possible tune-up could fix it. if already done then check ignition coil pack and ignition wires also spark plugs, check vacuum hoses for leaks or porous, last injectors clogged - use some techron fuel injector cleaner (wal-mart has them). Also get the throttle body and iac valve cleaned by throttle cleaner . Also this other possibilities are to be checked and confirmed.:---- Engine running rough or misfiring can be cause by the following:

1.Defective spark plugs
2.Inadequate spark/coil, defective spark plug wire.
3. Lack of compression
4.False air leakage.
5. Faulty fuel injectors.
6. Insufficient fuel pressure.
7. Contaminated fuel.
8. EGR valve that is leaking.
9. Oxygen sensors.
10. Throttle position sensor.
11. Manifold absolute pressure sensor
12.Mass Airflow Sensor
13.Idle air control valve

--------- This should help.Keep updated.Thanks.Helpmech.

Mar 27, 2011 | 2001 Chevrolet Impala

1 Answer

On acceleration it it misses through 1st 2nd 3rd gear.......runs better when cold... might be egr... disconnected the hose to valve.. still lacks power... put new carb gaskets... thought there might be a...


Sound slike some of the things you mentioned, could likely be causeing the problem. A vaccum leak would steal from the acceleration. also the EGR. You may just need a tune up. New plug, wires, filters, the whole deal.

Nov 20, 2009 | 1983 Ford Ranger

2 Answers

01 ford ranger 4x4 4.0V6-- rough idle like it wants to cut off. loses power or studders under acceleration. struggles to get up to 55 or 60


I agree. Try replacing the spark plugs, install new spark plug wires, change the air filter, change the fuel filter, and test the battery and alternator. Run a bottle of fuel system cleaner and water remover through it. To replace the spark plugs you'll most likely have to go through the wheel wells cause of their hard accessibility from the top. The fuel filter is located on the inside of the frame on the driver's side. Hope this helps. God bless

Oct 22, 2009 | 2000 Ford Ranger SuperCab

2 Answers

Hesitation on acceleration


Try giving it a tune up. It could be a faulty plug wire, spark plug, clogged air filter or clogged fuel filter.
Other possibities could include bad gasoline or a clogged fuel injector. If the tune up doesn't try adding fuel injector cleaner and octane boost to the gas.

Jul 13, 2009 | 2002 Volkswagen Passat

2 Answers

My son's gmc 4.3l hesitates upon acceleration. I have checked the coil, fuel pressure, replace the air charge sensor, new fuel filter, new air filter, new 100k spark plugs, cleaned the egr, checked the...


do you have any check engine lights on? If you do, that is the first thing I would have checked. It does sound like plugged EGR, vacuum leak, or bad TPS

May 15, 2009 | 1996 GMC Sonoma

2 Answers

Stumbles on acceleration


Well, I would replace the air filter, make sure the air hose from the air filter to the intake is not kinked or blocked and check for vacuum leaks. If these are all fine, I would check the fuel pressure as it is possible the pump is weak and not supplying enough fuel.

May 14, 2009 | 1996 Volkswagen Jetta

1 Answer

Nissan Stanza 1986 car bucks and cuts out when accelerating


I would check the vacuum advance. or maybe an O2 sensor

Feb 19, 2009 | 1985 Nissan Stanza

Not finding what you are looking for?
1998 Ford Escort Logo

Related Topics:

83 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

64034 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21990 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...