Question about Volkswagen Polo

1 Answer

I have a 2003 polo classic 1.6. We had it serviced a month ago and had repairs done to our sump. Not even a week later we had a break down.The mechanic had broken one of the water pipes and had just glued it back together.He then "repaired it again" and aparently removed the thermostat as it was "broken"a month later we are having more problems with our car loosing alot of water. The fan does not seem to come on like it is suposed to either.Sometimes Days it works other days not at all. We had no problems with the water until this mechanic worked on our car. Any insight on what the problem might be would be greatly appreciated.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Volkswagen Master
  • 42,084 Answers

The problem is the "mechanic " you used
take it to an accredited service center and get an inspection done and a quote for proper repairs

Posted on Apr 06, 2017

5 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

chiquititas
  • 1010 Answers

SOURCE: VW Polo Classic 1.6 Radiator fan not going on

Try moving the fan blades by hand to see if the fan spins freely to see if the problem is frozen bearings in the fan motor. Replace the fan motor if it doesn't turn. If it spins freely disconnect the wires and hook the fan directly to the battery using a jumper. If it runs the problem is most likely the thermostatic switch. If it doesn't the fan motor is bad.

Posted on Jul 03, 2008

  • 350 Answers

SOURCE: Engine Warning light on rover 75

hi after reading your problem i gather the water pump blew you lost water the car overheated you say it had a brand new cylinder head and the cars still losing water and causing it to overheat and the garage say its the same problem as before yet they won,t do the job because it needs a bottom end ;engine block] so why when they had the head off was this not checked for level and signs of cracking . to be fair to the garage it something that is often overlooked . but that said if this is the problem that occured after three days of buying you are entitled to have the work gaurenteed for 12 months unless otherwise stated i can see there warrenty company won,t want to pay for it as they already paid the garage to do the job [CORRECTLY] the garage had no right to sell a faulty car in the first place and secondly they have been paid by your warrenty company to repair it it is not the warrentys companys fault the garage didnt do what was required in the first place but its not yours either so i would read what your warrenty agreement is and see if it states they won,t pay twice for the same job if not phone them up tell them the only reason you bought the car is because of the warrenty and it is not your fault the job was done properly in the first place and expect the car to be repaired as it should have been in the first place and its up to them and the garage to decide which one of them pays tell them what the garage mechanic said about its allright to drive and i have no idea what book tells you to ignore warning lights but should be shot then go to the garage tell them you want it putting right and you don,t care wheather its under warrenty or the garages oblgation not sell defective vechicles it is up to the garage to put it right or give you your money back if the problem arises within a reasonable amount of time usually seven days tell them to put it in writing if they refuse to do the job if they refuse get a wittness to this and tell them it needs puting right and will be taking to another garage getting it repaired and am giving you the first chance to repair it as stated in law then the bill will forwarded to them an have you took finance out on it or did you pay cash if finance phone them up tell them the problems your having and are going to stop payments until the car is fixed REMEMBER THE GARAGE DEPENDS ON THE FINANCE AND WARRENTY COMPANYS THEY WILL NOT WANT TROUBLE FROM THEM BECAUSE THEY WITH DRAW THERE BACKING THE GARAGE WON,T SELL THER CARS HENCE OUT OF WORK i bet your a newcastle supporter as well with this kind of luck if you let them get away with it your as daft as a brush find out where to report the garage i think it is the office of fair trading and if they won,t bend i will be amazed yates210456

Posted on Oct 02, 2008

  • 180 Answers

SOURCE: had breaks repaired and a

I recommend finding a qualified garage to make the repairs.

Posted on Nov 28, 2010

  • 198 Answers

SOURCE: My car has 2 problems.

You need to go to a differant mechanic sounds like he has no idea what he is doing.You should never have to change spark plugs three times in 6 months.But the brake problem is not related to the SEL light and I dont think the installed your brakes properly if the are worn out that fast also.

Posted on Feb 12, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Taking the sump off a 2005 1.6 beetle


cannot say i have done one but the golf and polo come off on the earlier models ,perhaps its a gearbox out and flywheel off job which means its a drop out the bottom the complete unit ,i just do not know sorry

Mar 02, 2012 | 2005 Volkswagen New Beetle

1 Answer

Suddenly, No tail lights, brake lights, turns signal or back up lights At 83000 miles, 6 months ago, replaced head gaskets. 1 week later, service engine soon light came on. Tech said it was an oxygen...


just look for the blackened/burned pin on the rear light plastic connector and sand it down to re-establish a good electrical connection and save yourself $800 big ones on replacing the multiswitch.

Jun 26, 2011 | 1999 Chevrolet Venture

1 Answer

6 months ago, replaced head gaskets. 1 week later, service engine soon light came on. Tech said it was an oxygen sensor. Cleared code. 3 weeks ago, got oil change, replaced headlights and replaced...


CHECK TURN SIGNAL FUSE.IT COULD BE BLOWED OR YOU HAVE FAULTY TURN SIGNAL SWITCH.BECAUSE BACK LIGHTS AND TAIL LIGHTS SHARE SAME CIRCUIT WITH TURN SIGNAL SWITCH.

Jun 26, 2011 | 1999 Chevrolet Venture

1 Answer

I had my rear brakes and rotors replaced at a local shop 2 1/2 months ago. Two weeks ago my rear passenger side tire started to smell like burnt rubber. I brought it to the dealer for a oil change and had...


The shop that did your brakes should repair/replace the caliper. He HAD to install the pads into the caliper & had to remove the caliper to install new rotor. Hold that shop accountable for the repair. And don't take NO for an answer.

Mar 18, 2011 | 2009 Nissan Armada

1 Answer

Just had 200,000 km service now 205. regularly serviced. 2 weeks ago noticed engine heat rising well over half way. pulled over standard procedure. Now 2 weeks later after nursing Suby have taken to...


check the coolant temp sensor , fuses , relay and fan for operation if electric fans
if manual fan replace the viscous fan hub
have a pressure test done on cooling system to check for cracked tanks or other leaks
over 5 years old and never changed the water conditioner (antifreeze/boil concentrate ), consider replacing the radiator

Apr 24, 2017 | 2003 Subaru Forester

1 Answer

I had a transmission flush done 2 weeks ago. 1 week later my \low traction light came on whenever I accelerated from a stop. Now 1 more week later my ABS and TSC lights are on. There is a little shudder as...


First, Iam not a fan of flushing a trans. Owned a trans shop years ago.
You may have caused some solenoid issues, with the clutch material and cooler sediment.
Work on the ABS,TSC issues. Wheel Speed Sensors may be going and just a coincidence, a couple weeks later.
Make sure the fluid is correct for your vehicle and at the correct level.
I pray you didn't go to one of the Quick Lube Franchises.

Aug 03, 2010 | 1999 Pontiac Montana

1 Answer

5 speed first gear only start out it pops into neutral


It sounds like the the clip that holds it in first might have worn out. Back many years ago I had a Triumph Spitfire that would do this. I dropped the tranny and changed it myself, back in the 70's it was a 30 cent part. I don't even want to think about what it would cost to have done in a shop today.

Jul 10, 2009 | 1994 Ford Escort

1 Answer

Polo pulling to the left


get the tracking done (not just the front wheels get the back done aswell)

Jan 29, 2009 | 1999 Volkswagen Golf

6 Answers

VW Polo Classic 1.6 Radiator fan not going on


Try moving the fan blades by hand to see if the fan spins freely to see if the problem is frozen bearings in the fan motor. Replace the fan motor if it doesn't turn. If it spins freely disconnect the wires and hook the fan directly to the battery using a jumper. If it runs the problem is most likely the thermostatic switch. If it doesn't the fan motor is bad.

Jul 03, 2008 | 2002 Volkswagen Jetta TDI

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

27 people viewed this question

Ask a Question

Usually answered in minutes!

Top Volkswagen Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22133 Answers

yadayada
yadayada

Level 3 Expert

75807 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8172 Answers

Are you a Volkswagen Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...