Question about 2003 Ford Escape

1 Answer

Tried to start the engine and before it started, i heard a pop and felt the gas pedal come back to my foot. opened hood and the plastic engine cover was in pieces, anyone ever heard of this. it has

It had a electrical smell, but no fire or smoke. It restarted but the engine sounded like it was racing up and down and like it did not have the manifold attached.

Posted by on

Ad

1 Answer

Why are you telling us or asking whatever your asking,
when it sounds like you know what happened & what
the possible damage is

Have to look it over or have repair shop do so, if your
not into car repairs,& resolve all issues

Posted on Jan 19, 2013

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Mechanic can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Mechanic (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 1 Answer

SOURCE: 2000 Ford Escort ZX2 HELP!!

my girl friends car did the same thing come to find out the timing chain was off

Posted on Nov 29, 2008

  • 94 Answers

SOURCE: engine races hot or cold

It sounds very much like the idle air valve is faulty as I have just had same sort of problem I fitted a new idle air valve and it has cured mine. Unfortunately these idle air valves are not cheap. They are about £70 from ford but you can get them on ebay for about £30 from partsdome

Posted on Apr 18, 2009

emissionwiz
  • 77202 Answers

SOURCE: Smoke from exhaust when decelerating on Ford F-350 Powerstroke

Either valve stem seals are leaking or the turbo oil seal is leaking.

Posted on Apr 29, 2009

honeymokey
  • 3113 Answers

SOURCE: 2001 Ford Focus just started making noises like a

Check belt, idle pulleys and tensioner.

Posted on Jun 17, 2009

  • 40 Answers

SOURCE: Black smoke when i start engine, very rough idle.

sounds like possible a sensor went bad or is loosly connected. O2 sensor??? Also check the air filter. Sounds like whatever it is, is making the truck run rich----that would be the black smoke.


Hope this helps

Posted on Aug 08, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Vibration in engine area felt in gas pedal


Almost sounds like maybe a motor mount issue.

Nov 30, 2013 | 2003 Ford Taurus

1 Answer

When I pushed my clutch in to shift I felt a pop under my foot. After that I couldn't get my truck into gear. And now I can't start my truck.


Look underneath at where the pedal mounts, My bet is the plate that is mounted to the pedal has cracked. Im not saying you should, But i would leave it in place & spot weld it.

Apr 10, 2013 | 1991 Toyota Pickup

1 Answer

My coolant temperature sensor (Cylinder Heat Temperature Sensor) keeps popping out of place.


Are there threads on the sensor ? stripped where it screws into ? Have to have it fixed ,thread repair kit !

May 18, 2017 | 2007 Ford Focus (3 Door) Hatchback

1 Answer

My 1998 dodge caravan won't stay running. starts up but shuts down instantantly or when i take my foot off the gas pedal,


ok i have a 1998 durango with the 5.2L 318 engine. had trouble with a bad cell in my battery. I went out bought an optima red top battery for it 800cca. put it in and had same trouble. No start without putting foot on gas. wouldn't stay running without holding foot on gas. CPU has to relearn it's programming once you unplug it for long periods of time. mine was without power for about 2-3 weeks till i got new battery. Start with this.. first check under air filter make sure a squirrel hasn't made a mess under your air filter and it's clogging the air intake. Then pull off the lid to your injector cover ( the screw down lid coming from the air box ( with air filter in it) to "carb") make sure all your cables move freely. put that all back together and close hood. Start truck with foot slightly on gas pedal to get started. keep it at about 1k to 1500 rpm for about 1-2 minutes. Rev motor to about 2500rpm and let it die out if it will. Get out lock doors with key fob if you have it. if not make sure to lock doors. ( trust me it worked for me) let sit for 5 minutes. come back out and unlock door and relock door 3 times with fob ( if you have it ) or key if you don't have a fob. Then unlock it with the key and enter vehicle. Start truck as before and keep it around 1k to 1500 rpm again for about 30 seconds rev it up and should keep running. Mine did. I think the iac was stuck from sitting and has now since loosened up.
Good luck hope ti works for you.

Jun 05, 2012 | 1998 Dodge Caravan

1 Answer

How to adjust idle on 1998 chevy malibu


This is pretty simple, pop your hood open and look on the left side
with the car is running turn the screw counter clock wise till your rpms reach the 1 mark you will find the screw located in the same metal bar as the foot pedal cable...still cant find it ? pop the hood open and tap the gas pedal till you see the pedal move the cable line to carburetor under your hood it is right above the alternator.

Sometimes the screw gets messed up and you will have to replace the whole screw and crew housing this happens when it sticks there is also a pin that is under the circle wheel part of the idler.

Jan 08, 2012 | Cars & Trucks

1 Answer

I have a 1994 Honda Accord 4 door v6. I have rough idle when in drive and smooth idle when in neutral. Also rough take offs from a stop or slow speeds. If I pump the gas pedal a few time the rough take...


  • does the engine miss? bumps is a rythmic pattern?
  • an engine miss will appear to diminish at higher rpm due to centrifical force.
  • other possible problem broken or flat motor mount.
  • is the idle rough in reverse?
  • if not
  • open hood
  • start engine
  • Left foot on brake (hard)
  • start engine
  • watch engine as you select drive
  • still holding brake with left foot / throttle gas with right foot
  • does engine dramatically move?
  • if so replace motor mount on offending side
  • if not possible engine miss or transmission problems

Jul 10, 2010 | 1994 Honda Accord

2 Answers

I cant get my 99 dodge diesel started after draining water from fule.


air lock maybe need to bleed it or remove filtre fill will clean diesol and refit and prime it

Feb 18, 2010 | 1999 Dodge Ram 2500 4WD

2 Answers

Acceleration is not working


when you press the gas can you hear the engine accelerate if you can then that means it is your transmission if you cant it is your gas cable linkage just snap you can just replace it by removing your engine cover then add a small nut and tie it to the end of your gas linkage strech it in to the plastic arm and you can then use it to take to your mechanic to fix it properly

Oct 26, 2009 | 2003 Saturn VUE

1 Answer

Car tach jumps and cover of air filter blew off.


It sounds like the engine "backfired" and blew the cover off. This and having the tach "jumping" means that the engine timing is erratic. This can be caused by the crankshaft position sensor or the ignition module. It could also be cross firing at the coil pack,if so equipped. Make sure all of the wiring to these components is good.

May 24, 2009 | 2002 Jeep Grand Cherokee

Not finding what you are looking for?
2003 Ford Escape Logo

51 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

77201 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22265 Answers

fordexpert

Level 3 Expert

5579 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...