Question about 1986 Nissan 300ZX

2 Answers

Car not starting

Car starts runs for 5 mins then wont start for six hours.
changed ecu cam sensor 94 300zx

Posted by on

  • hexx01 Mar 06, 2009

    i have the same problem. car starts and i can drive it for about an hour. then i have to wait 3 to 4 hours in order for it to start again. I changed the relay, fuel filter and put fuel injector cleaner. feels as though something is clogged.

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 4 Answers

Mine will run for a while but it dies. then it won't restart. the problem is 99% of the time in the distributor. there is a pickup coil right in the distributor casing. only some heat up and have problems. yours is more then likely faulty. they go for $170 - $250. so go on eBay and you can find a whole distributor for $85, this is very cheap. it is re manufactured and guaranteed. good luck. call Nissan and they will tell you the same diagnostic.

Posted on Jul 03, 2009

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 8 Answers

Check the mass air flow sensor

Posted on Jun 16, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Cam sensor unplugged engine starts


Does not make sense because it is the signal from the cam sensor regarding engine revs that allows the computer to make timing changes, firing plugs, fuel mixture, etc.

And if the car starts without it, it must run for sh**. Might have a bad ECU.

Sep 15, 2016 | Cars & Trucks

1 Answer

1999 toyota corolla wont start


your fuel pump is going out I had the same issues, or check your o2 sensor near you cataletic converter. when this issue was happening to me at first i would be going down the road and the car would just stall, but would start in a few minutes.

Jul 31, 2012 | 1999 Toyota Corolla

1 Answer

My car starts up then runs for ten mins then dies. it will start up after that but wont stay running. then i come back an hour later then she starts right up and drives for ten mins then back to the same...


sounds like a bad cam sensor. have scanned if light on dash is on. if no scanner any auto parts store will scan for free. a bad or failing crank sensor will make vehicle stall out after a few seconds or minutes. if it is bad enough it will not start. because it controls timing.

Aug 19, 2010 | 1990 Mercury Topaz

1 Answer

WONT START WHEN COLD CRANKS FINE. HAS CODE 54 CAM


ok, any obd code means the sensor concerned is not detected by the ecu, or is way out of range of the normal signal the ecu expects. I would therefor check the electrical path between the sensor and the ecu terminals, it may be just a chafed cable or wire.

Jan 14, 2010 | 1997 Dodge Caravan

1 Answer

1993 wrangler starting problems


You have to find out if it has fuel and spark . One or the other is missing at the demise of the engine.

May 07, 2009 | 1993 Jeep Wrangler

1 Answer

Dies and wont restart. 1991 bmw 750il


You have a cam or crank sensor that has gone out.

May 01, 2009 | 1991 BMW 7 Series

2 Answers

1995 Eagle Talon Will not start


check the mass air flow sensor, if this is bad then the ecu wont get a signal and it wont send the right amount of fuel to the cylinders causing a no start condition

Jun 25, 2008 | 1995 Eagle Talon

Not finding what you are looking for?
Cars & Trucks Logo

214 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

yadayada
yadayada

Level 3 Expert

61168 Answers

Phil Lovisek
Phil Lovisek

Level 3 Expert

705 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...